[solved] specific AHCI/SATA-Driver urgent needed (Motherboard Asus B85-PLus)

Hi out there,

I’m looking since days now urgently for a AHCI-/SATA-Driver for my new motherboard Asus B85-Plus (5X Protection). The Problem is, that it is nessesary for an XP (SP3)-System.
There is no way for me with that Computer to change to a higher Windows for several reasons.

Asus offers only Drivers for Win7, Win8… etc.
Anyone out there with an idear?

greetz to all and thanks in advance

@ Creatura:
Welcome at Win-RAID Forum!

The “Universal 32bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by Fernando” should work for your system. You can get it >here<.
You should integrate it into the Windows XP CD according >this< thread.

Good luck!
Dieter (alias Fernando)

Dear Fernando, thank you for trying to help but this MEGAsite makes problems,

first it tell me my Opera is outdated ( I ask myself why they make this problem to theirs, but ok),
I updated Opera (and it is a awful version now) and now I receive only a blank page, I tried all 3 links (even if I only need the 32bit or the Universal), all 3 links same result - blank page

maybe the drivers should be uploaded somewhere to a site, which is not so prissy

greetz to all and to Fernando

Please use the Mirror if MEGA causes problems. These links will lead to Onedrive.

@ Creatura:

Your problems are caused by your browser resp. its settings. The links are fine.

This is surely right, the Problem is my browser (i think so too). But it is now a complete different browser to my known experiences and I set nothing special, I even don’t find anything where to set something explicit. The pure “Setting”-Dialogue in Opera 40 is now primitive and very miserable.
The Mirrorws (I had tried also) tell me different things: SSL-Mistake. My PC don’t accept this certificate (why ever). “I cannot reach onedrive because the site use HSTS” (for whatever that means and whatever in my PC don’t accept this. I didn’t do ANY setting telling so).

Thank you both for your patience with me

Edit: now I tried successless to fix this in the new Opera - is it maybe possible, just sending me this driver via email? it is embarrasing for me begging for this, but after the last 30 mins I think, this is the easiest way

Thank you

@ Creatura:

Why don’t you use another browser like Chrome or Internet Explorer?

The spyware IE I have killed already with nLite on the running system and Chrome… erm… I don’t want to use Chrome. I tried to update Firefox but the new install even don’t open - I guess it is a version for higher Windows-Versions.
In case of emergency maybe I install Chrome but only for one driver to setup so much new stuff on my PC is… not very good. As usual I don#t had any problems with my elder Opera and Firefox-Versions.

Edit: Ok I installed Chrome (v.45.0.2454.85) - same result in MEGA: just a blank page
and the mirror same result as in Firefox: "this is not a secure connection, you cannot reach onedrive because it is using HSTS… etc… ;-(

@ Creatura:

Which OS are you currently running?
This is what I have found >here<:

I’m running XP Pro SP3 - modded by nLite a while ago
But I have some other bad News - a friend which was shortly online picked up the driver for me (Universal Intel RST Drivers+Software Set v11.2.0.1006 mod+signed by Fernando) and I integrated it in nLite but… but… there were a lot of textdrivers in there and I didn’t know which one to choose so I took all (what was surely wrong) - however, it doesn’t work
I tried out to find which kind of SATA-Thing I have on my motherboard and worked myself through the english Users Guide of the B85 PLus but I didn’t find anything specific there which name it.
so all technical informations I can give is:
- Motherboard ASUS B85-Plus
- Processor: Intel Core i5-4400 / 3,1 Ghz LGA1150 boxed
(both are with drivers modded to XP with drivers from the ASUS page of this motherboard - I’m wondering, why they don’t give also a ACHI-driver for XP in addition)

the site is https://www.asus.com/de/support/Download…yu75pVm1nTD/17/
(for me it is particular in german but all important names, explanations etc are still in english)

but now I even don’t find even the ahci driverse there no more for Win7 + - a couple of days age thery were there and they cleaned up some more stuff
I tooked the AHCI from the support cd of the motherboard in case I find an Angel who can modify them for XP but… I don’t really see there a way


thank you Fernando, you tried to help me and this is very kind but I don’t have any Idea what to do now


@ Creatura:

Since your ASUS B85-Plus mainboard has an Intel 8-Series Chipset, the DeviceID of the on-board Intel SATA AHCI Controller probably is DEV_8C02 or DEV_9C02.
So if you want to integrate the “Universal 32bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by Fernando”, you should choose one of them.

ok I’m right now on the way making a new cd with nLite - can I take both versions at once or is this not good? better 2 tries?
I ask, because I don’t have much CD-r’s left - there was a lot of burning in the last days :o) and even on monday I’m far away from the next store were to buy some

It is better to create 2 CDs, each one with the support of a different Intel SATA AHCI Controller.

ok, thank you

ok, DEV_8C02 doesn’t work - if I switch in the UEFI the control from IDE to AHCI it means directly bluescreen right after;

now I try the other one - is it for sure, this is the onliest relevant switch in the UEFI? There are dozends of settings I never saw before because I used all the years the classical BIOS and my english as well as my knowledge is much too overdosed with all this.
It is late now - I go further with the 2nd try as far as I can but maybe I post tomorrow the result.

however, thank you very much Fernando

You have to switch the BIOS setting from IDE to AHCI before you start booting off the OS media.

Dear Fernando
I hope you can help me with a problem I’m having.

A couple of months buy a new PC (GIGABYTE B85M-D2V mother with i3 4150). My idea was to have a dual boot between XP 32 and 64bit W7.

I had no trouble installing W7 64bit. The issue appeared when trying to install XP 32btis. I found that the issue was for the SATA driver, so I tried to modify the BIOS settings to IDE, and the XP installation was successful.

The issue is that you prefer to use the benefits of SATA AHCI settings, so I kept looking and found your forum.

I can tell you is that in W7 64 can read that the driver you used Windows 7 64bit is: “Intel (R) 8 Series / C220 Chipset Family SATA AHCI Controller”.

Before this I consult:
1 - What it is the driver I have to use
2 - How do you recomend installation: a) putting together a CD containing the driver XP with nLite or b) that forces the new driver in XP loaded with BIOS IDE and then modify the BIOS to AHCI SATA?

Thank you very much for your help. Sincerelly,

@ DiegoA:
Jello Diego,
welcome at Win-RAID Forum!

Since there are at least 2 different Controllers with this name, you have to check the HardwareIDs of it:
Right click onto tthe listed Controller and choose the options “Properties” > “Details” > “Property” > “HardwareIDs”.
Important is just the DeviceID of the on-board Intel SATA AHCI Controller. It will be either DEV_8C02 or DEV_9C02. Only one of them is correct and should be used, when you try to get XP running in AHCI mode.

A driver, which definitively will support your Intel 8-Series Chipset system and Windows XP as well, is the “Universal 32bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by Fernando”. You can get it >here<.

I generally recommend to use the method a) according >this< guide.
Nevertheless you can try the other option as well.

Good luck!
Dieter (alias Fernando)

wow - I did this switch thing before install and the PC booted after install without bluescreen - Fernando you are genial (DEV_8C02)

now I just have to remember how to integrate GraphicCard, Chipset etc driver into nLite which are full of Folders, setup.exe’s etc. - I knewed this some years ago but this is too long time ago
and I have to make the final “Acronis”-Test - because this is one of my problems: my Acronis only work on a AHCI-managed HDD

Hello Fernando:
Thank you very much for your soon answer. I´ve checked the Dev_ID and it is DEV_8C02. Now I have to get the driver and test (which I will do in the week because I have to finish a job right now).

You told me that the driver is the "Universal 32bit Intel RST driver AHCI + RAID + mod v11.2.0.1006 signed by Fernando" … in the URL you indicated to me that the latest version of it or else, how can I identify the last?

Again, thank you very much for your help. I´ll comment you of my results.