[SOLVED] Win10 doesnt see Raid10 drives after fresh install

Hi, i have my previous config: Samsung SSD 32 Gb + Raid10 (4 x WDC). It worked perfect. 32 Gb is not enough for Windows to update, so it didnt update it for a year or so. Raid itself was made via raidXpert.

Today i’ve bought new SanDisk 240Gb SSD. I’ve installed fresh Windows 10, and the problem is that it just cant see my Raid.

I’ve found this article: https://social.technet.microsoft.com/For…win10itprosetup
It says, after KB3176493, Windows is using only signed drivers, etc. I’ve installed raidXpert, it works fine (i can access it via http://localhost:25902/, it says AMD Chipset SATA Controller, Driver Version 3.7.1540.43), but freaking Windows is just not showing it!

Are there any known workarounds?

@VeTaL :
1. Where is currently the boot sector of your current system? Did you recently change the location of the boot sector?
2. Did you ever break and recreate the formerly working RAID array?
3. What does the Device Manager show? Are there any yellow marked devices listed?
4. Is “RAID” enabled within the BIOS?

Hi, thanks for fast reply!

1. Nope - it was on the old SSD, and now, i believe its on the new one - because i just replaced SSDs and installed Windows from the USB.
2. Not entirely - sometimes one of the drives fall out from the array, so i’ve maintained that via raidXpert, but i didnt create it from a scratch.
3. Nope, all are fine, but some of them are “default devices”, i’ll attach screenshot soon.
4. Yep, but let me double check it for sure.

I’ll be back with screenshots in 10 minutes.

@Fernando :

3. Device manager: https://image.prntscr.com/image/CzY42NoZS6CbFtPHPW38kg.png
EDIT: Device manager2: https://image.prntscr.com/image/LMOTRQL8S865U8Y88n6fAg.png
Disk manager: https://image.prntscr.com/image/e5zAxd9hTDyv3lrdrDFerw.png
RaidXpert: https://image.prntscr.com/image/6tcr4Px_RPSdbwCS8LBzgQ.png

One of the RAID drives fell off (i’ve plugged both SSDs to transfer the data, so second one went instead of one of the Raid drives - i’ll fix it later).

4. Sata 1-4 are set to RAID.
Sata 5-6 are set to IDE.

PS: i’ve been using “old” SSD with not-updated Win10 10 minutes ago - it worked perfect, so seems no issues with Bios.

Posts: 11101
U have nice amount of the posts :slight_smile:

Just noted, forum breaks the link i provided in the first post.
Somehow, if i try to open it, i’m getting redirected to https://www.microsoft.com/pl-pl/store/b/…_p23_t544_cUA)() which is wrong.
Original link is https://social.technet.microsoft.com/For…win10itprosetup
I can be opened if to google “windows-10-v1607-clean-install-does-not-detect-nvidia-raid-arrays” and pick the topmost link.

@VeTaL :
Thanks for your infos.
Your problem seems to be caused by the altered detection of SCSI devices by the latest Win10 versions and by a faulty AMD RAID driver.
For details please look >here<, where I have explained the rather similar problem with NVIDIA nForce RAID systems.
Since your system drive is outside the RAID array, it should be possible to solve your problem by installing a matching AMD RAID driver, whose INF file has been slightly customized by me.
Please attach the related AMD RAID driver you are currently using (as RAR archive). Then I will try to modify the INF file.

Hi, actually, i’ve found a solution to my problem!

Apparently i have a BizSpark license, so i’ve contacted Microsoft support - it took a while and stuff - but the solution was super easy.

At this screen, Disk0 is shown as foreign, so what i had to do is to right click on it and pick “Import foreign disk” option. More info on it can be found here (if someone else would face this issue): https://technet.microsoft.com/en-us/libr…5(v=ws.11).aspx the paragraph “A dynamic disk’s status is Foreign.”. I was really afraid to do that because of risk to lose all my Raid data (last time Windows tried to “help” automatically, i’ve lost whole Linux partition).

Raid is online for me now, so hopefully no extra job is needed.

Thanks for offering help anyway, i had passed you a bottle of beer via PayPal :wink:

@VeTaL :
Congratulations, that you were able to solve your problem and thanks for the info about how you did it.
This may help other users with a similar issue.

Enjoy your updated Win10!