Specific BIOS modding problems with an ASUS ROG G751-JY notebook

@Fernando

I found a previous post from you :

“You just need to insert the module named “NVMeExpressDxE.ffs”. The other module named “SAMSUNG_M2_DXE.ffs” only supports M.2 connected Samsung SSDs, which do support AHCI (e.g. the SM951 AHCI) and not NVMe” (Link)

Just to clarify the G751JY from factory support Samsung SSD in AHCI (OEM SSD you got is a Samsung XP941 - M.2 PCIe - AHCI). I dont understand why @EthanWalker asked to add an M2 mod.


Lost_N_Bios asked me if I want nVME or M.2 or both of them. I know that it supports M.2 AHCI from factory but once he asked me, I did not want to complicate the subject.


Nope, It is a Samsung SM951 AHCI.


UPDATE:
Installed Windows 8.1 on a Samsung 850 Pro (not M.2 / NVME) + all the drivers / updates.
* Installed the ATK Package
** Couldn’t install the chipset driver
*** Couldn’t install Intel® Collaborative Processor Performance Control Driver
**** Couldn’t install Intel Rapid Storage Technology driver
Never had any problems installing the Chipset driver on Windows 8.1

@EthanWalker

Sorry forgot to mention for my laptop version. 1st time I see drivers install trouble you better revert back to original bios and use your SM951 until they come back online to help.
So you can test your keyboard backlight.

@EthanWalker - my point at “Did you see my post at #” was only in reference to that I specifically mentioned all tools and all versions I tested break the BIOS, and I spent hours figuring out how to do it all properly previously for Svan…
So no need for you to waste your time trying to mod yourself it will break no matter what you do with any tool.

And yes, I know you have this issue now with your KB Backlight, this is due to how you flashed, I’m sorry but I tried to have you do it the correct way first but you wanted to do the easy way instead.
I even tried to talk Svan out of flashing that way too, check his thread and you’ll see, just like in your case, it’s one of the first things I tried to lead you away from doing.

Thanks for confirming it’s not just a Win10 driver issue! This means 100% it’s due to use of AFU + /GAN (overwrote your original NVRAM with bare stock NVRAM)

@Svan - your Ethernet is not working, and it was before? If yes, more issues due to flashing with AFU/GAN then I can only assume, this system must have MAC ID stored in NVRAM as well instead of GbE (which isn’t anything we touched)
Thanks for clarifying about his SSD and this system too, so he doesn’t need M.2 mod at all, I’ll remove it on his fixed BIOS

Since I have FPT dumps from you both (I think), EthanWalker I know you have one posted as I checked it earlier, we can fix all this with FPT
Both of you need to flash your system with your original FPT dumped BIOS, this will put your BIOS back to square one (100% untouched). Then we can unlock the locks I mentioned before, and I make you both new mod BIOS, created from your FPT dumps, and then you FPT program those.
This is the proper way to flash mod BIOS on system that you can use FPT on, AFU is terrible and even more so it’s never great to use old AFU not meant for these systems with additional use of engineering hidden flash mechanisms (/GAN)
/GAN writes 100% what you give it, so if you use stock BIOS you loose all NVRAM, board specifics like serial, UUID etc. FPT does much the same, in a safer manner, and we use it in conjunction with a BIOS created from your dumped BIOS not stock, thus all original NVRAM and board specifics are retained.

As for RST, you need to install whatever version drivers go along with V14 roms, for this info Svan will have to tell you what he’s using or check the RAID Rom / EFI RAID rom threads and see which drivers go with what.

So, to get you back to square one, we are now back to what I originally wanted you to do (See post #4 here), this is the only way unless you want to order a flash programmer (CH341A = $2.60) and SOIC8 test clip with cable ($3.60) to program the BIOS using hardware programming
Same for you Svan - once you unlock those locks let me know and I will remake your mod using your FPT dump instead of stock BIOS

* Edit, you may be able to use your original dump as a source file for AFU w/GAN and use this command (BUT!!! I do suggest against use of AFU and /GAN both, but up to you)
AFU.exe file.bin /N /GAN
Reboot back to DOS >> AFU.exe file.bin /K /GAN
Reboot, check if KB Light working or not, if not >> AFU.exe file.bin /K2 /GAN

If you get errors with all the above, due to the switches (Some versions allow switch w/GAN and some do not), then try this with your stock FPT dumped BIOS and AFU >> AFU.exe file.bin /GAN

Again, I highly suggest you fix all this with FPT instead! But, the above may fix it for you
With FPT, ONLY flash a BIOS region you dumped with FPT. If you do not have one from before, then do NOTHING with FPT for now.
If you have a FPT dump from before, unlock the locks mentioned above (At post #4 now), then reboot and flash your original FPT dump back in

First, dump current messed up BIOS, in case you need to flash it back in due to error (Before any reboots!) >> FPTw.exe -bios -d currentbkup.bin
Then flash in your original BIOS region dumped by FPT before all this >> FPTw.exe -bios -f filename.bin

If you see any red size error stop, do not try to proceed and do not reboot (flash back in your currentbkup.bin made above, after that = safe to reboot if you need to) then show me image of the error so I can see command entered and error all on same screen, and then wait.
FPT will brick you board, please follow along carefully and do only exactly as mentioned, don’t try this or that on your own.

Which "driver" do you mean with "the chipset driver"?
Why and how did you try to install it?
Remarks:
1. Intel chipset devices (except the Intel Management Engine) neither need nor use a driver.
2. Real drivers are *.SYS files. None of the Intel Chipset Device Software Sets contain a real driver.


I’m not looking for the easiest way, I just need a way that I can do, even if it’s a process that takes more time.
The most complicated thing for me is to understand what I have to do or what I’m asked to do.

As an example for you to understand my level of noob: When you say ‘‘flash a BIOS region you dumped with FPT or Write back your Bios region with FPT’’ - I open the FPT and looking for Flash Bios region or Write back Bios region… and when I find that there is only Load/Verify/Dump Bios region: I get stuck.

The only moment of happiness is that I understand what I need to do with the FPT and why is it safer than AFU but
Disabling the locks via grub is something hard to understand for me even following that detailed guide.


If this method is somehow better, safer etc. - I can buy these tools (in case they do not require component soldering).


@Fernando

@EthanWalker :
Your inserted image is not an answer to my questions.
Why did you try to install the Intel Chipset Device Software (did the Device Manager show a "missing driver" yellow flag?), how did you do it and what happened (which message did you get?)?



Without this ‘‘tool’’, the Fn + F1, F2… combinations do not work (even with the installed ATK Pack).
No, I didn’t check the Device Manager.
I ran the installer and clicked 1-2 times on Next to skip de welcome screen and License agreement, than it gave me an error, don’t remember what is said but I can check later.

Trying to install any driver without previously checking the Device Manager for yellow flagged devices is always a mistake.

I suspect, that either no message or the one "The best driver is already running" occured.

@Lost_N_BIOS

Hi, I have only AFUDOS bakcup. I will try the commands you said and report if it fix the keyboard backlight or ethernet . For IRST rom and drivers you can use any version before the branch 15.x.x.x

UPDATE : AFUDOS backup.bin /N /GAN keyboard backlight is back from hell (I disabled Securboot and enabled CSM) Ethernet fixed too. Yahoooo

I wait you are back online don’t want to mess up everything.


I always install almost all the drivers and utilities from vendor’s page. Thank for the remark, I will know from now on.


No, there was something about compatibility but I installed this utility before and I did not have such a problem.



Congratulations! so, the version with the big cup of coffee is oficially excluded.

@EthanWalker - You said grub and setup_var was too difficult for you to use, that is why I had Svan tell you how he flashed.
I prefer, and suggested that you use FPT method instead from the start. This is the best and proper way to do this.

I do understand what you mean about FPT now, since to me load/verify/dump mean nothing when I think of using FPT

First thing you have to do is unlock those two locks in grub using setup_var.
I’ve made a detailed guide for this, if it’s too hard to understand it’s OK, keep reading and ask when you get stuck and I will further advise you or explain it in more detail etc.

Yes, the CH341A + SOIC8 test clip with cable do not require soldering, but are involved and you’d have to follow more guides and use unfamilar software with those too.
Plus, unless you pay more $$ for faster shipping or closer seller, the wait is 3-5 weeks for these items cheap from China ($7 total from China, $12-20 or so locally/faster shipped)

Scratch all that now - seeing Svan was able to fix with AFU you can too. Please take your FPT dump and flash how I originally suggested at post #24 (This reflashes NVRAM only)
AFU.exe filename.bin /N /GAN


@Svan - I think I have a FPT backup from you, or one is posted in your thread, but maybe not? Since your backlight was broken for year or due to physical damage this isn’t going to fix it Ethernet may get fixed, if you use FPT backup as a source file, I am not sure if AFU backup contains this kind of personal data

Thanks for your answer on the drivers to use with RST V14 roms << EthanWalker, see his reply above about RST drivers.
Here is all versions - Intel RST/RSTe Drivers (latest: v17.5.1.1021 WHQL/v6.1.2.1008 WHQL)

Holy cow!! No way! I thought you killed your keyboard backlight with liquid a year ago? Great Ethernet fixed now too.
So all this means EthanWalker can fix his issues now too without having to figure out the grub and FPT stuff, this will be much easier on him! So thank you much!

@Lost_N_BIOS

Yes I was not sure that backlight was broken before I flash the bios . In my previous post I said I have only AFUDOS backup.

On my side I can wait the programmer no emergency if you think it’s better. But I have to check where is the bios chip and this model is a pain to disassembly.

You said “If you do not have FPT backup from before, then do NOTHING with FPT for now” so I don’t know now lol

Greetings.

@Svan - OK, I thought you said for sure it was broken due to spilled liquid on it a year ago. Sorry about the backup confusion, I wasn’t sure, and thought you did FPT backup too on your thread. It’s OK, they both dump BIOS region only, but I’m not sure if AFU does it byte for byte like FPT does.

You already fixed everything, what are you talking about waiting on a programmer to do?
* Edit - I gotcha now, yes, that was for EthanWalker not you, and you already fixed via AFU method I gave above that (I was not sure that would get you guys fixed, that’s why I followed it with FPT info later)

@Lost_N_BIOS

Spi programmer (Flashcat). If I remember on the other post I linked only my modded bios. So I think you did the job on an original factory bios you downloaded. You never ask me to give you a backup I think.

Can you check that the bios you used before modding for me has the ethernet MAC address inside NVRAM ? I can send you in private message the MAC address if needed.

Yes, I’m not sure, all very confusing, and PM’s added into that too, so I’m lost on who gave me what. I do remember you giving me your mod BIOS, and I still have that in your folder too.
You are correct, I used stock BIOS for your mod because you said you’d already been flashing via AFU. And I checked it, and can tell the mod I sent you was built from stock due to stock/empty NVRAM volumes.
MAC address I cannot tell if it’s in this BIOS region, or in GbE until I get a full dump from someone that also gives me their MAC ID. I see GbE used in full dumps I find online, but only placeholder ID’s there, so I cannot tell if that’s done on purpose to remove MAC for sharing or if MAC ID is not stored in GbE on this model.

If your LAN MAC ID is correct now, and it wasn’t before you redid the AFU with /N switch, then it’s possibly in NVRAM or by redoing the NVRAM it fixed something else that allowed it to see your LAN ID properly.
It’s not in Stock NVRAM, or your “mod” NVRAM either, but would be in a AFU Backup if NVRAM is pulled during those AFU Backups and IF it’s in NVRAM on this system. Some Asus it’s in NVRAM, some it’s in a padding file in the BIOS region, others it’s in GbE region which it outside the BIOS region which we’ve been flashing here

@Lost_N_BIOS

If I hex edit the backup can I find the MAC address if i have the numbers ?

Yes, if you have a dump or backup from before all this, best to check that. Search via hex using UEFITool Search
Or give me your MAC ID and a copy of any previous backup before you did any of these AFU /GAN flashes.

Connect a Ethernet cable to your router and test, if it works then it’s in the BIOS (maybe not in the BIOS region though) IPConfig /All from CMD Prompt will give you the LAN MAC ID too
If you see FF:FF:FF:FF:FF:FF or 00:00:00:00:00:00 or 88:88:88:88:87:88 then it’s invalid (later is GbE placeholder - this we’ve not touched with any tools). You can dump this via FPT too, to confirm if your MAC ID is in there, it will be at first 6 bytes in hex >> FPTw.exe -gbe -d gbe.bin

@Lost_N_BIOS

Ok my result : can find ethernet mac address in my original backup (AFUDOS). Nothing in the modded bios you done and same for the backup I did after flash your mod.

Great! So, is your AFU backup 6MB or 8MB? If 8MB, send me a copy so I can see where LAN is kept on this model. You can edit your info out if you want, just tell me exactly what you replace it with so I can find

Thanks! Yes, nothing in what I sent you would have LAN or UUID or serial, all was from stock since you were flashing with AFU.

Backup only required for FPT flashing, since it will write in exactly what you give it, in full, so you cannot write stock with FPT or you loose many important details.
That’s why when you see me mention FPT at first, I say to make a backup and send to me for editing.