Specific BIOS modding problems with an ASUS ROG G751-JY notebook

Hey folks!

I have an old ROG G751-JY notebook (Intel HM87 chipset - Lynx Point) which may not currently support booting from the M.2 NVME.
Some googling makes me believe that I can fix this by modding the BIOS and adding modules that will enable booting from a nVME drive + updating microcodes for i7-4870HQ.

But, unfortunately I don’t trust my crooked hands because I have all the chances of turning my laptop into a brick,
which is why I decided to ask for help here from experienced people.

Is there anyone who can help me ?

Asus ROG G751JY
Bios version: 213
CPU: i7-4870HQ
PCI-E 2.0 x4

Additional info:

Thanks in advance!

EDIT by Fernando: Due to the specific problems, which have not much to do with the topic “How to get full NVMe support for all systems with an AMI UEFI BIOS” I have removed the related posts from the original thread and created a new one within the “BIOS Modding” Sub-Forum".

biosreg.zip (2.31 MB)

Check this post Asus G751JY AS213-Mod_UPD.zip
Microcodes are updated only for version with CPU I7 - 4710HQ
All credits to @Lost_N_BIOS.
May be he will agree to modify it for your CPU. At least you can use this one to install with a NVMe PCIe SSD.
Since EFI and OROM RST are updated to you can use RST Intel drivers at windows prompt.
Personnally I use AFUDOS /GAN to flash I have no experience with FTPw.


I really hope that he will see this post.

Thanks Svan!

You guys all lost me too If someone needs NVME mod, post request and info here, if someone needs some other BIOS modifications please make a thread (Usually)
@EthanWalker - Do you need NVME mod or M.2 Mod, or both (can both be inserted at same time “In general” @Fernando ?)
Additionally, can you write back your BIOS region with FPT?

*Note to anyone editing that BIOS later ( Asus G751JY) - That BIOS is a major pain to edit properly FYI, so I would not advise anyone edit it unless they are highly experience BIOS modder.
A few things may be able to be edited one at a time with certain tools, but be very careful as I found when editing certain things one usually update during a mod, with all available tools, all of them break the BIOS at one point or another during process so special juggle & dance is required (partially discussed here}

Edit - I checked, you need to disable these two locks via grub before you can write back BIOS region with FPT
SMI Lock>>> 0xA2
BIOS Lock >> 0xA3

Rename your .efi file to >> Shellx64.efi

Here is guide on how to use grub and setup_var, you can start at step 6, since I’ve gathered the variblaes for you above
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Well, my laptop boots from a Samsung SM951 AHCI version - It doesn’t support NVME SSD. So, I bought a Samsung 970 Plus nVME and I would like to make it my system drive.

If it is possible to set them both, it is OK.
If it is possible to make any other improvements in BIOS, updating, adding, removing etc. - Even better :smiley:

I feel so dumb now, I have no idea how to do that, never did that before.
My knowledge is limited to installing Windows and working with 3D design software.

Well you either have to do that, or have @Svan send you the flash tool he used and give you the method. Don’t feel dumb, we all have to learn as we go, so you couldn’t know how to do this until you run into it the first time pwink]

Thanks, so you only need NVME Mod, or is this M.2 device? I’m confused about all this since I do not use these items, I mod BIOS as requested by user and since I don’t know for sure and you don’t either we’ll have to wait
Thank you for the specific info, lets wait until Fernando can tell me for sure which mod you need M.2 or NVME or both can be done etc Since BIOS is a pain, with limited space, it may be best, and may be the only option, to do one or the other (M.2 or NVME mod)

Yes, many things are possible, I can update the microcodes and RST like I did for Svan, and I could unlock entire BIOS for you too, all up to you. For that, I’d prefer you make your own thread so I can keep track of everything easier.
If you just want NVME/M.2 mod (+ microcode and RST update), I’ll go ahead and do that here since we’ve been discussing it all anyway and I wont need back-n-forth with you on test BIOS like I might for a full BIOS unlock.


Download last Rufus version (take portable version don’t need to install it)
Insert your USB key and select FreeDOS on Boot selection option then press "START"
Extract joined file and copy it to your USB key
Set in bios to boot only on the USB key ----> If only it’s not working disable Security boot and Enable CSM

Command to save your current bios : AFUDOS name.bin /O
Command to flash modded bios : AFUDOS name.bin /P /B

P = Program Main bios image (For all main modifications in bios mod)
B = Program Boot block (For Microcodes updates in bios mod)

AFUDOS.rar (172 KB)

Thank you for your motivation, buddy.

Fernando said that it is possible to implement both of them, so if it is possible, why not.

My priority is M.2 / NVME -> but if updating microcodes and RST like you did for Svan has its benefits then it would be great if you could help me with that too.
What about Unlocking the entire BIOS, I think there is no need to do that because I do not think I’ll drain much juice from this laptop.

In case if it will make you feel more comfortable, I can create a new thread. I hope that I will not break any rules by creating so many useless threads and unclear requests.

It didn’t boot in UEFI mode, so I did it with CSM enabled.

I agree with you, Fernando… and I also want to say Thank you very much guys for all this guides, instructions, tutorials and help.

BUT, Instead of modifying by repeating the steps and risking turning my laptop into a brick,
I prefer to ask someone to do this modding for me, Someone who KNOWS WHAT HE DOES and not just repeats as the instruction says - having no idea what is going on.

And as no one here is obliged to offer help by losing time in vain - I am ready to pay for the service or donate to the site, as I have already done. Because time is money and a good job should be paid.
It’s much better than modding Bios by myself and then selling my laptop to pieces.

BIOSave.zip (2.31 MB)

@EthanWalker - You’re welcome! I agree with Fernando in many ways, about doing the mod yourself usually and then having someone check before you use, this would be most beneficial for you in order to be able to mod future BIOS for yourself.
However, this BIOS is a real pain, due to volume that you want to insert into, so any mod you did yourself will likely be a broken BIOS (For the NVME Mod part at least) And any increase within the main volume is going to break the BIOS too, so any microcode update or RST update will also break it
So in this instance, for Asus G751JY I suggest don’t waste your time or risk a brick (anyone), ask for someone to mod for you - as mentioned in my warning at post 4716 above

The only way I found around that is a abnormal procedure, after a few hours of trying all possible methods to edit BIOS. It may be a little easier, if you only wanted NVME mod, but still some special method would need to be found for that as well.
This is due to BIOS will break instantly with most all tools used in normal manner. For UBU I tested ucode, removes padding on last ucode module. Additionally for UBU editing, you need to modify the UBU package, edit file, add microcode etc.
So not easy for all user, even if it wasn’t breaking the file. Plus, I don’t think UBU does NVME edit, but even if it did there would be issue.

With other tools like MMTool (all versions and regular/small NVME mod file) or UEFITool as soon as you insert NVME/M.2 module and save the file it’s broken.
This means FIT Broken + Pad inserted at main volume - latter = bricked BIOS, former = CPU microcode not loading properly, not always a brick.

Mainly for Fernando - Now, time spent re-checking to confirm various stock editing methods general users might use, and all the time spent previously on this same BIOS, is why I prefer to do the mod vs check others work, at least in many instances and especially so in ones they’ve already pointed out some issue they’ve seen.
It takes much more time to check a BIOS, find what’s not broken (ie what software/method does work), what’s broken and find the solution to not break it, tell someone how to do it vs do the mod myself
This BIOS in particular is very tricky to edit, and in order to do it safely special changes need to be made to the main BIOS volume (use only one ucode), and modules (several or one large) need removed interim while you do the mods in order to allow it all to fit without creating a pad file, then replaced at or near end of process.
Thanks for your answer on the M.2/NVME module dual insertion. Where is the M.2 (Samsung I guess?) module that people use, I can’t find it on first page Let’s link this as additional file/method on first page somewhere since it’s similar mod

Unlocking BIOS only gives you a lot more settings to tinker with in the BIOS, that’s all up to you as I mentioned before. If that is something you want later, yes, please make another thread.
If you ever did brick your board by your own mod BIOS, you wouldn’t have to sell it for parts, you can save any system with a few tools that cost less than $7 shipped (CH341A flash programmer + SOIC8 test clip w/ cable - let me know if you want links to examples)
I will work on BIOS for you now, please wait patiently if you are reading this now, it may take me some time if I can’t re-use what I edited for Svan as a base

* Edit - @EthanWalker here is final mod


2. oRom RST TRIM Mod
3. NVME + M.2 Mod Insert
4. All microcodes removed in main volume except updated 40661
5. All original microcodes remain in secondary (last) volume >> updated

Flash per how Svan mentioned

After reading all this, I started to love my laptop as it is: old, with no nvme support etc.

I have already tried to mod my BIOS, following this guide:
The only thing I did different is adding NvmExpressDxe_4.ffs instead of mentioned there NvmExpressDxe_3.ffs… and modified the 213 version of Bios, and not 211 version mentioned there.
But in the end I did not decide to flash it, because I didn’t know if the mod was done right.

213nvme.zip (2.32 MB)

OriginalROM.zip (2.31 MB)

Thank you very much for this help and for the explanation.
I will flash the BIOS later, and then I will write here how it went.

@Lost_N_BIOS It just works!
Installed the Windows 10 Pro (UEFI) - everything works as it should BUT,
1 major issue found: the keyboard backlight doesn’t work. (re-flashed the bios 2x)

I decided to try to create a mod, adding only the nvme and m.2 modules. (to see if it will impact somehow the keyboard backlight)
But After saving the mod, a pad-file appears after the User interface section.
Is it safe to remove it ?


Just a small question for my learning : M2 mod = NVMe PCie mod ? Or it’s 2 different mods.

@Fernando - AFUWINGUI give random results especially for flashing (At least on the G751JY). To backup seems working well. But I don’t trust anymore windows application interacting with bios. Even backup I go straight to DOS.

The word "M2 mod" is misleading. What the related authors obviously meant is the insertion of a specific EFI module named "SAMSUNG_M2_DXE", which is required to boot off an M.2 or PCIe connected SSD, which uses the AHCI protocol. It has nothing to with an attached NVMe SSD.

@EthanWalker - no, that is not safe to remove, that is why I said this is very tricky BIOS to edit. If you could simply remove and it be OK that would not be tricky to edit
Did you read my post at 4738?? why waste your time, I laid out all test edits I made and their failures, this is not an easy BIOS to edit without it breaking.

This backlit issue is due to you using /GAN and a stock BIOS, this erases all NVRAM leaving only stock (Due to use of /GAN). This is why I prefer FPT, and one of the reasons I always suggest against /GAN (OR AFU In general)
To @Svan - yes, I dislike AFU for any flashes when it’s not required, and it’s not required here for this model. (Is your backlight working?)
You can put back in your stock NVRAM, if you have a backup of it from any previous dump. Send me that backup, I will replace NVRAM volumes in stock BIOS and send you new mod with special direction to flash NVRAM only
I found your dump at 4711 - let me know if you want to try using AFU again, or if you want to try the method below first.

Or, this can be fixed this way possibly, but may be more difficult for you to do (Post #13) >> [Solved - BIOS Unlock] ASUS VivoBook F510UA/X510UAR
You need to edit the batch file to write “xx” to DD instead of whatever the default is in there (I forget) - xx edit info is pending that is not actual values, need to find full dump with backlight enabled.

Never mind, please wait (ie DO NOTHING, before it gets worse ) I need to find proper full dump from this model, you dump and Svan’s neither one has the normal locations for this possible backlight control, so I need to find full dump to verify/find it’s location.
Or, you can try the NVRAM swap and /GAN flash of NVRAM, but I don’t see the proper variable entry in either of you guys dumps. So it’s either some other entry controlling this, in which case reflash of your NVRAM with your backed up NVRAM will work, or AFU or FPT is dumping all you guys NVRAM.

* Edit - I found two random dumps, neither have expected variables either. Lets wait for Svan to confirm his is working or not, then I’ll make you stock Mod BIOS with your NVRAM added into it, then show you how to reflash that NVRAM only

* Edit 2 - I see here, and elsewhere, this may be a common Win10 issue (along with all it’s other issues) Did you just do a clean install? If yes you need to get all windows updates installed and Asus drivers (especially ATK and any KB ones)

I will continue to look, since Svan didn’t mention this issue I assume for now it may not be related to the BIOS flash.,

This is insane! Yes, I did… I understood that modding Bios is like taking an antibiotic - which destroys the malefic bacteria, but also destroys the other vital components of the body. But the problem is that, well, I can see that my keyboard’s backlight doesn’t work, but there may be any other issues I haven’t yet noticed.

Ok, I will wait.
Thanks buddy for your efforts and time!

Clean Windows 10 Pro installation + Activated (license) + installed the ATK Package latest version, all the drivers from the Asus, all the updates from the Microsoft. - it doesn’t work.

then removed the new ssd and switched to the old one, that has the Windows 10 Pro and all the drivers installed on it, incl. ATK - backlight doesn’t work.

@EthanWalker : @Svan : @Lost_N_BIOS :
Due to the various problems with the modification of this specific BIOS, which haven’t much to do with the topic of the thread “[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS”, I have removed the related posts and created a new thread within the “BIOS Modding” Sub-Forum.
I hope, that this is ok for you, and am sorry, that I have moved some of the contributions the second time.

@EthanWalker :
If you are not satisfied with the chosen topic title, you can change it at any time, because you are now the thread opener.

It’s okay. Thanks for this thread!

@Lost_N_BIOS tagging you, this way you don’t lose the thread

@Lost_N_BIOS - @EthanWalker

Sorry i missed the keyboard backlight part. I didn’t mention it because mine was dead about 1 year ago. I got accident with a big glass of coffee
My ehthernet is dead too but I don’t care never use it (so it’s disabled in bios) and my Blu-Ray DVD Combo is nearly dead too acting like crazy when I insert a disc

I just did a fresh install today with all the drivers (excetp pad, macro, asus mouse : they are bugged). Pressing F4 to increase keyboard backlight like crazy didn’t help
(I saw some youtube videos about replacing the keyboard but seems when you buy it you don’t get the backlight part)

I think it’s shouldn’t be related to bios. Need to test with default bios then you can be sure.

The most important Chipset and ATK driver to test that. And don’t hesitate to press F4 many times and do it in the dark so it will be more easy to see if it’s working.

Jus need to replace ssd with the original one and flash original bios to test If you do that flash bios with EZ Flash inside the bios (more easy and fast)