SSD is not detected in UEFI (Asrock H97m Pro4)

Hello, my new M2 nvme SSD (Samsung 980 Pro), connected via a PCIe adapter card, is not detected in my UEFI or in windows. The PCIe adapter card support PCIe Gen. 2-4. I have updated the UEFI to the newest version and in a few older updates the changelogs contains nvme support. Ive testet both PCIe connectors of my mainboard (Gen 2 and 3). Ive read in different forums, that its not unusual that the ssd is not visible in UEFI entrys except in the system browser. Thats a graphical image of the mainboard, but there its not detected, too. Ive testet a guide from this forum with clover with a nvme dxe file in it. It shows me all other drives as a bootable entry except my new 980 pro SSD.
i cant boot the win setup from a usb stick like in that guide described without a error. But i think the drive is not visible in the setup when its not visible in clover too. Have anybody a idea?

Mainboard: Asrock H97m Pro 4, firmware: 2.30
CPU: Intel xeon 1230v3
PCIe Adapter: Icy Box IB-PCI208-HS

Test it in another motherboard.
Setting the bios as PURE UEFI (CSM OFF, Secure boot Other, later Windows), without any other drives connected to the system, upon UEFI Winx64 OS setup on destination drive, if there is none, the problem could be the adaptor or the drive, if so only way to be sure of hw failure in testing the devices on another motherboard.
If it works on another system, you may be out of luck as the motherboard doesnt like the adaptor or the NVMe.

(Which OS?)

Which Windows version do you use ?

Win 11. Tried a few live linux distros, but there its not dedected too.
Is it possible to detect the PCIe adapter in a UEFI shell, and when there its not visible, the adapter is probably the problem? Or must the UEFI support the nvme driver to be there detectable?
i have no other mainboard to test the adapter card, only realy old computers with intel duo cores.

Latest bios for that Asrock support NVMe, so the issue is other…motherboard slot, pcie adaptor doesnt like the Samsung or vice-versa, thats it, without tests in another motherboard you can debug it more, ensure that the NVMe is well seated in the adapter.

A properly connected NVMe SSD is not always shown by the BIOS, but it should be listed within the “Disks” section of the Windows Device Manager (provided, that the used port/slot supports an NVMe SSD at all).
If you don’t see the NVMe SSD within the Device Manager, either the SSD itself or the used adapter is defectve.

On the 2008 (!) Gigabyte M/B I currently use, my NVMe SSD is not recognized by the BIOS (this is why I use Clover by the way). However, all OSs (Win 10, Win 11, Linux) see the SSD (I only had a problem with Win 7, which I solved by installing the Win 7 NVMe drivers).

So, I can only concur to what others said when replying to you : the problem you face is likely to be caused by a defective NVMe adapter, SSD, or PCIe slot.

If you don’t have another mainboard at your disposal, you’re going to have difficulties to troubleshoot your problem. My suggestions :

If you have purchased the NVMe adapter and/or SSD :

  • from a “physical” merchant, bring them back to him, and ask him to test them on another mainboard.

  • from a merchant on the Internet, it’s more difficult. You may like to approach a PC repair shop if you have one in your vicinity, and ask to test your stuff on their system.

i have heared, that some m2 ssds wont work with some adapter cards.
does anyone know a good adapter card with 8x or better 16x PCIE lanes and is compatible with GEN. 2 on the mainboard and a GEN. 4 M2 SSD?

you only need x4 lanes for NVMe SSD

i’m using a $5 chinese adapter without any issues but some cheaper adapters like mine don’t have gold plating and can oxidize over time in high humidity which has happened to mine but no problems yet.

As Kuri mentioned even a damm chinese pos adaptor can work… now have you bought the NVMe SEC980 Pro new or used? If used have you tested the NVMe in another system, a friend of yours for example.
NVMe will use x4 lanes as mentioned and most of then can support Gen4/Gen3/Gen2

“i have heared, that some m2 ssds wont work with some adapter cards”
Now that’s interesting but also applies to the drive itself, the SEC980 Pro can be the “picky” one and not the adaptor.

With money in your pocket buy as many adaptors as you want… im sure that one will work, over n out, subject not worth any more discussion when the user doesnt make proper hw tests, its 0 or 1 simple.