SSD not as fast as it should be - looking for the bottleneck

Hi guys and hey Fernando,

I recently bought the SanDisk Ultra Plus (…d-datasheet.pdf) to speed up my computer. However, I am only getting around 370MB/s (should be 530MB/s according to the data sheet) when using the benchmarking software crystaldiskmark. I get higher results when connecting the SSD to another computer that I recently built. Therefore, I do not blame the SSD’s firmware or quality but are looking for a potential bottleneck that is limiting me. My first guess is that it is the SATA 6Gb/s ASM1061 controller that is part of my motherboard. I already flashed its firmware to 0.951 (thanks again Fernando for helping me out with that one!) which got me to the 370MB/s that I have now. I also tried to update the drivers, but that caused a BOD so I am currently using the standard windows drivers. My question is whether there is any other possibility that might be holding my SSD back or if there are modified drivers that do not cause a BOD. All relevant info is summed up in the attached picture.

If you have any ideas please let me know! :slight_smile:




@ greeny18:

I suspect, that it is the ASMedia SATA AHCI Controller, which is responsable for the unsufficient performance of your SSD.
It is well known, that even an Intel SATA2 (3G) port of an Intel system may be faster than any ASMedia SATA3 (6G) port.

I guess there is no other way then than upgrading to a new mainboard? :S

Probably yes, if you want real SATA3 speeds.

Have you tried to switch off to the Intel SATA port? I don’t know how old is your mobo, actually what mobo do you have. Does it support 6g/s ?
Another solution is to put two SSD into RAID-0 on the Intel port like I recently did. Mine is x58 board so only support 3g.s. This forum has good info on how to enable the TRIM for it. I think the write speed is reported high because of enabling the write cache. But overall I feel it is faster and also booting is faster once I don’t need the Marvell port.

D on RAID 0- 1-22-2015 5-02-29 PM.png

According to his benchmark picture he has an ASRock 980DE3/U3S3 mainboard, which is an AMD chipset one.
This mainboard has 6 AMD SATA2 ports and 2 ASMedia SATA3 ports.

his cpu is 6 years old and he has only 4Go of ram + win8.1…
he should be happy of the 370 Mb/s , with a so old board go back to win7 x86 or x64 or xp x86 or x64 : at least the one that support drivers from amd and asmedia .
it will be better than ms driver

Are you saying that SSD may perform better using Win7 and that my CPU as well as my ram are a potential bottleneck as well? Also I tried to use the latest drivers from asmedia but those caused a bluescreen…

your results are good , above poster with 2 ssds has only 300 Mo per drive .
with 4 Go of ram ,you should use a light windows like 7 is , and in 32 bit version .
there are some patch to use the zone above the third Go…-windows-7-sp1/
[or go 8 Go and a x64 win7]

Windows 8.1 x64 with 4GB RAM is just fine. There will be no difference with Windows 7 and especially by installing x86 OS and then using tricks (useless tricks) to show 4GB of RAM. Obviously, he needs x64 OS. Either way, that’s irrelevant to the problem.

x64 is two os running at the same time : 2x 2Go
x64 let use the whole 4Go minus rom

x86 only gives 3 Go without the patch that comes with sources [ that makes 700 or 800 Mo free ram for free ]
with x86 4Go he plays without pagefile and all in ram …if he has more ram and a x86 os windows , may be he could use asrock tools ramdisk that grab ram after 4 Go
i think its xfast ram :…ed-with-xp941/3

plus he will find some vista or 7 drivers while they do not install with x64

may be 8.1 but i would go 7 that is having same qualities and is lighter plus more used [ like xp ]