SSD+Raid5 with Intel & Asus MB Z87-Pro : Best Optimisation ?

Hello Fernando;
First thank you for your work! After long consultation on internet, it seems you are the best person understanding configuration with SSD & raid partitions at the same time. 
I try to find information relative to my configuration on your site but I still have different questions about my configuration.

My current System:
Mainboard: ASUS Z87-PRO, Disks: 1To Samsung 840 EVO SSD (OS HD) + 4 TB WD SATA3 HDD running in RAID 5 mode, Graphics: Gigabyte NVIDIA GeFore GTX 780 Ti, RAM: 8x2 GB Corsair VLP DDR3 @ 1600MHz, OS: Windows7 Ultimate x64

About the mainboard: It has 2 controllers for storage:
Intel® Z87 chipset : 6 x SATA 6Gb/s-Schnittstellen, yellow - Unterstützen RAID 0, 1, 5, 10 , Supports Intel® Dynamic Storage Accelerator, Intel® Smart Response Technology, Intel® Rapid Start Technology, Intel® Smart Connect Technology
ASMedia® ASM1061 controller : 2 x SATA 6Gb/s-Schnittstellen, dark brown (These SATA ports are for data hard drivers only. ATAPI devices are not supported)

About the HDs: Right now my HDs are connected as the shop did it: Everything is on the Intel Z87 chipset:
- SATA 1 : Samsung SSD
- SATA 2 : Blue ray player
- SATA 3 : N/A
- SATA 4-5-6 : Western Digital Red 4To 1-2-3

About software’s: (Installed from CD of the mainboard & Samsung SSD)
- Samsung Magician 4.3 tells me that my SSD are not in AHCI Mode & SATA information are impossible to track : after some research, it seem normal, this application seem not working properly when the BIOS SATA configuration is set to “RAID”
- Intel Rapid Storage V12.8.0.1016 : Tells me that the Samsung SSD are connected on SATA 6Gbits/s

About the Device manager : IDE ATA/ATAPI Controller :
- Asmedia 106x SATA Controller V.1.3.4.1
- ATA Channel 0
- ATA Channel 1

Test I made: I try to connect the Samsung SSD on SATA 1 ASMedia® ASM1061 controller: it’s not discovered => no boot. I don’t know how to “activate” this SATA ports (don’t find anything on the BIOS…)

Here are my questions :
1st: How I could be sure my SSD working on AHCI mode?
2nd: For you, what is the best? (Seem I have the choice): put everything on the 6*SATA Z87 as now or separate & put the SSD on the ASMedia controller ? (If I success to do it)?
3rd: In the actual configuration, even if all the HD are on Intel Z87 chipset: the used driver (on the device manager) are “Asmedia 106x SATA Controller” V.1.3.4.1
- Is it normal?
- And in this case, will I gate best result if I install the 64bit Win8Win7Vista ASMedia 106x SATA3 AHCI driver v2.0.8.0 WHQL? or it will be better to put the Universal 64bit Intel RST AHCI & RAID driver v11.2.0.1006 mod by Fernando as you suggest ?

I hope my questions make sense for you & I really hope you could help me optimise this new configuration.

@ Sebastelf:
Welcome at Win-RAID Forum!

Here are my answers:

  1. If you want to run your SSD in AHCI mode and get the best possible performsance, you should connect it to the first Intel SATA3 port and set the Intel SATA Controller to “AHCI” within the BIOS.
  2. This is what I would do:
    • Backup your RAID5 array data and your important system drive data.
    • Break the RAID5 array.
    • Set the Intel SATA Controller to “AHCI” mode.
    • Do a clean install of the OS onto the SSD.
    • Restore your data on your 3 HDDs.
  3. As long as your Intel SATA Controller has been set to “RAID” mode, all drives, which are connected with Intel SATA ports, are controlled by the Intel SATA RAID Controller, which is listed within the “Storage Controller” section of the Device Manager, and the related Intel RAID driver. The ASMedia AHCI driver has nothing to do with all these drives.
    You can not choose between the Intel RST(e) and an ASMedia AHCI/RAID driver unless you change the related SATA port connections.
    Since the Intel SATA3 ports will give the connected drives a far better performance than the ASMedia ones, I would only use the ASMedia ports as reserve ones (when all Intel 6 ports are occupied and you want to connect another drive.
    If you follow my advice, I would install the newest available Intel RST(e) driver v12.9.3.1000 WHQL or 13.0.3.1001 WHQL and not the Intel RST driver v11.2.0.1006, which is only the best choice for an Intel RAID array.

Regards
Fernando

Thank you for your very quick answer !
I understand that I will have the best optimisation with all HD in AHCI Mode.
But if I want to keep the 3 HD WD in raid 5 ?
I read it’s possible to run AHCI with raid on the same controller but it is the best way to do ? And if yes, did I do it well ? (I’m not even sure the SSD are right now in AHCI mode).
Regards;

If you want to keep the Intel RAID5 array, you should not change your current HDD/SSD configuration and the SATA mode of the Intel ports.

Even when the SATA Controller is running in "RAID" mode, some AHCI features like NCQ and hotplugging may be available.

It is definitively not running in AHCI mode, because the Intel SATA Controller has been set to "RAID".

Ok, after different check, I finally will install the discs as you suggest :
BIOS : AHCI Mode & I will put the 64bit Intel RSTe AHCI & RAID drivers v13.0.3.1001 WHQL.

I have 2 mores questions :
1- You tell me too do a clean install of the OS onto the SSD : Is that really necessary ? I already beak the raid & reconfigure the HD : everything seem ok. (Even Samsung Magician tell me it’s ok).
2- As I read in the drivers parts : without raid configuration, the RST software is not longer necessary : only the drivers are. As you strongly suggest, I will uninstall it before put the new drivers v13.0.3.1001 WHQL.
My question could seem stupid but I prefer ask before making stupid thing (& sorry, maybe it’s on the forum, but I didn’t find it) : how I install the drivers ? There is no .exe : I go to the device manager and I change manually the Serial ATA AHCI controller ?
Kind regards.

It is not really necessary, but I generally recommend to do a fresh OS installation after having changed the SATA mode of the system drive (in your case from RAID to AHCI).

This would be a good idea.

Yes! Just right click onto the listed Intel Serial ATA AHCI Controller (you may check the HardwareIDs of it to be sure, that it is the Intel and not the ASMedia AHCI Controller), choose the option "Update Driver Software" > "Browse my Computer" and navigate to the iaAHCIC.inf file of the Intel RST(e) driver version you want to get installed.

Hello Fernando, since I made this upgrade (to v13.0.3.1001 WHQL) I have very strange freezes : about every 1 to 3 minutes, for usually 5 to 10 sec, they are 2 to 5 freezes.
What ever I do : working, playing, watching DVD or even doing nothing. It seem like the PC try to access some place he didn’t find.
I’m not even sure it came from this point or from something else…
Have you already experience that kind of trouble ? If not, I’m goind to search somewhere else.

@ Sebastelf:

No, I don’t have any experience with the troubles you have described. Although I don’t know the reason for your issues, I doubt, that they directly are caused by the in use Intel RST(e) driver.

Questions:

  1. Are you now running all your storage drives in AHCI mode?
  2. If yes, have you already tried to run temporarily the generic MS AHCI driver (can easily been changed from within the Device Manager)?
  3. Does the Device Manager show any yellow marks?
  4. Have you done a look into the event manager of the OS? If yes, which errors are there listed?
  5. Did you overclock anything within the BIOS?
  6. Have you checked your memory sticks?

Hello Fernando;
Sorry for my late answer. New baby at home give me some more work :wink:
Here my answers :
1.Are you now running all your storage drives in AHCI mode? Yes
2.If yes, have you already tried to run temporarily the generic MS AHCI driver (can easily been changed from within the Device Manager)? : Not yet, but I will try later this option if still go wrong.
3.Does the Device Manager show any yellow marks? : no
4.Have you done a look into the event manager of the OS? If yes, which errors are there listed?
Somes Errors are listed but nothing corresponding at the time of the trouble… : I will try to check that after.
5.Did you overclock anything within the BIOS? : Not with the Bios but I used Asus 4-Way Optimisation since my last message : it uprgrade the CPU by 17% (and mybe made other thing) : Now the pb appears less frequently : every 10-15 min : I think the problem came from somthing I touch in the bios… : Next step : I will try to put the default bios to see if changing something. (I Hope it’s not the BIOS itself that I have upgrade recently (BiosZ87-PRO-ASUS-1802).
6.Have you checked your memory sticks? : Yes (memtest) : good.

This excuses everything - congratulations for having enlarged your family! I hope, that you all (incl. the baby) are fine.

Thanks for your interim report.
When you have the needed time for further tests, please post the results.