Stuck Windows7 at disk.sys in safe mode

I patched a Windows 7 image to use samsung NVMe drivers and usb3.0 drivers for my amd motherboard, but when I try to boot it gets stuck at the Windows logo incomplete (in safe mode it gets stuck at disk.sys). I tried using the microsoft hotfix for NVMe disks, but to no luck. I used them with UEFI and CSM (in CSM I have the same problems but it throws an error that my computer is not fully ACPI compliant)… In UEFI I also tried using UefiSeven, but still no luck.

Notice: I only have usb 3.0 ports so this is why I felt that usb 3.0 drivers were necessary in my case and I use a laptop.
Notice2: If I remove disk.sys, the system gets stuck at fvevol.sys and If I remove that the system just errors out.

Welcome to the Win-RAID Forum!
Here are my advices:

  1. If you want to use the MS NVMe Hotfixes for the Win7 installation, you have to integrate them into the boot.wim and install.wim as Hotfixes (not as driver).
  2. You can avoid the USB driver problems by booting off a DVD, but this requires an optical drive.

Good luck!
Dieter (alias Fernando)


  1. Well, I tried integrating the updates (as updates), but it did not work, the ssd that I currentry use in my laptop is a samsung 980 pro (upgraded the old ssd from my laptop) and when they did not work I tried integrating the ssd drivers and no success (still). Well, yesterday I tried running the setup.exe, which required another (signed) ssd driver, which did not work when slipstreamed (only loaded from the installer itself-name of required driver: [Community NVMe Storport Miniport]). When asked to boot into windows 7 setup (from ssd) it still got stuck at disk.sys which I tried to remove, but got stuck at fvevol.sys which remove actually gave me an error (normally). In safe mode I saw the nvme driver load…

  2. I saw the usb 3.0 problem (from the time I was booting the rest of the setup from ssd), that this is not a problem.

3.So wathever I do, I get stuck at some point at disk.sys during boot.

What means “didn’t work”? What happened resp. which message did you get at which situation?
Did you integrate the Hotfixes into both Win7 Images (boot.wim and install.wim)?

1.I got a message that I am missing [Community NVMe Storport Miniport] driver, when running the setup.exe file from my current windows install (even if I slipstream the correct driver), the only way to get further is to load the driver and when entering part 2 of setup I get stuck at disk.sys.
2.Even when I integrate the nvme patched/drivers to both win7 images, I still get stuck at disk.sys.


And what happens, when you try to install Win10 or Win11 onto the same NVMe SSD?

It just works.

If you want to install an outdated OS like Win7 onto a Samsung NVMe disk drive, you may better use an SSD, which is natively supported by the latest Samsung NVMe driver.

Yeah, the problem with that is that in my laptop I can’t put a SSD. I tought of that, but it isn’t possible.


If Windows 7 Setup halts at boot time when displaying OS logo, then you need to apply the patch for Windows 7 UEFI loader.

Windows 7 builtin drivers (VGA.SYS and VIDEOPRT.SYS) assume that VGA BIOS (INT 10H) is universally available, but this is no longer the case on modern computers with pure UEFI firmware (without CSM).

Patch for UEFI loader provides emulation of VGA BIOS (INT 10H) over UEFI GOP framebuffer, thus enabling installation of Windows 7 to the modern computers without CSM.

Also, without this patch, Windows 7 just freezes instead of displaying BSoD (blue screen of death) on the modern computers where VGA-compatible hardware is not available (Windows 7 can’t switch to classic 640x480x4bpp VGA mode in order to display BSoD). With this patch, Windows 7 is able to display BSoD over the UEFI GOP framebuffer, if necessary.

there is also a packed .iso with seabass bios for booting straight VHD via uefi but may work for your purpose
there is a way to highjack win10 install usb but it needs the config file converted
I had a fatal error using pure samsung dr for 980 made possible by @fernando as official download at the time and still never had 980 ver plus no .inf but the guru himself saved another day(even though fatal error not driver fault)its also about potential fake csm some laptops have that needs a patch for as well-flashboot pro does it all except the seabass mod
that Ill dig it up if interested-flashboot pro is cool as it will make a clone of your current perfect install (win10 or win7)into a bootable usb installer or win2go with current programs installed-I needed a few more add on-flashbootpro website has good explanation why it is-I may add a newer gop to bios if i can figure out one thats compat
also never remove .sys files or any files if they hang, maybe switch them out

good luck!


Well, I’ve tried before and tried now uefi seven, but to no success (unfortunately). It still gets stuck at boot time.

Note: If I run it in csm mode it just blurscreens that my computer is not fully ACPI compliant and I don’t know why…

I give up, because there is no driver for my proccessor with integrated graphics (AMD Ryzen™ 5 3500U with Radeon™ Vega Mobile Gfx × 8)… So it is not worth it and if I had driver I just could slipstreamed them in the iso and remove the vga driver.