Stuck with Samsung 970evo and Asus Z170k

Hi everyone, I’m totaly stuck with this new (and first SSD) for 2 weeks now !

My M.2 is only detected by the bios when I put “auto” (so not "M.2) in “on board configuration”.
And the M.2, in both cases, is never detected during the windows installation (or in W10 when I boot with my current HDD).
I’ve also tried to remove my pciex GC, and pciex wifi card, but it doesn’t change anything…
The bios is updated. So I can’t understand what’s wrong.
And I’ve tried almost every combinasion in the bios (csm/no csm/ legacy)… maybe I’ve missed something…

If somebody could help me, it would be really appriciated :confused: :slight_smile:

@sentryman :
Welcome to the Win-RAID Forum!
Maybe the SATA port, where your current system drive is connected, is using the same lanes as the on-board M.2 port.
My advice: Put the SATA data cable of your system drive into another SATA port and check, what happens afterwards.
Dieter (alias Fernando)

Nope it doesn’t work, no SATA port were plugged… I’ve tried to replug my had with w10 on it in an other port, but it doesn’t change anything…

Maybe SSD is faulty? Connect it as a secondary device, boot to windows and install NVME drivers and see if it shows up in device manager or not.

I will try the SSD on a friend’s Motherboard which has 2 M.2 ports…

I’ve tried my ssd on a Aorus Z370, the ssd is only seen in the menu where you can force the boot, almost the same as my MB
After starting W10 on the other m2 on this motherboard, nothing is displayed in the storage menu, and nothing in « unalocated »
In the device manager, and after installing the Samsung nvme, the ssd « Samsung 970 evo » is shown. But still nothing in storage manger …

The ssd is faulty ? Or what ? I’ve missed something ?

Can you format it in diskpart?

Open Command prompt, then type each command one by one

List disk
Select disk *Choose the SSD, be 100% sure it’s correct drive you wanted, by size or name etc
Create partition primary align=1024
Format quick FS=NTFS

After that, can you now see it in disk management?

thank you for you answer, but the disk is not shown either in diskpart… :frowning:

Btw, the ssd is shown in "override boot" in the bios, that can help ?

So to be clear if you use disk start > type diskmgmt.msc > <enter> it is not asking you to initialise the disk?

The drive might be locked due to powerloss you can fix this with powercycling.
Power up into bios leave the drive for 20 min.
Shut down with power button then switch off power supply or pull cable.
Wait 30 seconds.
Power up into bios wait for 20 min.
Shut down with power button then switch off power supply or pull cable.
Wait 30 seconds.
Power up into bios wait for 20 min.
Shut down with power button then switch off power supply or pull cable.

After this power up into windows 10 (setup) without any other drive connected and see if the drive is visible.

Nope nothing asked in dismgmt.msc (it was the same, when tried on the aorus MB)

okay thanks for the power tip ! I will try that !

unfortunatly it didn’t work… :frowning:
I’ve send a mail to samsung… will see

Do you think I should return the product to amazon instead of searching ?
(and Asking for the same one)

When I put in the bios in on board configuration , the auto option instead of m2, I see « Samsung nvme driver » in the device manager in w10… when I put m2, I don’t see it…
It was same with my friend’s Z370 MB, when I tried…
Should I try again with the power cycling ?
Any ideas ?

Sounds like the drive is bad, you should see it in device manger. What BIOS setting are you changing to see/not see it? If you can see it with auto, leave it on auto.

New 970 received !
And directly recognized by w10 on the usb bootable key…
So it was “just” a faulty ssd…

@sentryman - great your new drive works properly, sorry you had such a hassle with the old one, faulty devices always hard to troubleshoot unless you have another similar to compare with.