Supermicro X9DRi-F / X9DR3-F PCIe Bifurcation

Hello all, long time lurker. Successfully used the very helpful information here to add NVMe support to an older Gigabyte Z68 board, which went flying right out the window when I ended up with 2 different NVMe SSDs with OptionROMs for legacy boot (Plextor M8Pe, Samsung 950 PRO). Thank you all greatly for that!

These two server boards share a firmware - there’s one minor change between the two of them, the Intel SCU ports. It shows PCI-e Bifurcation options in the latest UEFI, which I am certain I have enabled correctly/for the correct slot, I mapped the slot#s to the IOMMU#s using a block diagram I found somewhere, and then double checked in HWInfo. I’ve enabled 4x4x4x4 for one of the 16x slots, and it properly shows up as only supporting 4x after I’ve done so, but no new devices/slots show up, it remains as one under that IOMMU. I installed the ASUS 4x v2 card, and it will only detect the SSD in the first slot.

Any ideas? It’s an Intel C602 motherboard, so I guess it’s closest to the X79 series, which I see several people have successfully enabled bifurcation on.

Here’s what I’ve found for how the slots and PCI-e lanes are mapped and named:


CPU2 Slot6 16x - IOH1 #2

CPU2 Slot5 8x - IOH1 #1

CPU2 Slot4 16x - IOH1 #3 - this is the one I’ve tried to split to 4x4x4x4, all it did was change the maximum supported link speed in the slot to 4x. Nothing changed under PCI Bus in HWiNFO

CPU1 Slot3 8x - IOH0 #3A

CPU1 Slot2 16x - IOH0 #2

CPU1 Slot1 8x - IOH0 #3B, shows as 3C in HWiNFO


PCI-e Lanes/IOH # that aren’t mapped to physical slots

IOH0 #1B - Onboard Intel i350 NIC


IOH0 #1 is split, 4x and 4x. One is a link to the PCH, the other is a link to the onboard NIC.

The UEFI has/shows bifurcation options that are correctly set for the slots that already share an IOH#, like CPU1 Slot1 and 3. They just don’t appear to be doing anything for splitting a single slot.

@sheik124 - Did you set 4x4x4x4 for all the other possible slots, then test? That would be my first move.
Is that slot you are trying x16 electrically? Some x16 slots only have x4 or x8 pins, you’ll have to check up close with a flashlight, or look on back of board to ensure pins are coming through the entire slot.
I say this because you describe it as an X16 slot, but your change only made it x4 max. Also, the terminology used here is confusing, you are trying to change lane width not speed, so be sure you are checking the correct thing (width not speed) in windows when you check.

Thank you. Yeah, the 16x slots on this board are all electrically 16x as well. I can’t exactly remove the board and look at it, but the block diagram has 16 PCI-E lanes going to the physical 16x slots.

I gave up on it, couldn’t get it working and just went back to using one SSD, already sold 1. Anybody want a Hyper M.2 16x V2?

I wanted to reply specifically saying I have PCIe Bifurcation 4x4x4x4 on SLOT4 working perfectly with a Hyper M.2 16x V2

Initially it didn’t work right. Latest BIOS & Firmware flashed to the mobo got them working perfectly. I’m considering trying to bifurcate the other slots too and utterly max it out with NVMe. If I get it working, I’ll report in.

Wow. How?! I had the latest BIOS version as well, and nothing I tried worked.

I just noticed there was a new BIOS released in 2020. That was probably the ticket. I will download it (3.4) and give it a shot next time I need to power this thing down. I know I still have the ASUS v2 card, not sure if I have more than one M.2 SSD that I am not using.