[Support] MSI BIG BANG XPOWER II Bios Nvme Modding

Thank you Fernando for Creating this Guide, its nice to have the possibility to make it work.

I "followed" your Guide still have some doubts about it.

I am not sure where i am suppose to insert the nvme at some point you said…

"Important: Make sure, that the target DXE Volume contains a module named "CSMCORE".

so i was like oh must be in here, (but i must be confusing things here.)


and so jumped to the insertion part of the code and now i have "just pick the last DXE file and insert after it."

so now its in here?


Just for testing the process i did it after the last DXE still need to be sure, did a small video of it cause never been a fan of flashing bios even more modding it, but i really wanted to have this nvme as a boot.

youtu.be/LP7g1vKWxW0 -> just noticed i cant share external links yet so if needed i remove it.

Seems there’s a pad- file that disappeared (stock bios 2.8)


Try using MMTool, looks better (I tried


Please dump/ backup your own bios (FD, GbE, ME, bios region) or at least the bios region before wirting anything modded to the SPI!

You can address Fernando directly by using


Hi lfb6 thanks, you are right the pad dessapears all the time not sure why, i tried MM tool and says "The image is not an Aptio V"

My bios is from MSI board Big Bang Xpower II

not sure how to get it done since the pad dessappears all the time.

Took bios 2.8 from this page:

Can take 2.81 here, too
https://forum-de.msi.com/index.php?topic=104513.10%3Bwap2# and both open all files

On which bios are you working? Stock or dumped own bios? Attach it to your post.

I am using Stock the same you downloaded from https://www.msi.com/Motherboard/support/Big-Bang-XPower-II

My actual bios is E7737IMS V2.8B2, I was thinking on flashing the other bios to E7737IMS V2.8 modded for nvme to work.

Should i be using the one i am using i am not sure if this one is any better then the final from MSi, but i have been using it for a long time maybe i should dump it and use it instead?

Just tested with and it worked.

It depends on the way of upgrading. Normal bios update programs spare regions with machine specific data when updating (NVRAM, serial, mac, …)- it’s OK to work on stock bios when using the normal update procedure. When you have to flash the bios back by programmer or flash programming tool you better work on your own dump since the machine soecific data will get overwritten when flashing a modified stock bios.

Always good to have a backup before flashing a modded bios. You could use ME System Tools v8 r3 - (2017-11-19) from
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

Try dumping the complate chip content
fpt(w(64)) -d SPI.bin

If this gives an error try dumping the regions
fpt(w(64)) -DESC -d FDreg.bin
fpt(w(64)) -GBE -d GbEreg.bin
fpt(w(64)) -ME -d MEreg.bin
fpt(w(64)) -BIOS -d BIOSreg.bin

Downloaded ME System Tools v8 r3 - (2017-11-19) many tools there i think i should use Flash Programming\Windows64\fptw64.exe?
is it safe to start it? any of those tools start doing something right away?

W64 version should work, yes. You need to run it in an administrator- command window. The commands wriiten will start immidiately, but the -d parameter is ‘dump’, means reading.

as soon as i click D closes, "Error 200: Invalid parameter value specified by user. Use -? option to see help."

i runed it as Administrator, tried ? closes immediately.

OPEN command window in corresponding folder, show screendump of windows/result!

Thank you lfb6 i wasn’t really thinking, just executed the exe and from that wasn’t helping since it always closed after hitting a key to show the rest of the list so i used CMD as admin and that way it worked smoothly did the fptw64.exe -d SPI.bin so now i have a bin file.


Yep, take good care of that, that’s a copy of your complete bios for your specific machine/ with all the machine specific data!

Please execute fptw64 -I (same setting- admin windows) and post the result. That will give you some information about the flash descriptor.


OK, you have an unlocked flash descriptor. If there are no protected memory ranges you could flash a complete bios (or bios region) with fpt, too.

If I remember right it worked for you with mmtool to add the nvme dxe to stock bios. Try updating with the tools normally used for updates and you should be good to go!

yes i think now its working as intended still i will recheck the bios if everything is in place, at least the pad now stays there.



I did all of this (dump and check) on my first Bios if i want to use my second Bios for the flash do i need to first switch Bios, Dump it check it and just then Flash it? Or i just need to Switch and flash it.


I usually check the box for insert compressed, but since the whole volume is compressed I’m not sure if that does make any difference, probably not.

As far as I understand these 2 bios are harware chosen by switch. If you use normal MSI bios update procedure, it should be fine to update with the same modified stock bios. Taking a backup of bios 2 before flashing over might be usefull anyway.

I finally flashed it and now i have a Pata showing on the boot hard drive selection not sure if its working or not.

I think i will know after activating UEFI and installed windows in GPT partition.

Hi lfb6, everything worked perfectly.

I remember reading that Pata wasn’t a bad thing but that i had successfully added the nvme support, so i was thinking that after changing it to UEFI and with the Disc in GPT since it was in MBR everything would show as expected.

After bios update I changed my nvme to GPT and used AOMEI Backupper to do a Clone disc, everything worked just fine.

Changed bios to UEFI and boot to Windows boot manager.

Everything is ok so far.

Thank a lot for all the support lfb6, how can i pay you a beer m8.

@Pr1m3 Good work! And thanks for the feedback, you’re very welcome. If you really feel a strong urge to say ‘thank you’: Give the beer to the forum maintainers: page-donation.html