Surface Pro 4 UEFI Problem.


First of all, sorry if my post in not in the right place, and second…sorry for my poor english, i’m Portuguese.

I have a Surface Pro 4 i5 (6300U) with SSD 128G, during a windows update (i think it was the bios firmware) died! After rebooting, it never gave a new image, but the machine stays working.
It was stayed for about 3/4 months until I got the courage to disassemble it, with luck I did not break anything.
I removed the chip and programmed (in RT809F) with a dump that I found on the internet.
The dump is the same as mine taking out the SSD (mine is 128 and dump 256).

What happens:

  • The machine starts, the Surface logo appears and with a red line with the lock unlocked and do not pass from there; sometimes it goes from the logo and the image turns black with only backlight;
  • The machine now takes almost 40 seconds to boot, I do not know if it will be because the battery is dead (this is because I have already tried it and tried to load it out and it does not accept load);
  • I can not get into Bios (POWER + VOL +) or a Windows 10 installation PEN (POWER + VOL-);

Any tips? Is there a machine to rebuild the firmware based on the microsoft website?

@mvisionpt :
Welcome to the Win-RAID Forum!

Unfortunately I cannot help you myself, because I am not an expert regarding your problem.
Hopefully you will get support by someone else.

Good luck!
Dieter (alias Fernando)

But maybe…there is someting you could help.

FIT version could make diference?

EDIT by Fernando: Unneeded fully quoted post removed (to save space)

Not really.
@plutomaniac or @CodeRush are the experts, not me.

You should not flash other SPI dumps unless absolutely necessary as you will loose BIOS-specific info (Serial Numbers etc) and may end up with a non-working Engine firmware. Even on a dump from the same OEM model, you must always follow the Engine CleanUp Guide. The same guide must be followed if you suspect your own dump has corrupt Engine firmware. Can you compress and upload all images that you have (your dump, other dump, official MS update)?

First of all, thanks for your anser.

I attach the dump original, from web and MS.

Thanks for your help!

Firmware MS Update.rar (3.6 MB)

surface_pro4_original_dump.rar (3.79 MB)

surface_pro4_web_dump.rar (2.93 MB)

Ok, I suggest you take your own dump and follow the Engine CleanUp Guide. Flash back the output from the guide with the programmer and see if that fixes everything.

Thanks, I’m trying to make the image and I have some questions:

When I load dump in FIT it gives me the following information in the LOG:

What is the dump of the repository that I should load: or

I was unable to indefinite NPDM and YPDM through ME Analyzer.

Forget! i found it…sorry :slight_smile:

The BIOS Region on Decomp folder only have 10 240 KB, should be like that:

Before compile it give me two warnings:

Thank you.

As can be seen at MEA, your firmware is NPDM. You can choose the latest firmware during cleanup which as of now is for your system.

The BIOS is 10MB in size. That’s totally normal and not small. FIT doesn’t touch the BIOS region at all anyhow.

The first three warnings have to do with certain (now) deprecated settings. The original SPI image was built with a very old FIT v11.0.0.1171 but the current one does not recognize these settings and sets them to current default. That’s ok, you can ignore these during the CleanUp Guide. When the system is back up and running, remember to post a “MEInfo -verbose” result and I may ask you to run a small command to restore these settings from defaults to Intel recommended values.

Those two messages you see when building are normal and verify that the OEM does indeed want them to be set like that. Both of them are permanent and fused to the hardware, that’s why FIT asks again.

Thanks, I’ve done my dump with this Firmware ( and I’ll test it when I get home.

I’ll give you the feedback later! Thank you.

PS: still need to report this new firmware? hehehehehe kinding!

me_11_8_sp4.rar (3.66 MB)

Same result…Surface works, but black screen.

I’m doing something wrong? Or dump can be corrupted on another zone?

I doubt that you did something wrong when following the CleanUp Guide as you seem very thorough and careful, kudos for that. Did you also run a “fptw -greset” after the CSME cleanup? If that doesn’t help as well, we can exclude the CSME firmware as the source of the problem. Which leaves BIOS region only (probably NVRAM). Is the attached image above (me_11_8_sp4.rar) your result of the CleanUp Guide?

"fptw -greset" this is not just to do on Surface when it boots up?

Yes, the attach image is the final dump from CleanUP Guide.

Yes you should do “fptw -greset” only once after you re-flash the cleaned CSME firmware SPI image. If it failed after that too then the problem is BIOS related. What we can test is for you to take your cleaned dump (me_11_8_sp4) and replace its BIOS region with the one from the web dump (surface_pro4_web_dump), which I assume works properly, via UEFITool’s > “Extract/Replace as is…” actions.

Yeah, but this reset I still can not do.

And if instead, I get the web dump, I change the serial number (directly in the code) and make the Clean Region ME with the same version (in this case 11.6).
Because with this dump at least I get the image and with my original nothing.

What you say?

I’ve done your way and my way.

In booth, i got picture and it freeze on Surface logo (button don’t take action) but it now it takes 15 seconds to get picture (before 40s).

More ideias?

I don’t have any other ideas unfortunately but we do know that the BIOS is problematic, not CSME.

Yes and i don’t have any ideia how to rebuild them.

I will try to find more dumps on web, or ask for it.

Thanks for your help!

Exactly, that’s what I would do. Maybe that one web dump is also kind of problematic. The BIOS region is out of my comfort zone, especially when BootGuard is active, so finding other dumps is a relatively easy way to quickly see if something works, albeit with wrong Serial Numbers. I advise you to use your own cleaned CSME dump and switch the BIOS regions only via UEFITool, as I explained previously, to avoid any of the Engine issues that can occur when flashing 3rd party dumps as explained at Section A of the CleanUp Guide. The UEFI from MS is not useful as it seems to consist of parts only, maybe those that get updated but certainly not the entire 10MB region that we seek.

Hi There,

I have a surface pro 4 that had an unknown UEFI Password on it, I opened it up that one and another and extracted everything off the winbond chip and then reprogrammed the chip that had the password on it, this ultimately cleared the password and the machine now boots but something has gone wrong with the intel management engine as it shows the version number in the UEFI as
the machine functions fine except for the touch screen

I am interested to know if my issue is related to this engine cleanup guide that is refered to earlier in this thread, do I need to follow this in order reprogram one chip from another?