Switched from Win10 LTSC to Win10 Pro 1909, can't install OFA or intel RST drivers for SSDs

Built a new system and installed Windows 10 LTSC and was able to use the OFA drivers for my NVME SSDs which gave a great performance boost. Unfortunately I had to switch to Windows 10 Pro because of compatibility issues with some Logitech peripherals (Windows 10 LTSC wouldn’t install Logitech G Hub).

After switching to Windows 10 Pro 1909 I’ve tried updating my SSD drivers and keep getting an error. “The folder you specified doesn’t contain a compatible software driver for your device. If the folder contains a drivers, make sure it is designed to work with Windows for x64-based systems.” These are the same exact files I used on Windows 10 LTSC. I re-downloaded the OFA x64 Windows 10 files, reinstalled the certificate using the cmd file, and I was still getting the errors. I decided to try the Intel RST drivers and again, got the same error. Not sure what’s going on.

Here are my two NVME SSDs

@sinykk :
Welcome to the Win-RAID Forum!

You cannot update or change the driver of any device, which is listed within the "Disks" section of the Device Manager.
If you want to change the in-use NVMe driver, you have to expand the "Storage Controllers" section and to update the driver of the listed NVMe Controller.

Good luck!
Dieter (alias Fernando)

I’m an idiot. I don’t know how I messed that up. I was totally trying to update the drivers for disk drives instead of storage controllers.


@sinykk :
You’re welcome! Everyone can have a blackout sometime.
How satisfied are you with the NVMe drivers from OFA and Intel? Which ones did you try?