The system does not shut down properly and has ME error....need an urgent solution

Hello, guys, this being my first post, I would apologize the post to be lengthy.

Seeking advice from all.

My current situation is this:
I tried to install XP for a reason but a blue screen hardware error warning showed during installation so I stopped the intallation.
Then, gone back to Win 7 again.

1# Suddenly, a black screen came out showing “fixing firmware”. Then a prompt came in blue screen which was asking to load default BIOS setting, which I did.

2# Now, the PC does not shut down completely, only the hard disk, keyboard and mouse. All system fan, CPU fan and PSU never shuts down.
I have cleared CMOS. Then, I loaded F3 version BIOS from gigabyte using Q-Flash.

3# In device manager, there is an error in Intel Management Engine Interface that shows "This device cannot start. (Code 10) A device which does not exist was specified."

4# I have tried with fitc tool, whenever I drag & drop the bios, it shows an error "Flash Image: Unrecognized binary format"

5# So, I tried with ME Verification Utility from Intel which shows

“The Manageability Engine check has encountered an error.
Explanation: The application is trying to communicate with Intel® Manageability Engine firmware, and encountered an error because the Intel® Manageability Engine is disabled or not available.
Suggestion: Verify that the Intel® Manageability Engine is enabled, and communication between application and the Intel® Manageability Engine is working.
Error 9258: Communication error between application and Intel(R) ME module (FW Update client)
Explanation: The Manageability Engine firmware failed to return an application result
Suggestion: Please flash the Intel® Manageability Engine region and unplug power for 6 seconds. For mobile platforms, also remove the battery.
Error 9259: Internal error (Could not determine FW features information)”

6# It takes a lot of time to boot successfully and there is unsuccessful boot as well.

7# My motherboard got 3 chips: Backup bios (MXIC 25L8006E), Main bios (MXIC 25L8006E) and ME bios (MXIC 25L6465E).

MEInfo
Error 9259: Internal error (Could not determine FW features information)
MEManuf
Error 9296: MEManuf Test Failed

How to save the ME bios image to hard drive?
How to cure the ME bios?

Waiting for the kind advices !

Thanks in advance

My system is:
Codename Clarkdale
Specification Intel(R) Core™ i3 CPU 540 @ 3.07GHz Socket 1156 LGA
Memory Size 4 GBytes
Mainboard Model Gigabyte H55M-S2V
Graphics: Intel HD Graphics
BIOS version F3
SAMSUNG HD0103SJ
Capacity 1000 GB
OS Win 7

IMG.jpg

That motherboard has a weird SPI chip configuration. Can you dump, compress and attach the three SPI chip images to look at them?

Looks like it has Descriptor and ME in ME_BIOS and BIOS region in both M(ain)_BIOS or B(ackup)_BIOS selectable by a jumper/switch/GPIO pin. Stupid, but working.

Unfortunately, I don’t have a chip programmer that I can dump the images from these chips ?
Is there any other way ?

Try Flash Programming Tool with “fptw -d spi.bin” command.

Here is the spi.bin and two screen shots of fptw
Have a look inside.
Thanks

spi.zip (3.41 MB)

1.JPG

2.JPG

Here is the fixed SPI image. Use Flash Programming Tool with command “fptw -f spi_fix.bin” followed by “fptw -greset”. After the reboot, check if your problems are gone.

spi_fix.rar (2.87 MB)

now backing up pc, then, will try
thanks a lot

Thanks with millions of hot cakes
The system now shuts down completely.
Just a little problem still remains, the device manager still shows yellow marks with "This device cannot start. (Code 10)"
Is it a problem?
I have uninstalled, then installed the driver but that didn’t work.

Thanks & Regards

The ME firmware should now be healthy. You should update to the latest one using FWUpdate. Maybe that will fix any remaining issues. Then check its status with MEInfo and MEManuf tools, as explained at the ME thread.

I don’t know who are the creators of this forum. Enormous thanks to all of them. Special thanks to plutomaniac for giving the modded bios. You, guys, saved me.

I have never felt so moved by using a site such as this one. I’ve been online for a long time. It’s amazing to me that the folks here come on to help people over and over again, asking nothing in return.

Should I keep the major and minor same or I can jump to any other like 6.0.30.1203 to 6.2.61.3535 for UPD?
Do I need to worry for the different file size ?

I am making sure myself to avoid any failure.
Thanks again

The latest for your system is 6.2.61.3535 5MB Desktop (DT). You can use FWUpdate for the update.

Thanks a lot again for this enormous help that you are doing for us.
Without appreciation and enormous thanks, I don’t have anything to give in return.

Trying "FWUpdLcl.exe -f 6.2.61.3535_5MB_DT_PRD_UPD.bin" warns "Error 8716: Invalid usage"
Do I need FWUpdLcl 64bit ?

Check “FWUpdLcl.exe -?” to see the available commands. I think FWUpdate 6 and earlier did not need -f before the file.

First, I tried
1#
>MEInfoWin

Intel(R) MEInfo Version: 6.2.60.3535
Copyright(C) 2005 - 2011, Intel Corporation. All rights reserved.

PMXUtil: Error during PMX Call: PMxDrv!MAPPHYS - Bad Input Parameters

Error 9258: Communication error between application and Intel(R) ME module (FW U
pdate client)

Error 9259: Internal error (Could not determine FW features information)



2#
>MEManufWin
Intel(R) MEManuf Version: 6.0.40.1214
Copyright(C) 2005 - 2010, Intel Corporation. All rights reserved.

Error 9296: MEManuf Test Failed
Use <VERBOSE> option for more details



3#
Then,I tried this,
>FWUpdLcl.exe ME.bin -generic
Intel (R) Firmware Update Utility Version 6.2.0.1022
Copyright (C) 2007-2011, Intel Corporation. All rights reserved.



Error 8193: Intel (R) ME Interface : Cannot locate ME device driver


The system shuts down but does not restart.
Am i missing something ?

32 bit windows does restart but not the 64 bit. What is the reason behind it ?
Got it, The culprit was windows ME driver reinstalling solved the restart issue.
But the device manager issue still remains.

Even in DOS, fw update does not work,

IMG_20171226_132844.jpg