Thinkbook 14 IIL Bios issue


I have been reading but I don’t seem to find the right answer.

I have a Thinkbook 14 IIL that apparently the BIOS was corrupted as it didn’t display anything when turned on. First, following a guide, I managed to “fix” it with the BIOS dump and some ME Cleaning. The laptop boots up but it had missing serial/UUID/etc.
Then I managed to fix the missing information editing the areas where the information was stored. The laptop now has correct serial number/UUID/windows Key, etc. But the Intel ME is disabled and there was no audio on the laptop.
I had another laptop, same model and did a dump of the BIOS(it had an old BIOS). Used that dump to put the correct information (serial/windows key/etc) and did clean the ME Region. Flashed it using CH341a but after the flash the laptop did not recognized any of the hard drives and there was no option for Storage in BIOS, so I can choose from AHCI or RST.

What am I doing wrong?

I can provide dump from the corrupted laptop and also the dump for the working laptop(2nd one) and if needed the BIOS i have worked on.

Thanks in advance

Do you have a dump from the first Thinkbook in bricked state?

Otherwise please post what you have so that one can have a look.

Did you flash back the complete image or just the ME region?

I flashed back the complete image after following a youtube video to replace BIOS Region and clean ME region.

This is the bricked dump and the file I flashed to recover.

If you need the dump from the working machine let me know.

Recovery BIOS Thinkbook (6.9 MB)
bricked (7.2 MB)

Yes. please post the dump of the third / working machine, too.

Already those 2 images do have a lot of differences in ME configuration:

This is the dump from the working laptop. (7.1 MB)

This is the one I made at first. Without serial numbers, windows key, etc. It did boot and display was working. Also I believe that ME and TPM were working because I could update to Win11.

I am also attaching the same file, but with the serial number, windows key, uuid injected. (6.9 MB) (6.9 MB)

Well, some problems to understand what happened here.

The bricked machine had the same bios version 17 as laptop 2, and the static parts of both bios regions are 100% identical. So error should be in ME or NVRAM?

Then you have a recovery image with a funny ME (AMT enabled for a consumer LP ME ?) and an almost stock bios region- latest version from Lenovo.
Then you put in UUID/SN… and clean the ME with the correct configuration but older version and change the first padding in bios region (EC firmware) back to the older EC from the bricked bios- possibly while copying back the Lenovo data ‘in one’.
In addition the last (?) firmware with cleaned ME is back on bios 15 while the one with UUID and serial and… was on latest (28)

So either there’s an error in cleaning ME, corrupt NVRAM (again?) or the machine isn’t happy with the combination of older EC fw and latest bios region or something completely different happened when assembling/ disassembling.

The easiest option would’ve been to empty the NVRAM for the bricked bios, maybe clean ME in addition (bricked_nvr_ME). Another option would be transfer the machine specific data to a stock latest bios and clean the ME (bricked_nvr_newME_newbios. (6.9 MB) (6.9 MB)

As always no warranty!

Sorry for the late reply. We were in the middle of Hurricane Fiona.

I tried both files and ME is still disabled.

Thank you for your help. I will keep trying whenever I have some free time

Hope you came through Fiona in a good way!

You wrote about no audio and not recognizing the harddisks- does that work now?

Please post the output of MEInfoWin(64).exe -verbose

Yes, we are dealing with power loss and few minor things, thanks.

The hard drives work. I think I messed up when “fixing” the ME region on that BIOS with a lot of differences. Hard drives are working again but sound isn’t.

this is the output:

Intel (R) MEInfo Version:
Copyright (C) 2005 - 2020, Intel Corporation. All rights reserved.

Windows OS Version : 10.0

LPC Device Id: 3482.
Platform: Icelake Platform 
General FW Information
FW Status Register1: 0x80042044
FW Status Register2: 0x3B280116
FW Status Register3: 0x00000020
FW Status Register4: 0x00004000
FW Status Register5: 0x00000000
FW Status Register6: 0x40000000

    CurrentState:                                Disabled
    ManufacturingMode:                           Disabled
    FlashPartition:                              Valid
    OperationalState:                            CM0 with UMA
    InitComplete:                                Initializing
    BUPLoadState:                                Success
    ErrorCode:                                   Disabled
    ModeOfOperation:                             Unsecured mode by H/W jumper
    SPI Flash Log:                               Not Present
    Phase:                                       BringUp
    PhaseStatus:                                 CM0_TEMP_DISABLE
    ME File System Corrupted:                    No
    FPF and ME Config Status:                    Committed

Error 198: ME disabled.

Well, the line

“ModeOfOperation: Unsecured mode by H/W jumper”

isn’t a good sign. The images I did send you both have a cleaned freshly built ME region. Disabling the ME can be done by hardware- a switch or jumper- or by bios.setting, But the NVRAM (where bios/firmware settings are stored) was clean/empty (“stock”) in both firmware images, too.

So there’s only a few possibilities:

  • There does exist a recovery jumper or switch which is set
  • There’s a setting that’s stored in CMOS (not NVRAM)
  • The system didn’t load bios default values properly
  • You didn’t flash the images properly

1.) Search for any recovery jumper or switch you might’ve set in the process
2.) Try to clear the CMOS according to for example:

3.) Load bios default values

(Audio not working might be related to non functional ME)


There is no hardware jumper I can see on the laptop. I have disassembled the laptop and didnt find anything.

I have tried CMOS reset and load factory defaults.

I am using a CH341A to flash the firmware. I have tried using flashrom (linux) and ASProgrammer/NeoProgrammer under windows.

Thank you for your help

Please read the firmware again from the chip so that we get a fresh dump of the actual content. Do it twice, check if both dumps are identical. Attach the dump.

I dumped twice using flashrom. Both files are identical.

Dump attached (6.9 MB)

OK, ME is properly flashed, but untouched, state is still ‘configured’, should be ‘initialized’.

Now you’re on bios version 21?

As written before: One option to disable ME is via bios, so no control here. Since you wrote you flashed both firmwares I attached with stock bios and empty NVRAM this can possibly be excluded, too.

Seems to be hardware then…

Yeah, it appears that no matter what I flashed, it still says configured.

Oh, well. Thanks again for all your efforts. I really appreciate it