ThinkPad X1 Carbon 4th Gen (20FC) ME Missing

Hi! Great to be here.
I’ve spent the last days reading similar issues on the (old) forum before i decided to register and ask for your help.
I have a similar problem to the one in this post. My notebook wasn’t booting, so i took it to a technician and they managed to flash a new Bios, but… now ME is missing, my fan runs like crazy, it takes a long time to boot and to resume from sleep, and my Bluetooth audio is not working. These are all the issues I found so far.
I can’t install ME Software/Firmware. The Device Manager shows me Error 45 on hidden Intel Management Engine. On Bios, ME firmware version is empty.
I would return it to the technician, if i wasn’t in another country.

I am no expert, but i did try to follow some tutorials here. Tried to dump the Bios and re-flash a new ME, but i get an error about needing permissions to unlock flash descriptor.
Tried the Guide to Unlock Intel Flash Descriptor, couldn’t find a way to use the pinmod method, and couldn’t find the ‘Setup’ text in UEFITool.
I’m really lost. Love this notebook but i’m honestly frustrated.

I also found that this notebook, being a VPro, should have an MBEx menu, and it’s supposed to have an option to enable/disable ME, but it doesn’t access it. It shows only “Accessing MBEx…” when i enter the hotkey Ctrl+p and boots to Windows.

Think i wrote already too much. :slight_smile:
If you guys can help me, i will be forever grateful.

The post that you read is pointing the solution, this is a task to learn and to do it on your side as no one can do it for you.
This is not a 5m task and requires some reading, focus and time.
Latest Special Topics/Intel Management Engine topics - Win-Raid (

1 Like

Thank you for your input. Looks like i have some reading to do :slight_smile:
But won’t i need a Bios bin file? Care to point me in the right direction to get one?

The bin file is your output of the current system spi content by the FPT tool, the cleaning method aplies to the full spi or ME region, full spi is recommended, its described in the guide.
The output result file is the cleaned ME, using the same or near up version image in the repository matching the current ME version in the system now.
This operations requires the access to the spi regions, also in the guide, other than that only by using a programmer.
If you already read the guides you wont be doing this questions…so again, read and learn.

Thank you for your help @MeatWar .
I managed to clean the dumped bin, or so i believe, but i still have a problem unlocking Flash Descriptor.
The only relevant data i found (and i managed to extract about 15 files) was the data below:

0x5DE12 		One Of: Me FW Image Re-Flash, VarStoreInfo (VarOffset/VarName): 0x2, VarStore: 0x4, QuestionId: 0x86E, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 8B 03 8C 03 6E 08 04 00 02 00 10 10 00 01 00}
0x5DE23 			One Of Option: Disabled, Value (8 bit): 0x0 (default) {09 07 04 00 30 00 00}
0x5DE2A 			One Of Option: Enabled, Value (8 bit): 0x1 {09 07 03 00 00 00 01}

…which leads me to believe the correct setup_var, should be → setup_var 0x2 0x1 at the EFI shell, right?
But that doesn’t work, unfortunately.
Does this mean i have to use programmer?
Again… thank you and sorry to bother.

the easiest safe way to make sure everything dumped, then yes a programmer should be used.

if intelfpt does not work, try using afuwin (if your bios is an AMI bios, make sure you know your chipset, and try to find the latest afuwin or the same afuwin from asus web that matches the chipset (like gen 4 mobos, try to take that one), since that’s what i do if im unsure of the afuwin needed to flash). the amisetupwriter somehow didnt work on me.

Thank you for your reply, but bios is Phoenix and i can’t find a way to flash it.