Tongfang(GM5MG0Y) Bios Rollback is not possible

Hi there, recently I bought a rebranded tongfang and I want to rollback my bios because the older version has the dGPU only mod in BIOS. I was not able to mod it with AMIBCP so I wanted to flash the older file. However, it gives an error "cannot update bios with different platform name”. I tried with every possible way. Flashing f.nsh in EFI, using device manager, using bat files, using ami flasher but no luck. They all give the same error. Can someone help?

Link to the BIOS old and new.…RZ5x4hBb2Yuxd-e

EDIT by Fernando: To make it easier for the supporters I have deleted the other thread with the same request and merged the above 2 posts.

EDIT: After with someone’s help, I was able to diagnose the problem. The support sent me wrong files TWICE. So Instead, I created my dump file and attached it to the Google Drive. Can we enable dGPU?

This redundant post has been deleted by Fernando.

have you contacted the support for a bios update? you should.cause i could not find any
have you tried dumping your bios? what was the result?
have you tried using hwinfo for device info? since its rebranded (or refurbished?) maybe it has a different part(s) inside than original

I also recommend updating management engine firmware,
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

I got both files from the support, so they are comptabile. Actually, I can flash the current one again. Obviously It has no change. But rollback seems to be impossible.

Mshybrid,dGpu,iGpu and dynamic options are available
i have also updated the modules,microcodes.if something is missing you can use amibcp 5.02

I will give it a try in 2 hours. You have just saved my life. Thank you soooooooo much for your effort! Ill give feedbacks ASAP.

I was able to flash, however; dGPU option was missing again. So I opened amibcp 5.02 and changed default to supervisor. However; I can not flash the file again. It says "Different platform name" thingy again. I dont know what I am doing wrong. Could you please change it to user or supervisor and sent it again? I dont know if its a bug with my machine or I am doing something wrong.

Amibcp is not a reliable tool for its worth
Does the requested setting works?
Have you reseted the cmos?
You need the change the whole related tree,not just one line to make it appear in menu,so instead change a setting as your liking
And if all fails,ifr body must be extracted and edited in hex

Did not work since It was not showing up in the BIOS. Maybe I was not able to flash the bios you have sent me correctly? I used Afuwinguix64.exe v5.12.00.1904 for it. I also tried 5.14. I may try AfuEfi64 but I think it is just gonna give the same error it gives. My ME drivers are the latest, I really dont know what I am missing.

Updating management engine firmware also recommended,
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

I have just updated them like an hour ago. :frowning:

firmware,not driver :slight_smile: probably wont solve your problem though
reset cmos,then flash the bios again

I am at a dead end then :)) It will void my warranty, the device is just 7 days old and the cmos battery is at the back of the motherboard so I have to completly disassemble it in order to do it :C

If someone is reading maybe they can help. This is the error I get with all ways I know. (Afuefi, Afuwin, F.nsh)

WhatsApp Image 2021-03-10 at 02.44.04.jpeg

Okay so with someone’s help, I was able to diagnose the problem. The files that the SUPPORT sent me was for a different motherboard. So Instead, I dumped my BIOS. Is there any way that you can make the changes to that one?…RZ5x4hBb2Yuxd-e