[TOOL] Lenovo (H20) Bios Unlocker and Locker

Latest Firmware can be still unlocked without flashing, just not with this tool…

by any chance there would be an updated release?

Well the only way to know, is Waiting :smiley:

The only thing i want is to activate XMP somehow :confused:

Hi, I can’t see the file for the windows app
Could you send again please?

Hi, what post/file are you referring to? If it’s a missing attachment hosted on the forum (not external), please report it at Welcome to the new site! - Site Feedback - Win-Raid (level1techs.com) because we just migrated to a new platform and some things may be broken.

Hi, is a file posted in the first page of this post Unlocker.zip

Anyway Is not a problem for me to reupload the file, let me know,

1 Like

Mm, yes, you are right. I can see it at the old forum, but not here. I think not all attachments are transferred yet.

Feel free to download it from the old forum for now while we investigate. I’ll report this to @wendell at the welcome thread.

1 Like

The fun thing, is that also on the old forum is shown only the FileName, and no way to download,
For Now I will here again, I case It was lost…

Unlocker.zip (8.4 KB)

Nevermind, I see that wendell fixed it, thanks


Oh, yeap. I removed all rights except reading at the old forum, and that’s why you cannot download it. Anyway, it will get fixed here. :slight_smile:

EDIT: Fixed old forum permissions to allow attachment reading/downloading as well. Should help temporarily until all migration issues related to attachments are resolved.

Thank you very much!
I now have a question though; when I run the unlocker it says

"The token does not have the specified privilege.
A required privilege is not held by the client"

What does this mean and is there any way to continue past this?

Just run the unlocker as admin

Okay, I try that and it says The system could not find the environment option that was entered.
What do I do?

Reboot and try, is abug of the app.

Or use the latest zip, where this bug is fixed

@plutomaniac sorry to bother, you but seem that the copy of the first post is not exact.

The one on win raid, was updated a few time, but this is the first version of the post

Yes, this is a known issue that @wendell and I are aware of. Post edits between early December and April have not carried over. Hopefully an automatic solution can be conjured to update the content of any edited posts since December. Fingers crossed! :hand_with_index_finger_and_thumb_crossed:


Alright, I’ve run the newer version and it says it has successfully unlocked, however I can’t see an advanced bios when I go into it. After reading some of the past comments it seems that my version may be too new. I am running bios version EFCN54WW
Is there anyway to go to a previous working version?

Legion 5i
10300h 4-Core
1660Ti 6GB
2*8GB 3200MHz CL16 RAM (Running at 2667 MHz)
BIOS EFCN54WW (22/03/22 Update)

Oh, yes, all the new versione aftert the april security update are surely not supported…

okay, so is there a way to revert my bios to a previous version?

EDIT: I managed to download an older version that supports it and booted it. It worked and I can now access the advanced bios
For reference the version I downloaded was EFCN48WW

EDIT 2: I’ve managed to get my ram to run at 2933 in windows after setting it to 3200 in the bios. How do I get it to run at 3200mhz?

I using it unlocked my legion 5pro, but i didn’t find ‘wake on lan’ option except ‘wake on pme’ which didn’t work.(crying) I just want to do a wol. do you have any idea? i would appreciate it if you offer me some advice.