[TOOL] UEFI Editor

Can you share the log or edited files if still have them?

Original: https://download.asrock.com/BIOS/AM5/X670E%20Taichi(2.02)ROM.zip
Modified: creative

Replaced NVME Sanitization Tool Ref page id with Advanced Ref page id.

There’s two elements of NVME Santization Tool in the bios. One with question id 6E in Advanced and another in Tool with question id 24. Perhaps, you replaced the wrong one, which is 6E?

I had the same result trying to replace PC Health in B550M bios. It has two PC Health pages.

can’t dump/write BIOS on my asus MB with flashrom. Wonder if I can modify the ASUS CAP file with the changes I did with UEFI-Editor and flash BIOS normally? E.g. can I insert the changes from UEFI-editor with Uefi-tool 0.28.0 in cap file and then use modified cap file to flash normally?

Don’t know.

Try something else than flashrom. Search on the forum.

“Normal” using OEM motherboard tools method or by Flashrom?
Capsulated files are data headers with signature/security measures, exactly against modified files and used in update files from the OEM.
Flashrom doesn’t care for these and also this data is not part of the bios itself.
A dump also doesn’t contain this header.
[Guide] How to flash a modded AMI UEFI BIOS - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

…but looks quite old.
You didn’t mentioned your Asus model and the guide is not old at all, basic principles from Asus cap files and methods still valid on modern motherboards.

Good luck, all the best.

Thx that is what I suspected.
Well the problem for me is that flashrom can not detect the bios using -p internal.

With Normal I ment with motherboards builtin flash utilities.
So I guess I need to use ch341 to dump and write back rom then. If it’s possible.

Thx have read that guide, but looks quite old.

I modified the one under Tool.

This situation is odd.

I googled for bios overview and found an interesting discrepancy.

Could have Asus put the different one under Tool? The way they remove USB Configuration from Advanced?

I don’t doubt you in any way and don’t insist the feature to be pulled in the main branch.
Just want to know your thoughts.

No clue why that Ref is missing there, but I assume you can unlock it with an Access Level change.
I wouldn’t be surprised if the page ID method didn’t work with other vendors, considering each vendor seems to handle things differently in general.
Gigabyte is the last desktop mainstream vendor that isn’t solved yet, so I’m hopeful this will be a viable solution. I just want to confirm myself that this works (specifically a video demonstration). So far, I haven’t been able to find a volunteer with a gigabyte board.

Hello again.
I know you don’t plan to add Aptio 4 support. Because AMIBCP works well and stuff. But there is a single issue, cos of which at least minimal support worth being added to the editor.

A single line in Setup SCT is all that needs to be changed for unlocking.

That’s how I imagine the editor would operate like. Unfortunatelly, I could not went further and write parser function as I don’t understand what happens from line 722 and onwards.

Will it be okay if I ask for your help?

Not sure what that GitHub collab invite is about, but the permission requirements are excessive.

This is the main issue with Aptio IV, IMO. What single line are you talking about specifically?

L722+ parses the top-level menu structure and would likely not even work with Aptio IV since the IFR is split into many form sets.

Regarding page IDs, it does not work on Z590 Aorus Elite, but does work on H110M-DS2. It seems like it doesn’t work on more recent Gigabyte boards anymore. I think I’ll add page ID + address parsing to the data.json as a compromise for now, so hex-editing is easier.

You should decline then. I wonder why github needs this all.

Provided that I can’t write parser from scratch, I thought to use this code as a base for a second ParseData function.
The thing is, I don’t understand syntax. That’s what I meant.

Ok, cool.

1. Which section.


2. What the line.

3. How to parse.

Oh, so you’re basically going to parse the Setup.sct file directly? Like I said, L722+ is just for top-level menu parsing in the AMITSE.sct file. You can ignore that. BTW, I added the page ID parsing and also switched the dev env from CRA (since it’s EoL) to Vite and refactored quite a bunch of stuff.

I wanted to. But now no more confident if I am able to sort that out.

Yes, I noticed it the previous day. Good work.

any updates on this project?
I’d like to tinker with this but seems like files are missing in the repo and it won’t run.

Not sure what you mean, but no files are missing.


I mean it won’t run locally for testing.
my server is configured correctly to run this type of script. it runs my script just fine but not this one. what am I missing?

I see some includes that aren’t in the master; can you send me a link to those?

I have no idea what you’re trying to do, but if you want to build it yourself, download and install Node.js, clone the repo, run npm install and then npm run build or npm run dev to start a dev server.

was running it in IIS…

eslint kicking error “file-not-found” “./src/**/*.”