Toshiba XG3 NVMe SSD Windows 7 driver installation fail

Hello! Third day I’m trying to install Windows 7 on my Gigabyte AERO 15x laptop. Here was preinstalled Toshiba XG3 NVMe SSD. As everybody knows, Win7 doesn’t support NVMe natively, so, I’ve tried to use OCZ NVMe drivers from this topic, at the start of installation this driver does work, the SSD is visible for installing, but when installation finishing up, there appears error “Windows installation cannot continue because a required driver couldn’t be installed”.

Does anybody knows, how to fix this? Thanks in advance!

Make sure you are using EFI booting on Windows installation and have GPT formatted drive.
You can bypass this by simply reseting laptop (before it can undo what it copied), and truing to boot from Windows 7 that was copied on that drive.

Some background : LINK

@iljinst :
Welcome to the Win-RAID Forum!
Why haven’t you integrated >this< MS Hotfix into your Win7 image?
If you want, you can install the specific OCZ NVMe driver once Win7 is up and running.
Dieter (alias Fernando)

Do I have to integrate this hotfix only in "install.wim" or in boot.wim as well?

@iljinst :
Since the NVMe driver is required already at the beginning of the OS installation, it has to be integrated into the boot.wim as well.

I’ve tried to integrate into install.wim and boot64.wim, however it doesn’t work, the Windows installator doesn’t see a SSD.

Either you have done a mistake or you have forgotten something.
How exactly did you start the OS installation?

I’ve started this from USB flash-disk in UEFI-mode.

Hello. I have tried to integrate the hotfix both with driver (as it was advised on Microsoft website) into installation image. And I still have problems.

1. If I integrate into boot.wim only - it works until finishing of installation (driver couldn’t be installed).
2. If I integrate into install.wim as well - there appears another error - “Windows cannot find the Microsoft Software License Terms”. Yes, I’ve tried to delete “ei.cfg” file, however installation tool asks me for key for this build, which I don’t have.

Most interesting thing - if I integrate only hotfix there - this error doesn’t appear, however, SSD still invisible for installator.

Which “Installation Tool” do you mean and for which OS Build do you have no key? We don’t help users, who want or are going to violate Mcrosoft’s license regulations.

By “installation tool” I call the whole process of Windows installation

I haven’t said any single word about violating of license regulations. I’ve just said that I don’t have proper key for exact build of Windows. I’ve downloaded oficial MSDN-image of Windows 7, and I want to purchase key after OS installation (I have right to do that in 30 days), otherwise I don’t have any reason to buy this key.

You obviously need a valid key before you are going to install the OS.