Toshiba XG5: Slow seq. write rate

i am new here. I have a Toshiba XG 256 GB NVME Drive. At my last CDM Bench end march i had a seq. write rate from 1100 Mb/s. And now i had only 350 Mb/s. I’m using the modded ocz driver from fernando (Thx for your work). If i use the MS stornvme-Driver i get the same results. What can i do to get the full performance back? Or what is the cause? A MS update?

kind regards

@Charlie0815 :
Welcome to the Win-RAID Forum!

Although I do not know the exact reason for the sudden performance drop of your NVMe SSD, I recommend to have a look into the start post of >this< thread.
Good luck!

Dieter (alias Fernando)

Thx. I don’t switch any BIOS options between the CDM-tests. All drivers up-to-date. LPM is off. I tested both write caching options. I get the same results. It feels like the write cache is disabled as the stornvme do. Between the tests I updated the microcode and windows did his updates

Update: I switched back from mc 3C to 3A and now it is the low seq. rate solved. And all other CDM benchmark are now better. I benched the XG5 with MC 3C through USB-Bootloader. I don’t know why the performance of the seq. write rate is much better then with BIOS-Update and MC 3C.

Toshiba XG5 mit MC 3A.PNG

Toshiba XG5 mit MC 3C.PNG

I have a HP Envy with a same Toshiba XG5 and also have the low writting, 339 mb/s. How did you get the speed back? I wonder if updating to windows 1803 didn’t create that. Read the update process towards 1803 was on hold for intel and toshiba NVME drives because of power management.

@kaloo Sorry for my really late answer. I found no solution which is still working. My values are as bad as they were before. I thought it was a microcode error or it has something to do with the Spectre Update. So I tried a clean install on an old ssd with windows 1709. I flashed an old bios to see the problem was the microcode. But the low writting is back. At the moment a have no solution. I’m thinking that is a firmware bug of the XG5. A firmware update is available for the Dell version of the XG5 (firmware AADAxxxx). But there is no firmware update for the HP version (AAHAxxxx) and the Dell firmware cannot be copied to the HP firmware. You can ask HP if there will be a firmware update for the SSD soon or if they have a solution.
I want to install windows 1703 on my old ssd to see if there is a problem there.

There is finally an update on HP for the XG5 : Toshiba XG5 SSD Firmware Update AAHA4103 Rev.A 5.4 MB Oct 22, 2018

I applied it but it does not change the low write speed. From what I understand as long as the system is set on the XG5 you don’t get the max writte speed…

@kaloo Thank you. I just found the update too.
I read that the SLC cache is the problem. Dell seems to have fixed this with a firmware update.
A clean Windows 1703 installation also didn’t improve the situation.
So far I haven’t found a solution to copy the Dell firmware to the HP.

You might be able to flash the dell firmware by extracting the SIG file from the dell installer and copy it into the XG5 hp updater folder, it should update with the dell firmware to do the job. Not sure which dell firmware is the latest one.

That was my idea too. :slight_smile:

I tried two approaches, but so far I haven’t succeeded in flashing the Dell firmware to the HP drive.

It looks like the sig file is also in the exe. It might work by replacing the sig file in the temporary folder where the exe is decompressed.

I had done this. I decompressed both exe-files of the firmwares. One way was to replace the sig-file and second way was to modify the config-file to recognize the SSD.


sounds nice. I think I found the right updater, but it keeps telling me "this drive is not supported with this application"
I have a kxg50znv512g with the AAGA4102 firmware and can’t update it in any way, because I have no DELL system :frowning:

Read speed 3k, but write speed like 300mb/sec :frowning:

Can you tell me what to do to get the firmware update done?

//EDIT: I edited the config file to suite my firmware revision: from AAHA to AAGA and got this error

IOCTL - firmware activate failed. 0x45D.

It is a bit difficult to find the right firmware because there are also non-SED and SED (Self encrypting drive) models. And Toshiba gives no support because they are OEM ssd.
At the moment I have three different firmwares for the XG5. But no solution.

Actually I wanted to upgrade to a bigger xg5. But not with this performance

I tried every firmware I found, but couldn’t manage to upgrade it…what a shame :frowning:

Any tips? :slight_smile:

Not at the moment.

any news on the subject?
I have two fujitsu branded one (AAFA) but Fujitsu isn’t even providing a firmware update…

@Lost_N_BIOS actually the topic treated here is not drivers related, but it’s all about firmware therefore it might be better to move it somewhere else (solid state?)
the content is similar to Firmware Updates for Samsung M.2/PCIe SSDs (where to get and how to do)

@elisw :
Thanks for your good advice!


meanwhile I managed to find 3 sources of firmware:
HP, with AAHA .sig file
Dell, with AADA .sig file
Lenovo, with AALA .sig file

unfortunately the flashing has proved a bit troublesome…