Transfer uuid from old MSI bios to new bios


The BIOS on my MSI Z87-G45 Gaming broke for some unknown reason after the computer had stood disconnected for about a year. The only sign of life on power up was a black screen with a white underscore. To make a long story short I got a ch341a programmer, downloaded the latest bios version from the MSI webpage, did a backup read of the broken bios, wrote the new binary to the chip, and the computer went to life! All is good. Now to the tricky part:

I hoped that the existing Windows installation would just fire up but it won’t… It shows the loading screen, then bluescreens for a microsecond, reboots and gets me to the repair tool where i can try to fix the broken bootup. It does what it does and says it can’t repair the system and reboots again. So I’m kinda stuck where I can’t boot Windows up.

I’m not sure, but something tells me it might have something to do with the UUID being removed/changed when I wrote the new bios. I read a bunch of threads here and did try to find numbers like MAC address etc in the backup-file with a hex-editor. I found the mac-address location in the backup and copied it over to the same location in the new bios (haven’t tried to boot it yet so I don’t know if made any difference). Though the serial-number or UUID I can’t find in the backup-file.

So… Where can I learn how to figure out where these things are in the backup-file or where (if) to put them in the new bios so that Windows recognize it as the same hardware/UUID/serial?

The easy way out would be just to format and re-install Windows but I’ve got things on that drive that I would like to get running again if that is possible. (For facts it is acting as a CNC-controller and I’ve made some configurations that I don’t remember anymore, should’ve made a backup…)

If anyone has any ideas I would gladly appreciate it :slight_smile:

Kind regards

The problem is solved and it had nothing to do with the UUID. I did get the UUID field filled after inserting the MAC address into the new bios file though.

The problem causing the bluescreen and reboot was that when I wrote the new bios, the old settings were reset. Which meant that the SATA settings defaulted to AHCI, which I used to have as RAID. So after changing from AHCI to RAID, Windows booted up just fine.