TRIM function is lost

Hi everybody,

yesterday I found out that my TRIM functionallity is absent. I made several tests with the EFI/SATA driver module 12.9 and 13.1 and belonging driver sets. The verification with TRIM check and also the hexeditor test fails. This is very strange because it worked over the last year flawlessly. Only difference is the upgrade to a I7 4930K (from 3930K) and I changed my SSD’s. Before I used 3 OCZ Solid3 120 GB in RAID-0 and now 2 OCZ Vertex 460 240 GB in RAID-0. Could it be related to the SSD firmware (no update available so far/initial release)? I use dev. 2822 on my X79 chipset and boot in clean UEFI mode. The BIOS is modded with all new RAID OROM’s (TRIM modded ones), SATA driver modules, LAN OROM and CPU microcodes. Any idea is appreciated…

Best regards hanson

that’s exactly my same situation
I modded my bios 4608(asus P9x79 deluxe)
with 13.1 orom and flashed it ubf
using 13.1 whql drivers trim is enabled but trimcheck-06 say’s
it’s not working

sorry,I jumped too early,I did some searching and found how to mod the bios
but,the bios reflash worked fine but trim is still not working
it’s enabled but not working .13.1 irst is installed but trimcheck-06 still says no go
thank you,bigcid10

The TrimCheck tool is not able to detect very low TRIM activities (which are rather normal during the usual work). That is why I recommend to trigger the TRIM command (e.g. by using the Win8 “Optimizer” or Anvil’s Storage Utilities), before the user starts running the TrimCheck tool.

I did all this (triggering, using hex method) but my system seems to have no TRIM function anymore… For what reason I don’t know :frowning:

What means "no TRIM function anymore"?
Which was the last Intel RST(e) RAID driver/ROM resp. SataDriver combination with TRIM in RAID0 support?

I explained it when I started this thread. I tried several combinations with all the same result: no TRIM function. Over the last year these combinations did work. I updated my SSD’s recently and changed my processor from I7 3930K to I7 4930K. It’s strange…

I am sorry, but I have overviewed it.

My conclusion: It is the OCZ Vertex 460 SSD Firmware, which lets the TRIM command not pass into the RAID0 array.
You should ask OCZ for a new Firmware version for their Vertex 460 SSDs.

Yes that was also my idea. Unfortunately these SSD’s are brand new, so far there is no firmware update available. But you’re right, maybe I should push OCZ by mail so they take care of this special problem at the next release.

Fortunately there is no need to be in a hurry, because
a) the SSDs are new and will not really need TRIM support within the next weeks and
b) the OCZ Vertex 460 SSDs have a very good Garbage Collection, which is able to clean the cells as well (although it takes more time to finish its work).

OK, great to hear that. I also left about 30 GB of unpartitioned space at the end of my array for these functions.