[Troubleshooting + Attempt to resolve] Broken Palit GTX 970 Jetstream

@Fernando I’m not sure if this is the right place to create this discussion, I apologize in advance.

I’ve been reading through this forum for quite sometime, but in the last days I managed, with the help of others forum members and especially thanks to @Lost_N_BIOS to solve a big issue I had on a X79 motherboard and to mod with success a Z170 to run an i5 8600k as explained on the guide. I also uploaded the bios if anyone is in need.
Since I received so much help there, I decided I would post a little log about a dead GTX 970 I bought for 20 Euros, hoping that I could receive help and that maybe this can be followed as an example to troubleshoot a broken GPU with similar problems.

The guy who sold it to me said it stopped working random. I decided not to insist.
The card is the GTX 970 Palit Jetsream. It has the warranty sticker on the screw on the back, so the card never got opened. It had some dust on it, but not much compared to other cards.

First thing I did and I recommend doing was simply tried putting it on a test bench. Maybe the guy had the PSU broken, since he didin’t look much experienced. Nothing, fans spinning, LED turning on but no signal.

I decided then to take it apart, cleaning it with some alcohol whipes, replacing thermal paste and thermal pads. Sometimes it’s just a thermal issue, so it was worth a try. Still nothing, same as upwards.

At this point you should boot the system with the iGPU or another GPU and see if the card is detected, but at the moment I couldn’t so I decided to put it in the oven, since that is a temporary fix that can save certain GPU from death. There are plenty of tutorials on the internet about how to do and there are a lot of people explaining why this is just a temporary fix and why you shoudn’t do it unless you are not planning to use that oven again AND you already tried everything. I do recommend to do this as last chance. The next things I am gonna explain are a better choice. For me, the oven didn’t solve the problem.

Today I will set up a test system with another GPU, in order to see if it is properly recognised. In which case it could be an IO issue (ports of the board not working) or a bios problem.

I will update this later on.


I built a test bed and the GPU isn’t recognised. I believe the problem has to do with the graphics card not receiving power. I say this because the heatsink is completely cold, there is absolutely no heat being produced. I will make a zip folder with the images I have and upload it soon. https://www.sendspace.com/file/3odrw5

Since your contribution has nothing to do with the main topics “Storage Drivers” and “BIOS Modding”, I have moved it into the “Off Topic” Sub-Forum.
Hopefully you will get advices nevertheless.

Thanks a lot, I did post it in that place because I thought I would have probably had to do a vbios mod lowering the clocks or by programming it via SPI programmer, but I believe your decision is right.