Trying to Recover Bios on a Lenovo Z51-70


After i have successfully recovered my ASUS K75VM i have the same problem with my Lenovo Z51-70, already a black display, fan and led works.
I dont know where is the newest bios bin file, i only found this here

Hope it will be the same as at my ASUS?
I will open the Laptop and will make a dump of the bios with my programmer soon.

Greets Markus

Hi, i made bios dump of my notebook now, i dont know whats wrong here.
maybe you can help me please? looking for a solution, have a black screen on my laptop since some days.

here is the dump which i made

greets and thank you

z51-70 bios dump.rar (3.57 MB)

so i think my laptop is dead because the power button have no colour if i try to turn it on… anyone can help me please? :open_mouth:

Change 37311Bh in your dump from B6 to 96


Check in UEFIToolNE that the marked section can be expanded again correctly



very thanks, i will try it now, but the fan is also not working…
only the charging led is blinking.

okay, have done the 96 and checked the two different dumps in UEFIToolNE alpha 58, its completely the same as at your screenshot.
i have tried to flash, it was finished and after the assembling there is the same. :open_mouth:

z51-70 bios dump edit.rar (3.57 MB)

Please make a new dump and post it.


The actually dump is that one: "z51-70 bios dump edit.rar" from my post above.

Do you thing its a bios problem? I think it could be but i also think i can be a defect motherboard…

-there is no reaction if i turn it on
-if i connect the power supply the orange charging led on the front is flashing

Greets and Thank you for your help!


Is it really read back from the bios chip or is it the last file you flashed?

its the last file i flashed.

When i am at home i can read and make a dump.
Give me one hour.

Greets and Thank you


Here ist the actual dump from mainboard.

Greets Markus

z51-70 bios dump edit 2.rar (3.57 MB)

I doubt that this is really bios related. Anyway- I emptied NVRAM, and reset ME region, try this file:

Please reset CMOS after flashing before trying to boot. (3.54 MB)


I tried this one, no changes sry :frowning:

1.) disconnect accupack and bios battery for almost 10min
2.) meanwhile i flashed the chip with your cleaned bios (thank you)
3.) connected the accupack and power supply
4.) also pressed the turn on button for 30 sec

It looks like there a massive motherboard fail :frowning:
I should look for a new board now

i tried to flash it again and there is another colour of the led now (its white flashing now…)

This is latest stock bios from lenovo, it’s a complete image including ME, so if this doesn’t work the error isn’t uefi firmware.

Please don’t rely on the verify function of the programming software. Read the file content after flashing, save it with a new name, and compare the original file and the newly read chip content to be 100% sure that the chip is properly flashed.
File compare: Command prompt window fc /b filename1 filename2 or use HxD ‘Analysis’ - ‘Data comparison’ - ‘Compare…’ (3.54 MB)

so i tried to do everything, but nothing worked with these device

i also have compered with HxD and there are the same files…
i will check a new mainboard now.

greets markus


Thanks for the feedback!

Feedback is that i bought a new mainboard and the fault is already existing… the orange led was blinking, after 30minutes the orange led switched off, since them there is a white led which ON all the time. But there is NO reaction if i turn on the power button… NOTHING

That’s so far still consistent with what I wrote:

So assuming that it’s not very probable that both boards do have the same error you’ll have to check all things that are connected to the board: RAM, connected smaller boards, display…

Yes it think there is some other problem like the display or other external boards.
maybe i will try do start with akku, board, display alone?



I got the new Mainboard and localized the problem with the power button which not works… New Power Button and the Laptop worked fine for 1 week!!!

Now i have a new problem:
I cannot start the laptop anymore, because i think the GPU is defect for a second time…

If I turn the laptop on the fan starts for 1 second. After that there is nothing, display stays black everytime.
The Power Button is white all the time, the both front LEDs are white…

I dont know but i think there was a overheating (i dont know why because the fan worked normally)

Greets Markus