Trying to unbrick a HP Zbook 17 G3

Using a CH341 black/gold programmer I had a lot of trouble with the black SOIC clip that came with it. This is where my troubles started, I got some bad reads and attempted to write to the Winbond 25Q128FVSQ 1650 chip.
The laptop bricked of course.
So I got a blue SOIC 8 clip and got a good connection on the chip after a few dozen tries. I used 2 different bin files I had to the Zbook G3 and kept getting verification errors using the CH341a 1.34 software as well as ASprogrammer 1.41

I read up here on the guide for CH341 NOT to use CH341a 1.34 on the chip and to also make attempts both supplying power (not on) to the motherboard and not. I got a successful write trying to plug in then unplug the laptop while connected to the CH341 and using ASprogrammer 1.41 using one of the supposedly unlocked bin files for this laptop. It verified ok and I rechecked it, then I did a read and got a good read off the chip too, to verify that the bin had been written to the chip. Everything looked good but the unit still wont boot.

The laptop powers on, fans spool up and screen stays blank. It will loop after 1 or 2 mins.
If I put in a HP BIOS recovery USB drive and hold WinKey+B for 40seconds it’ll mount the USB drive and attempt to read it but doesn’t do anything with the info on the drive.

So a few things, I’m pretty sure I don’t have a good read from the chip before I over wrote it. I have some reads but don’t think they are good.
What I did do was get what I thought was good read off another Zbook 17 G3 and compared it to the bin files I got off the internet. As far as I can tell they match up and the one I’m using from the internet is for a Zbook 17 G3.

I’m lost on what to try to do next. Did I brick the laptop by enabling Bootgaurd or some other HP bullshit? Am I not writing to the chip correctly?

@carsondel - HP BIOS fixing/editing is a major PAIN, due to HP’s choices!! I actively avoid HP threads often, if that tells you anything
If you are under warranty and can RMA, it may be best for you to do so now before time runs out.

Verification errors are usually related to only certain software/versions can read/write properly to any given chip ID, not all will work even if chip ID is in there, and some you may need to use other than exact ID
Since you tried to write without getting a known confirmed good dump first, you may have lost all system specific details And if SureStart is a thing on this model you may not be able to fix it without this.

For 25Q128FV - Write to this chip, only with Colibri (included below) or ASProgrammer 1.41 has been confirmed working here by others (1.18 also confirmed OK for READ ONLY)

ASProgrammer will work, so you should be good with that, or you can use Colibri in above package if you like it better.

To confirm any write manually, which if using ASProgrammer or Colibri you should not have to do, but you can do this way. After write/verify, close the program, open it again, then read, verify and save.
Then compare that saved file in hex against the file you wrote, if it’s 100% match then write was 100% OK

What caused the initial brick here?? Zip all reads you have and max compress, then upload for me and I will look them over and see if anything worthy there, but I can only guess since we don’t have a proper read (unless you read with ASP 1.41, or 1.18 software before you erase/wrote)


Here are 4 different attempts I made last week on the reads.
The files labeled Z17g3 Read 1 and 2 matched when I used a CRC checker.

I bricked the laptop attempting to overwrite the bios in order to remove the bios password.

I did try again to write to the laptop using the Colibri program you sent me. Seems like it writes correctly but the laptop still won’t boot. I get the Caps Lock/Num Lock 5 blinks which per HP means no response from the BIOS.

Thanks for your help!!

So I’m confused about what I’m doing wrong at this point.
I took another HP laptop with a Winbond 25Q128FVSQ BIOS chip
I used Colibri to read it, got what appeared to be a good read. I even saved 2 of the reads and the CRC checker said they matched. Then I used Colibri to erase the chip and simply write the read I just took back onto the chip.
The laptop bricked as well.
Powers up with the blinking caps and numlock light 5 times fan spins up and nothing.

Ok so for some reason I cannot write to the BIOS chip correctly.
I’m not sure what I’m doing wrong.
Colibri detects the chip fine and doesn’t give me any errors during the write process. The write process takes about 8 minutes? But when I read back the contents of the chip, only a few random lines of code appear on it.
Is something wrong with my CH341? My cable?
I figure my cable is good if I can get good reads off of it right?

No idea why i wasn’t getting full writes, maybe it was a combo of not having the system powered up and then down before writing? Maybe I didn’t have the clip on just right?
Ok so here what sorta worked.
1st I screwed up no using the right software to take a proper read of the OEM bios. No matter what I did, the system wouldn’t boot at all and only powered on with the 5 Cap/Num blink and that’s it

So I retraced all my steps. Removed the CMOS battery, primary drive, would try to boot, then remove the power supply cable and the battery. Connect the SOIC clip to the bios chip and run AsProgrammer
Using the identify chip command I would click on it while seating the clip till i got a solid read and it would pop up the chip ID consistently.
Next take a read of the chip, confirm I got what looked like a proper bios file
Click the unlock button (not sure if this step is needed)
Erase the chip (took some unit 45 secs others 62 secs)
Opened various random Zbook 17 G3 Bins I found all over the net and Programmed the chip until one FINALLY worked. The HP bios screen came up after several reboots, alerted me of corrupted BIOS and it would rebuild the OEM bios
several more reboots and an alert that the system would insert system identifiers to OEM ids and it was up and running

I had fully unlocked functioning BIOS and brought this thing back from being bricked.

Is this thread dead? I’m having an issue with my g3 and don’t know what ic is the bios.

Post/attach some high resolution pictures of the board, both sides …

I figured out the bios problem and managed to flash a bios. The ic above the gpu to the left of the m.2 and cmos battery, is that for the vbios? I accidentally wiped it thinking that was the bios originally. The computer boots just fine but my p1000 will not show up correctly.

Might be, might not be, can’t read what’s written on the chip, so not even sure what kind of chip it is. You didn’t dump / backup the content of this chip before trying to write to it?

EDIT Do the USB-C ports work as expected? There’s a Thunderbolt firmware update on HPs pages, try to run the software, look what the program will tell you.

This is the one above the gpu and to the left of the m.2 and cmos next to the ram slots.

This one I found out was indeed the bios. I never messed with the one close to the type-c ports. I just need a dump of the first one if anyone kmow where I can get it. I’ll try the software updates from hp.

There are som dump collections at badcaps. At least two show the 8MByte chip having a ‘shortened’ bios image. Unsure how it’d be shortened and if this is the case here, too.

EDIT Seems the NVidia bios/ firmware is for at least some of these models part of main bios. Unclear what you flashed, though…

I’m looking there already. I have a amd S7100X showing up sometime today to see if it can at least see that. The drivers install just fine, its just not giving me a readout on gpu z. And it seems like the gpu is initiated and running when i start a a game to test it.