Trying to unlock BIOS of an old Asrock P55 Deluxe and update IME - Please HELP!

This is my first message to this forum which is kinda an act of desperation

I have a quite old PC based on i5-750 with Asrock P55 Deluxe m/b. The last 3 months I have a strange problem. While I have installed 16GB of RAM (all 4 DIMM slots populated) two of them stopped working suddenly. When I’m booting the post BIOS screen shows 8GB but when I’m in Windows 10, the task manager shows 16GB installed but only 8GB used.

I tried to find a possible reason for that (other that my m/b has some hardware problem with voltages e.t.c.) and I noticed a post in a forum where a similar problem was attributed to corrupted IME and solved by updating the IME. I started digging and finally I came here.

My System is IBX based according to ME analyzer.



My goal is to somehow to build a new BIOS with an updated IME (or IBX) and flash it back to my m/b hopping that this will solve the problem with the “missing” RAM.

I tried almost everything using the provided tools. I even removed the SPI FLASH chip, connected it to a Raspberry pi with flashrom, red the contents, applied FD unlocking (using HEX editor) following the guides here, flashed back the BIOS but nothing! I can’t build a new BIOS using FITc.

The error I get is :



Truth is that the updated ME file downloaded from the repo (the one for IBX systems) is 144KB while the one extracted from the BIOS dump is 120KB. I’m not sure where the problem lies and if I’m doing something wrong.

I would appreciate any help from the experienced people inside the forum.

For your convenience I am attaching the BIOS dump file.

Thanks in advance for your time!


EDIT

Every time I try to dump ME section only from the dumped BIOS I get the following message.




Which lead us to the conclusion that bios is still locked.

P55_deluxe.rar (902 KB)

All you have to do to re-flash the stock firmware (and thus verify if it was corrupted) is to use the programmer with the 2MB SPI image from ASRock’s website. No need to follow any guides in your case.

Hey Platon!

Thank you very much for your reply.

Well, I did it (flashed BIOS file from the manufacturer using the SPI flasher) but the result is the same, Windows reads 16GB, uses only 8GB, BIOS reads 16GB (if you press DEL and enter into the setup screen) but in the post screen shows only 8.

I remember very well that after a crash (Green Screen) and just after the BIOS post the systems didn’t boot and a message like “Intel ME not initialized” or something relevant appeared. It happened just one time a couple of months ago.

Since you know like your palm the IME and BIOS things, do you have any idea what could be the issue?

Just for your info, I swapped DIMMs with the other two and DIMMs are just fine. It’s the two DIMM slots (same color) that don’t work. I’m thinking about the IMC but I don’t have any idea how to test it except of replacing CPU with another (which I have to buy of course ).

Thanks in advance for your time.

The Ignition SKU of ME 6 was extremely barebones, only responsible for hardware initialization basically. You can check its state via MEInfo tool from Intel (Converged Security) Management Engine: Drivers, Firmware and Tools > Section C. I had written some notes about IBX SKU 5 years ago or so, check this to see what I mean. Of course skip the whole part about forcefully disabling it, that is not the goal here.

Now, if you have re-flashed the stock SPI image and the problem persists, it is not firmware related but rather hardware or a compatibility one. If only those two slots don’t work (even with the known working DIMMs) try using some compressed air to clean them, just in case they are dirty and proper contact is not made. The next step is to check for compatibility between the 4 modules themselves and the motherboard itself (size, frequency, timings, vendor, single/dual sided etc). If nothing works and these two slots are not operational then the problem must be located in hardware (bad mobo or bad CPU IMC). I can’t think of something else right now. But I believe that looking into the (useless) IBX ME firmware on that platform is a waste of time.

Hi Again,

yep, I have red almost everything related to IME. It looks that in my m/b indeed IME has very limited functionality. Those DIMMS worked for almost 5 years without problems. I selected them so timings and XMP be the same even though the later 2 were installed 4 years after the PC build. I have done almost everything to find a solution (DIMM slots were the first to be cleaned and inspected). I may have to remove m/b and check for aged or cold soldering around DIMM slots.

Anyway, thank you very much for time and help. Since I am a member of the forum now I will take advantage and post a BIOS dump from an ACER laptop I have that might hide some secret menus and “power” inside it waiting to be discovered by someone here