Trying to Update the IME Firmware on Asus P7H57D-V Evo... and Failing. Any Ideas?


Lately, I’ve grown interested in updating the IME firmware on the various motherboards in my collection, after having successfully updated the firmware on my Asus P8Z77-V Deluxe with no trouble thanks to the guides on this forum on the matter. I’m now looking to do the same thing with my P7H57D-V Evo.

Here’s the information MEAnalyzer spits out for the latest BIOS for the board, which is currently flashed onto the BIOS chip:

To start, I installed Windows 7 SP1 on the board, went to run MEInfo to see if it could see the ME firmware version like MEAnalyzer could, and… it showed multiple errors before crashing. MEManuf did a similar thing - showed errors, but no crashing.

I decided to try the DOS version of MEInfo using a FreeDOS bootable USB drive made with Rufus. This time, it seems to have ran successfully, and I outputted the result to a text file to verify. As far as I could tell, it didn’t trip up anywhere. Here’s the result for your convenience: result.txt.

I then tried flashing the latest ME6 UPD firmware file through the DOS version of the FWupdate tool, but it spat out an error, saying something that local firmware updating was disabled. I read the " [[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing]" guide, grabbed the BIOS file from Asus’s website, and noted that the BIOS was unlocked using HxN. The BIOS on the BIOS chip that I read using a programmer also looks to be unlocked. I’ve also attempted the Realtek audio chip “pinmod,” to no avail.

So then, following the " [[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization]" guide, I’ve tried to manually update the firmware of the latest BIOS to the latest RGN file available in the repository in the hopes of somehow circumnavigating this IME firmware updating lock - - and once again was greeted with an error: The flash parts specified aren't big enough to hold the image that is being built! Please increase the total flash part size.

Comparing the sizes of the ME Region.bin files, it appears the newer file is 4kb larger than the original. If there’s a way to “increase” the total flash part size, I’m not sure how I would go about that.

With all of that being said, the question I have is: Where do I go from here? Can I actually update the firmware for this board, or am I stuck with the stock firmware? And if so, what is the best method, and how can I overcome the issues I’ve had?

Any help would be appreciated. Thanks!

Use FWUpdate instead

I’m sorry. I forgot to mention I also did use the Windows version of FWUpdate. Doesn’t work either. Nothing works.

The flash descriptor of the stock image is invalid, has bios region size 0x800000 which is the size of the complete file. That way FIT can’t work. Tried one older version which at least had the start address of the bios region right, but size still was wrong. Bios region shoud start at 0x600000, size 200000.

Open the 1903 bios in FIT
Right click PDR region and disable region
Drag the bios region down so that it’s located under ME region
Adjust size of bios region to 0x00200000
Change binary inout file for bios region to PDR Region.bin int the decompressed folder

Do the rest of the cleaning task as described in the guide!

1 Like

are you done or should I help You :smiley:

That did it!

Sorry for the delay, my sleep-schedule is weird rn. :slight_smile:

I first verified the new rom file:

I flashed the ROM with my programmer, it POSTed just fine, ran Windows, ran fptw -greset and was surprised by the immediate restart, and then I checked via DOS MEInfo:
FW Version:

However, MEInfo for Windows still does work properly, and the BIOS is still for some reason locked:

Am I missing something?

Maybe settings in FIT- Configuration ME ‘Local FWU overide counter’ and ‘Local FWU overide qualifier’, see
ht tps://
page 40:
“If the Local FWU Override Counter has a value between 1 and 255, firmware updates are allowed even if updates are disabled in the ME BIOS Extension (MEBx) settings.
After the flash is programmed, each time the computer restarts it causes the Local FWU Override Counter to be decremented. When the Local FWU Override Counter reaches 0, firmware updates are no longer allowed if they are not enabled in the MEBx settings.”

“If the Local FWU Override Counter is set to -1 and the Local Firmware Override Qualifier is set to 0, firmware updates are always allowed regardless of the settings in the MEBx.”

Either you can access an option in bios to allow updates of ME Fw or you might want to change the mentioned settings in FITc.

Another way would be to do the clean process and not to choose same version ME but latest.

That was it! Had to set the counter to -1 from 1.

There wasn’t a newer RGN file in the repository than that that I could tell, so that’s why I still needed to manually update the IME firmware afterwards with the latest UPD file.

The IME flash from FreeDOS:

ME Analyzer check of programmer-read ROM:

Thank you so much lfb6!

1 Like

Since I’m a new user, I can only include 2 links in a post at a time, hence this second post.

For anyone wanting the final ROM that they can just flash via a programmer, I’ve placed it on my Google drive: Asus P7H57D-V EVO IME-Updated BIOS (

1 Like

Bro is your work done or Not. If not reply mee
:grinning: Here To help You ASAP

I’m done. Thanks, though. :slight_smile:

1 Like