UEFI - Windows 7 - changing my UEFI boot priorities - given by Linux grub.

i have problem on one of my machines i have dual boot Linux Mint + Windows 7 x64 UEFI, im using Grub as bootloader and Linux as my primary OS, but problem is that when i boot to Windows 7, it change UEFI boot priorities a make WIndows 7 as primary OS.

Do you have clue, how to stop it? I installed lots of dual boot systems, but i never sse this. What could cause it?



One of the answers is to let the Windows Boot Loader to chainload GRUB EFI executable. You just need to confirm the correct route:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

Thanks, but im sure that on other machine, when is working for me, i didnt do this, so there has to be other way, i would like to let bcdedit untouched, its better to avoid any interaction with it…

That is why asked here, it was to be something strange with my Windows 7, i have installed BootICe, but im not aware that it is doing something with boot order, unless its executed… true is that i also used Hasleo UEFI trial, so maybe it could do that, but again im not aware it is working like some service or something like that.

I believe you need to install one OS or the other OS so that (OS/bootloader) first remains, but not sure which OS/bootloader to install first
@noInk - may be able to advise, if you don’t want to use method in post #2, but editing that way sure seems easier to me than doing a double reinstall to test which way works for you of the method I mentioned

Like already said in the thread probably the last installed OS overwrote your OS boot file.
Unless you specified it depend by the hard-drive port connected during the installation.
If the board BIOS allow you to: disable the WINDOWS BOOT MANAGER boot option.
If the OTHER OS boot files are still there, it might boot from it, if not, either BCEDIT | Advanced Startup Options > Startup and Recovery or msconfig could work.
On a search engine look for something like " start and recovery windows 7 set other os linux " there plenty of information already.

My Windows 7 where installed first, after Linux, but i migrated my Windows 7 bios to UEFI install later.

I never saw Windows boot manager boot option on / off in bios there is only some Win8/10 option.

Im setting boot options from UEFI, boot Windows are rewriting that setting everytime when they boot.

So you thing that i should just rewrite boot* file on EFI partition? I know there are folders per OS, but i need root of EFI could / should be some default one… and true is that my could be from Windows… and i can replace with Grub2 one… Is this your idea?


I m not suggesting anything.
If you want GRUB to boot the WINDOWS (BOOT MANAGER) you need to configure GRUB to boot the WINDOWS (BOOT MANAGER).
If WINDOWS is making itself default you need to make something else default.

A BIOS board usually allow you to manually select the corresponding NVAR entry or booth path.
If the WINDOWS BOOT MANAGER options is present, having it DISALBED automatically achieve the same result: first boot file if found in the boot order will boot.
WINDOWS (BOOT MANAGER) usually reside on first physical disk available, select a different path|nvar. Some board also allow to select other common boot manager as first boot option.

Grub is booting windows fine… problem is that Windows boot is overwritten NVRAM boot settings… and Grub is no more booting, but bios is now booting Windows… Until i set Grub again, its working i until boot Windows again.


Only intel pre UEFI board might not expose or manage the WINDOWS BOOT MANAGER option entry as USER selectable entry.
It become requirement with UEFI. Disable the WINDOWS BOOT MANAGER with the boot option or mark another EFI\LEGACY boot file/path/nvar as primary boot option.
If WINDOWS is making itself default you need to make something else default. BCEDIT | Advanced Startup Options | Startup and Recovery or msconfig usually work directly from the OS.
The recovery environment from the installed OS might not work without repairing the installation first. In case of boot issue, use the [MEDIA] installer environment to restore the OS boot manager.