Unable to flash BIOS with SOIC clip and programmer

Hi all,
I have been beating my head against this problem for a month, and I guess I just need to ask for help. I am new to BIOS modding.

Flashrom always says that it can’t find a flash chip. It has never successfully detected it.

My chip is labeled MX25L12873F.
flashrom -p internal lists “MX25L12845E” and “MX25L12835F/MX25L12845E/MX25L12865E.” It says both are ~16MB, and it can’t read either one.

I have tried a CH341A, black board, which I know is not ideal. I have also tried using a Raspberry Pi.

I have tried with the cheap black SOIC clip that came with the CD341A, and then I got a Pomona clip.

I have tried unplugging everything from the motherboard. I have tried powering everything from the programmer, 3.3 or 5. I also tried disconnecting power and ground from my programmer, and powering the motherboard with the PC power supply.

The PC is an Elitedesk 800 G1 Tower.

I feel like I have followed every guide, and tried every troubleshooting step that I could find here.

Any suggestions? Is it just a situation where I really have to desolder it? I was trying to avoid that…

Thank you!

It may be that you haven’t clipped it perfectly, sometimes it takes me a good 10+ times to get a connection. Also, sometimes you must have PSU connected (not forced on, but power switch on PSU in ON mod - ie normal), and sometimes you have to remove PSU cables.

From past experience with this chip - MX25L12873F use 1.31Free/1.40, ASProgrammer 1.4 or 1.41, or CH341A v1.1.1.32
Inside this package is 1.31Free/1.40 - http://s000.tinyupload.com/index.php?fil…695330485827902
ASProgrammer - https://github.com/nofeletru/UsbAsp-flash/releases/
CH341A v1.1.1.32 (Post #12) - [Help] Flashed stock Bios on Aero 15, now it won’t post

Is this system bricked, or can you boot it to windows or DOS?

I have clipped that thing so many times. My nice new Pomona clip is already getting worn out. I think I am getting it right.

The system boots fine. Luckily FLOCKDN bit is set, and I can’t use the sleep exploit on it, so I haven’t been able to do anything too dangerous.

Do you think that these Windows tools may work when flashrom in linux fails? I will figure out a second windows machine and give it a go.

Thank you.

Edit: I did some quick tests with Windows, and so far no magic. The software detects the programmer, but not the flash chip. I noticed that when I have the chip powered from the programmer my motherboard’s standby LED comes on.
Only thing I did not try this time was pulling the CPU. Will try that tomorrow.

1. check the clip if it’s stable?
2. PSU connected may be necessary I think.
3. I don’t think software counts in this situation.But I prefer CH341A

Do you have the correct CH341A driver installed? It’s in this package if you are not sure - http://s000.tinyupload.com/index.php?fil…695330485827902

Do you have cables connected correctly to your pomona? And, do you have them into the correct main slot, and correct pins into correct holes in that slot?
Here is image guide if you are not sure, this applies more to the generic black chip, you’d have to check pamona cables yourself manually
[GUIDE] Flash BIOS with CH341A programmer

Windows should work, as should flashrom
You didn’t move jumpers on the CH341A did you? Jumper needs to be in position 1-2, on lever side, furthers away from lever (on black/gold CH341A)

Leave PSU connected (both cables) then test again. Only the above mentioned software/versions work to write to this chip, windows CH341A software-wise I mean, so if you get it detected keep that in mind if you are not using flashrom

Oh!I remember something rare cases about connecting problem.


1.The CH341A programmer has one jumper cap on the jumper,you must see if it’s on the correct jumper or not.
2.The other side of the clip is the foundation that owns 8 jumpers,you must plug in the correct 8 holes of the CH341A programmer.
3.Did you press the bar of programmer when you plug the foundation?
4.The clip would be worn out when using over 50 times(or less).You can’t even keep it stable,I had broken 3 clips.But it’s cheap in my country.

Thanks for the advice. I was able to get it to work! Though I had to pull apart the clip and straighten the pins. And sometimes it will detect and seemingly perform reads and writes, but does not work properly. I can tell when it is happening because clicking Verify results in an error.

Now I have discovered that it is not easy to unlock the hidden menus in this BIOS, so I will go open a request post. =)

Nice you got it working finally! You have to use the versions I mentioned at post #2, or all writes will fail.
Menu unlocking on this BIOS will require magic string edit, plus possibly Access Level edit on top of that (test without first)

Magic String shown/explained a little bit (Magic string often before > EE 2E 20 71 53 5F D9 40 AB 3D 9E 0C 26 D9 66 57
[Request] How to Access Locked/Hidden BIOS Menu Settings (16)
Also here, shorter - [Request] How to Access Locked/Hidden BIOS Menu Settings (12)