Unable to flash modded GA-970A-UD3 BIOS

Hi. I tried to integrate the new AMD AHCI BIOS into BIOS F8A from the Gigabyte 970A UD3, available here.
I went all the way through the process, renamed the file to match the module internal filename, and integrated it no problems, but when I try to flash it, QFlash says the BIOS is invalid.
Am I missing something?
Thanks in advance.

@ uKER:
Welcome at Win-RAID Forum!

You ran into the same problem with the tool CBROM as many other users, who tried to modify a Gigabyte mainboard BIOS. This is a Gigabyte BIOS issue and only happens, when the checksum sensitive module MEMINIT is below the PCI ROM module you are going to update.
My advice is to let the original BIOS F8a untouched. It contains the AMD AHCI ROM v3.1.2.0, which will let you boot very quickly into any OS running in AHCI mode. An update to v3.2.1.0 may not be worth the effort of the complicated modding procedure and the risk of flashing a modded Award/Phoenix BIOS into a Gigabyte mainboard.
If you want to know how it is possible to circumvent Gigabyte’s security actions to prevent, that the user flashes a modded BIOS, you may look into >this< thread.

Since your problem has been caused by the modding procedure and not by the OROM you tried to insert, I changed the title and will move your post into >this< Forum section.