Unable to go through BIOS recovery on Lenovo M93P SFF

Situation: HW: Lenovo M93p SFF; (bricked?) BIOS stuck at Lenovo logo. Probable cause (haven’t been flashing anything for months now), may sound crazy or just a coincidence but that’s an additional info: Using a thunderbolt 2 cable instead of DP one in the dedicated GPU (nVidia Quadro NVS 510).

Tried disconnect-all-drives/cards, jumper 2-3 method: double short beep, screen comes up and then keeps stuck with “BIOS is recoverying…” on the bottom left of screen (yes, that’s mispelled, but that’s the way it is). If I put a key without the ROM files the behavior is different so I assume the procedure is good.

the integrated Ethernet card’s link goes up but doesn’t ask for an IP (usual behavior with vPro as in my case, so system unreachable for remote management).

I have a CH flash programmer but:
1. still unable to identify where the chip is
2. if/when I find it, don’t know what to flash on it

Let me know if I omitted important/useful information.

Any suggestion? Thanks!

Have you tied to clear cmos?

The flash chips also have names on it like Winbond W25Q64BV OR MXIC 25Q64**.

It also have 8 legs

Maybe there are 1~2 flash chips on your board,could you take a photo on your board?

When you found it, you should dump it first, Read the flash and save to a file.This should be the full dump.

1.If there is only 1 flash chip on your board,

You can download the stock bios region on the offical website, Change the dumped biosregion to the stock one Use uefitool And save to a file.

After that you will have a mixed full dump,Flash it to the flash chip.If the problem is the bios region broken,you will fix it.

2.If you have 2 flash chips on your board ,you must dump them all.The next step is a little more complicated.
Let’s talk about it when you are sure how many flash chips are on your motherboard.

Hi and thanks for your answer!

CMOS removed and cleared (that’s one of the things that jumper on 2-3 does).

The problem is exactly to identify where the chips are. here’s a pic of the motherboard: https://i.ebayimg.com/images/g/Io0AAOSwvd9d-69t/s-l1600.jpg

1 or 2 chips is not a problem: I did both already on other machines and I know the required principles.

I see two ways out:

1. Flashing the Rom(s) with the programmer: referring to the pic above, it seems to me that the chip is thw one one right, bigger 8-pins one with a red dot between the speaker and the screw hole. But once again: need to understand how to preserve what needs to be preserver/what to flash

2. Recovering without flashing: what happens when jumper is set on 2-3 and the recovery procedure starts? Why it hangs on “Recoverying”?

There are 2 flash chips on your board
i see.
1.You need to dump them to files and uplaod .
2. Is that hangs on "Recoverying" you mean the screen frozen?

Hey hi! Thanks for coming back to me so rapidly!

“there are 2 flash chips on your board”: which ones/where?

1. Can you confirm I understood correctly: you want me to send you a dump so you can check what’s wrong?
2. Supposed behavior: switch off, remove power cable, move CMOS CLR Jumper from 1-2 to 2-3, insert key with BIOS binary files inserted, wait for it to load. Should show a series of messages and then say the BIOS has been flashed. What happens in my case is: Machine boots, says “BIOS is recoverying…” and stays there (been waiting more than 30 minutes); bloc num/caps lock/CTRL+ALT+DEL still work.

Hope this is what you needed :wink:


@jhsvip stiil there? all right?

It looks like the BIOS is broken。
Sorry, I’m a little busy recently. I didn’t have time to read the post
According to your description, it looks like your BIOS is damaged
I think you should go to the official website to download a BIOS and update it to solve the problem.
The best way is to consult the official website support and Ask them how to recover BIOS in this situation.(It should be very easy to upgrade.here is the link click here Try to use the BIOS Update (USB Drive Package))
I downloaded the BIOS update pakage. I found that there are EC and BIOS region files in it after unzipping. Try using the U-disk version of BIOS update, which may solve your problem.
If the BIOS file can not be automatically upgraded after decompressing to the U disk, you need to consult the customer service about how to recover the BIOS in this case.

that’s what I did: what I described happens doing the BIOS recovery procedure (jumper on 2-3 and USB key)…

Can you boot in dos mode? If you can boot in dos,the BIOS file can be automatically upgraded with the usb key.
The usb key must format to fat32 or fat16.

no I can’t: BIOS locks up in normal mode and it stays on “Reoverying” in recovery mode. vPro which I used regurarly is unreachable: the network card doesn’t event send a broadcast to request a DHCP address.

The key is wokring properly: if it’s not done as it requires to, the screen doesn’t show “recoverying”

Sorry, I’m just a newbie but have you tried plugging an usb crisis drive with your bios? (I suppose the mb has a phoenix bios)

Thanks for trying Alex but in order for that to work the BIOS should work too and try to boot which ins’t the case here. The only way to change it’s behavior is to go through BIOS recover, a step that bypasses/comes before normal BIOS and tries a specific manufacturer recovery. In that case it is enabled through moving a jumper on the MB which is supposed to load the BIOS fro a CD or USB thumbdrive but as documented this process gets stuck.

try this tool, if you had a phoenix bios, (remember to change yours bios filename to BIOS.WPH and delete the pre-existing one).

the usb stick must be less than 2GB (due to FAT FS limits)


If I were you, I’d refrain to tell people just to try things: you may guide them into worse troubles than they already are.

The tool you linked is for laptops that don’t have a specific recovery procedure (that most already have) so doesn’t apply in my case.

Furthermore it’s for so old computer that it doesn’t run correctly even in XP mode (keeps saying “Porject Path Must be Specified! The folder must contain both BIOS.ROM and PLATFORM.BIN files, or a BIOS.WPH file” and the project path is grayed out.

The size of the USB key doesn’t matter; the requirement is simply to have a fat partition in order to be able to boot a DOS system.

My Lenovo m93p shucks on bios more than hours, please guys help me out, I did all bios recovering but still nothing helps me out.

Hi Salim I have a M93p with modded bios
first off please disregard any of the aforementioned suggestions above

you have an AMI bios-very easy to work with

you have to install the correct version of bios matching your boot block #
and lenovo doesnt provide the older bioses on their site but dont panic
while you are learning you can make a bootable USB-search online for tools to verify its bootable after you create it or check it out on a working computer
BEFORE you put any bios on it-I use poweriso to make bootable usb and extract the .ISO into the usb no just copying it
several guides here can show you how to use another tool to take a full copy of bios right off the chip for analysis
one of the issues is Intels management engine-ME its a pesky program with a chip of its own-
plug the usb into the back port and choose a black (non-usb3) port
go to amazon and buy a ch341a black programmer-if this doesnt work you will have to hard flash it but thats easy to and I can help you
you want the programmer anyway because your M93p can do cool stuff fully unlocked-I have NVME support-newest raid, optane memory on a daughter card in a 1x slot
dual m.2 drives operating at pcie 3 x4, overclocking limits, turning off a reserve drive until you need it, and faster booting, etc

try a fresh lenovo bios iso download extracted to fat32 usb on back port-label file AMI.BIOS it may auto update after some time
if you have already done that then the chs41a is the way to go-you have 2 chips-need to copy (dump) both chips a 4mb and 8mb
those need to be combined in a hex editor and then opened in uefi tool for modding and resaving then the files needs to be split again
and reflashed via the hardware programmer-if you dont want mods and just to reanimate then it is possible that you only need to reflash
the bios sector which the standard ch341a software doesnt allow that I am aware of but you can link flashrom.exe to function thru the programmer and give it a specific command
to flash bios region only with the lenovo iso-All of this only happens my trick doesnt work but I brought mine back many times this way until I got a programmer and started reading things to the end and NOT trusting all of the advice given here by noobs-also look at the dates of the forum for relevance
this is totally fixable and I have a barely used motherboard leftover from I bought 2 for $40 and have since repaired my first bricked machine so I sill got one for me a spare for me also-my little m93p with radian 560X gets it done-I have 8 hard drives connected-psx image boot via network and old linksys AC router in wireless bridge mode for media server(s)
one of which is a USB running virtual slimmed down win10-possibilites are endless and RAM is cheap-been studying ram drives and I like my AMD ram drive software for $10

Look for pin 1 on the bios ic and used the ch341a cable with red cable to connect to pin on the ic. Read the ic with neo programmer or as programmer for databackup , the one with 8mb is the original bios and the second one near it is the eeprom ,just read the 8m ic and contacts me for the bios bin file my whatsapp +2330207665370