Unable to repair/flash a LSI megaraid 9271-8i


Apologies if this post is in the wrong place

I have a home media server that has been running for years that suddenly wont see my raid array. Main use is to store random info and I use it as a plex server.

I am running a LSI megaraid 9271-8i

8 drives setup as raid 50

It’s a Z97-pro gamer board with a i7-4790 cpu and 16gig RAM

It is total overkill for what I use it for, but I like it and it has always worked great!

Until now…

The error I get is in the attached foto

The internet is full of people that have had the same problem and the solution is apparently to just reflash the raid card.

I have been struggling with this for almost two weeks and am unable to fix it.

What I’ve done:

  • Used a FreeDOS USB with megarec.exe to reflash – same error
  • Storcli and megacli is suggested but try finding the software and a proper step by step is just crazy impossible
  • Tried using sas2flash but im missing some or other step

Any advice or suggestion are super welcome