Unlock Advanced Menu and Enable NVME Support for Acer E5-476G-54U3

Hello everyone, this is my first post here and let me give my sincere thanks to the mods and everyone who have contributed to this forum.

I have an Acer E5-476G-54U3 that I would like to bios mod in order to allow me disable CFG Lock (For hackintosh purpose :XD) from the bios menu and if possible enable NVME support on my laptop.

My laptop seems to have M.2 Sata port in it (I checked and there’s two legs or hole?) and somehow it won’t detect my ADATA SX6000 Lite 256GB SSD. I have seen some videos on youtube showing that my laptop series (E5-476g) works perfectly with NVME drives like ADATA SX6000 Lite or even higher end part like ADATA SX8200 Pro.

Here’s one of the youtube video showing their steps in installing ADATA SX6000 Lite NVME drive on their laptop (I’m sorry I can’t find any English video for this type of laptop).

I’ve also notice that the BIOS version of the laptop on that video is 1.05 while mine is already updated to latest 1.37 BIOS version. Could it be the reason?

BTW here’s my dumped BIOS Region using FPT and the error it shows when I tried to reflash it.

BIOS Family ID is Z8VR I think

Current Error.png

BIOS Family ID.png

ACER E5-476G-54U3 biosreg.zip (3.89 MB)

Before we start, a hardware flash programmer (for example CH341a based) is strongly recommended.
I found this in IFR,so if you understand all risk is on your own,let’s begin.

Step one:go find grub and make a boot device
Step two:boot into grub and enter below(without quote)
"setup_var 0x17 0x0" press enter
"setup_var 0x3C 0x0" press enter
then reboot and check if CFG Lock is removed now.
About the NVMe part,I think your laptop have native support for it,which means just plug-n-play.

Thanks for the answer! I will follow your instructions once I’m done from work.

Yeah about the nvme thingy it indeed should works out of the box but for some reason the ssd isn’t detected on my laptop. I tried the ssd on my friend PC and it was detected just fine.

Hello @Blossomcrown sorry for waiting!
I have followed your instruction which resulted in error 0x00000008 when I type both setup_var command on efishell.
I found myself another tool called RU.efi by James Wang which allows me to edit the value and save the edit. I edited the value for both 0x17 (BIOS Lock) and 0x3C (CFG Lock) to 00. For some reason the value for BIOS Lock is already set to 00 so I just rewrite it to 00 again just to make sure.

I will wait the Big Soul (Lost_N_BIOS) to say anything right , but from his notes …

There are many variable’ s Locks (depends on manufacturers), listed here and it’s possible to edit into RAM (EFI, RU shell,Linux, UVE), when
we get error 28 or 280 using Intel Fpt tool to backup bios.

RTC Lock
SMI lock
Flash Protection Range Registers
SPD Write Disable
BIOS Guard
Flash Wear Out Protection
CFG Lock
Me FW Image Re-Flash
MC Lock
Local FW Update

But on error 368 we are meeting the “FLOCKDN” - BiosRegionLockDxe (GUID - BC05DC37-9DA0-4050-9728-F34DDB01E200) Eeprom (Bios), descibed by CodeRus and it needs the SPI programmer to bypass.
It needs to extract and modify Module into Bios and rewrite bios back, so You will make all modifies at that time.
I hope Lost_N_BIOS will reply You as soon as, so to say him “Thanks” for all You made for us !
Lost_N_BIOS … You’re GREAT !

P.S. @Lost_N_BIOS , let me know how to send you a donation for a couple of beers :wink:

Glad to know that you make it works.Good job!
RU is pretty useful i agree.