Unlock Aptio V Z170 Board Menu Chipset unhide and other Menu

I have a Z170 board with Aptio V bios. I would like to unlock all menus. I already tried some. With AMiBCP from default on user and SUpervisior. Everything does not work.
I also read that UEFItool deletes the menu data when extracting setup from the bios. It should go with AFUEFI( and so on) to extract the actual data of the menu. Are there other methods that are easier?

bios.zip (3.57 MB)

Unfortunately, all versions of AMIBCP for Aptio V do not work correctly. Try to find a newer version than (5.02.0031)

What you heard about UEFITool is wrong, or at least the way you mentioned that, maybe that person is doing something wrong or doesn’t know what to do etc? What exact motherboard do you need this done for, stock link please.

Sometimes you have to do 1 or 2 things on top of AMIBCP edit, other times only those 1 or 2 things and not an AMIBCP root menu change etc, all depends on the BIOS.

I have version!

With this version of the problem, you need a newer version.

I can be done with combo of AMIBCP and magic string edit and or 46 02 to 47 02. I will check it now and send you BIOS to test. Usually only “Chipset” needs multiple methods (2-3), Advanced usually only AMIBCP alone or AMIBCP+Magic String edit.

You still never said what motherboard this is! Obviously I will find out, but this kind of thing should be mentioned right up front. For me I’d like to know in case I already unlocked this BIOS previously I could link you to that without having to download and check etc.

Please post MEinfowin output image or text (in full) - to check if Bootguard/ACM is enabled, it’s in this BIOS.

CLEVO P870DM << Is that the exact model? And no problem pulling menu data from setup/IFR with UEFITool extraction.
Also I previously fully unlocked P770ZM, so I’m sure this will be same edit process, simple and quick to get you partially unlocked, then you can do rest as you see fit with AMIBCP 5.02.0023

Please upload an image showing what all current BIOS sections/tabs you have visible, thanks.

Also, forgot to ask, were is the 4MB BIOS file too? Or does your board only have one BIOS included with the stock downloads?
The other I mentioned has two, and EC files with it’s downloads, so assumed maybe this one should at least have two BIOS as well (4MB & 8MB)

Go ahead and get a dump with AFUwin/AFUWinGUI too, so I can compare, thanks!

Yeah, it’s a P870 model.
Unfortunately I can’t send you a picture yet.
I’m still waiting for my mainboard. I’ll let you know when I have it.
Exactly, I think you just have to go from TRUE to FALSE, and the rest can be done with AMIBCP.
I’ll test it when I get the board back.
Thank you for your commitment!

The file here has nothing to do with the BIOS menu. Just wanted to have a link to link!:slight_smile:

TE.zip (20.2 KB)

Some things, like Chipset do not have TRUE/False, or Suppress If. Chipset usually can’t be done with AMIBCP, but may nee it also set there too plus other method. Advanced often can done by AMIBCP alone.

File to link? What is the TE.Zip?

Are you saying all versions tested up to are not working correctly but versions after will work properly or still unknown if working in later versions? No one has posted a version any later than this one so far?

That’s the latest version I’ve found … maybe @SoniX can clarify?

Latest available (5.02.0031), But it does not work properly with the latest BIOSes.


I don’t get that message when I load my bios? Is there a link to amibcp I would like to try that one to see if I get the same results as

The question is maybe bootgaurd needs to be disabled or something else preventing menus from showing or the very latest bios’s must have even a later version that’s not available to us yet?


@pcfr33k - bootguard would not affect your ability to modify BIOS or enable hidden settings or tabs. If you need help enabling menu sections make a thread with all your board details, stock BIOS link and a FPT dump of your BIOS if Intel based board and then I can help you try to enable menus

@Lost_N_BIOS , thank you very much! I have a BIOS dump … I think both him and I are trying to unlock some menus (particularly things like Chipset, and second set of Main / Advanced menus to allow for overclocking, memory profiles, etc.) on this TONGFANG GK5CN6Z APTIO V BIOS. Give me a second to start a new thread. I think it would be useful for everyone with this variant board (which is many people). I would like to know how to do this though. I’ve had no luck going into setup_IFR.txt and finding the particular 01010100… etc string corresponding to the hidden options. I also had no luck finding the True’s in there for the hidden entries.

I have a Walmart Overpowered Laptop, a barebone Clevo laptop that OEM’s make to their liking. Its an Intel based board coffee lake i7-8750H 6 core processor, I took the back cover off and used my Xeltek 610P Rom Reader/Writer to dump the Bios. The link to their Bios is not the latest version if you can work off the rom dump I would appreciate it because then I can just flash that back with the Xeltek which is what I was doing all day yesterday.

The Bios is AMI Aptio V. Its a GigaDevice chip that I had a hard time finding the device config for but found one. The weird thing though is that their Bios on their website is 10420kb and my dump is 16mb. The chip ID is in the filename I gave to the bios I am attaching.

I followed along a guide to do in manually but the 46 02 was not exactly in the place where the guide said it should be and in the pei txt file generated by IFR it was difficult for me to figure out which section belong to 46 02 to modify it to 47 02.

Link to Guide I tried to follow and Bios from manufacturer website below along with two versions of the Bios I dumped. Not sure what FPT dump is but I hope my dump from the Xeltek device will be good enough and easier for me to flash back.

Its the OP-LP3 you want to download, can’t download just the Bios have to grab the entire zip which is drivers and Bios. Keep in mind this is not the latest version I have tha came stock on my laptop and they have not posted that one only a previous version.


Guides I followed:


This is another guide I followed but not exactly sure which menu corresponded to which 46 02.


Is that the 64 bit version? I might be confusing it with maybe v4 aptio I think they had two versions and one had 64 in its name.

@pcfr33k , thanks, you beat me to it. Is this for the OP-LP3? I noticed you posted in the OP-LP2 thread over @ notebookreview which is why I ask (which is the one I’m working with). Same GD chip on there but I do not have a programmer so I could only dump the 10 MB flash out of the 16 MB chip. Otherwise, I will start a separate thread for both of our efforts trying to get this to work.

@nimaim - You’re welcome - I think someone else mentioned that board here too, in another thread? Maybe one of you two? Yes, once we figure out, I can tell you method.
Magic string like that is not found in IFR, but it is in setup if used. In order to use that, or check for that, I need to see images of your BIOS, please show me image at least for now of Main, Advanced, Security, Boot, and Save and exit and make sure across the top in at least one I can see all currently visible sections/tabs.

And yes @pcfr33k - I can and would prefer working with dumps for now, because when using FPT or programmer to push back your details may be in the files if using FPT or AFU BIOS Region dump, sometimes some of the details are stored in NVRAM or padding files within the BIOS region
Later, once we figure it all out, I can do on a stock BIOS and you can share that with everyone else. Has anyone already confirmed flashing or programming in modified BIOS is OK and bootable (not RSA Signed etc)?

Posted in new thread as requested so I don’t hijack this one any further :slight_smile: