Unlock Hidden BIOS menu for none-UEFI AMI BIOS?


i came across this great forum and amazing collection of information how to modify a BIOS.
However i haven’t found a guide how to unlock hidden menus for a none-UEFI AMI BIOS.

I found MMTool 3.62 which is able to open my ROM file but i realized after reading UEFI based AMI BIOS’s tutorials i need AMIBCP to set the unlock flags.
However when i tried to open the ROM file in AMIBCP v4.53 i receive the following error message


Just in case i have uploaded/attached the ROM file which is straight from the ASUS and not dumped with

Should i dump the ROM file with
before opening the ROM file in AMIBCP or is the version of AMIBCP wrong for this BIOS ROM version?

As far as i could tell its an AMI RomBuid Version is "4.18" it doesn't mention if its Aptio or not.

I hope someone can point me into the right direction.
I really want to unlock SPD timing/RAM configuration features for this BIOS.

The BIOS is for the ASUS n61vn.

Looks like im a step further.
I figured out that the BIOS ROM file is an AMIBIOS8 file by trying to dump the rom file with the proper AFUDOS version.
I was only able to dump the ROM file using AFUDOS starting with than 4.2x.
Looks like the latest version is AFUDOS 4.40.

No i figure i need the proper AMIBCP version that works with AMIBIOS8?
I tried opening the dumped file into AMIBCP 4.53 but received the same error message.

N61VAS.209.zip (626 KB)

MMTool 3.19, 3.22, 3.26 open this BIOS fine, as do AMIBCP 3.13, 3.37 and 3.51. So those would be tools to use, I would use the newer versions first.

There is no settings hidden, nor hidden menus in this BIOS, so nothing to enable

Thanks for your reply. Yes i came across a russian site listing in russian which AMIBCP version is right for which BIOS version and also took a look inside.
And saw that everything is enabled (Not Hidden).

I did see in the tab BIOS Strings that hint to options which are not even listed in the BIOS menu.
Are those string just for human interpretation (out) or can be invoked but were left out by the OEM?

I have another BIOS which is APTIO V but when i open it in AMIBCP it just crashes the windows without an error message.
Would you know which AMIBCP version would be the correct version for that BIOS?

BIOS.zip (3.06 MB)

Yes, left out from the OEM, probably due to same BIOS base used to build many variants on the same BIOS.

For the other linked BIOS, both AMIBCP 4.55.0070 and AMIBCP 5.02.0023 open that BIOS properly. It is Zotac Aptio V based BIOS, so best tool to use is the version 5 one.

i just took a look and most of the cpu configuration isn’t available in the BIOS option but it says “Yes” under “Show”.
Am I correct to assume. That i have to change the “Access/Use” to “User” to actually see them in the BIOS?

After having changed the Access/Use options and save the BIOS ROM file. Is it save to flash with AFUDOS?
Or would i end up with a bricked motherboard?

I read that i have to issue a specific set of commands to flash a modified BIOS.
That’s why I’m asking.

Yes, if something shows Yes/not hidden and you still cannot see it but do see other settings in that same menu section around the setting you want, then set to User and try again see if visible in BIOS.

In most cases yes it is safe to flash BIOS modified with this tool. Flash modified BIOS same way you flash stock BIOS, sometimes there is security checks though, but that would only tell you it wont let you flash.
Download stock BIOS, it should come with flash tool and or instructions and a batch file possibly, that would have your specific commands to use (ie edit batch and see commands used, or run batch)

Some BIOS you can simply update via USB from within the BIOS itself, always try that method first if your board has these options (Usually shown in the tools or exit menu sections)

thanks for your help! i do have one more question or two
i had some time to order a faster processor of the notebook i was working on. (none-UEFI, first BIOS)
after i swapped the RAM with low density RAM i was able to get it to recognize 8GB.
then i swapped the CPU for a core 2 quad Q9000.

the BIOS is still untouched and the latest version of the OEM (ASUS) version 209.
i reset’d the CMOS using the onboard EZFlash tool by flashing the BIOS 209 again. which resets the CMOS after the procedure.

here is the thing. the CPU is recognized in the BIOS but once i try to boot Windows it just hangs.
just to verify it is not an Windows issue i tried to boot the latest Ubuntu 18.04 Desktop LiveCD.
same issue. swapped the CPU back to the stock one, which came with the notebook.
Windows boots fine and the Ubuntu LiveCD too.

before i ordered the Q9000 cpu i did my research and checked:
A: the Asus n61vn supports the Q9000.
B: found a few geekbench listings running the n61vn with the Q9000

i did notice one thing though.
in this CPU-Z validation listing which runs an Asus n61vn with the Q9000 the CPU Microcode revision is listed as Rev. 0xA0B
this one even list Rev. 0xA0C
so i took a look into the cpu microcode list of the latest BIOS i had flashed and it shows version A07

the MC Extractor database shows the A0B and A0C version being newer


which leads me to my questions.

A: could updating the CPU microcode fix the boot of the OS’s?
B: how do i decide properly which cpu microcode revision to pick. do i choose the latest one? do i go by platform id first?
C: whats the recommended way to patch the bios with the newer microcode for non-UEFI BIOS? MMTool 3.26 with cpu patch or something better?

A. Yes
B. Look at stock BIOS, the values in parentheses after platform number (5, 7) are what you need to look for. Choose latest microcode that contains at least those (can be more also, such as 2, 5, 7)
You will pick Platform 44 or B1 one here, based on which covers those numbers you needed in parentheses - https://github.com/platomav/CPUMicrocodes/tree/master/Intel

C. MMTool CPU Patch tab, delete old, insert new then save BIOS image. If you get errors inserting, microcode size may need adjusted, I can’t explain that easily so if you run into this issue I can do the mod for you.

any guess with which one i should go with? 44 or B1? they have identical dates.

i did a “dry run” with MMTool and B1 cpu patch and didn’t receive any error while inserting.
i also run a diff compare of the original rom and the patched one to see actual binary changes and it patched the rom in quite a few places.
but since MMTool 3.26 is from AMI itself i think patching should be harmless when done correctly.

as the current cpu that works and boots the OS has a different platform id 10676.
my guess would be that even if something with the patching would have been wrong that cpu would be unaffected.

just trying to make sure everything went smooth before the actual flash.
i don’t have a raspberry pi + IC Clip to recover from a bad flash

I explained which on the other thread (And this one in post #8)
Drop your current BIOS from download, or backup, into MC Extractor and it will show you current microcodes in the BIOS and it’s platforms, then on the new microcodes you want one with same platform numbers in parentheses, meaning this number X (x,x) doesn’t matter, but these do x (X, X)

If you are doing this on the Zotac BIOS I checked above, it’s Aptio V so you want to use MMTool 5.02