Unlocking bios, msi gt72vr 6re 267be. tried many things, but nothings worked.

@Falkentyne Wich number in the EC must i change (picture included)
I think i have the right number, but i am not sure. it’s the 20 marked in light gray. E0 03

Embedded controller.png

Hi Stefan,
yes, that is the number to change, but the problem is, I do not have access to your laptop. i do not know which values your EC has stored as proper CPU identifications.
However MSI will usually have ‘older’ cpu ID’s in newer laptops, that’s why the GT73VR recognizes the “20” CPU ID from a GT72VR.

But if I use “20” in my GT73VR (mine is default=90), i will get unlimited TDP for 28 seconds, then i will get 45W power throttle after, even though I have a 7820HK.

First, try to update your EC to the NEWEST for your laptop (if you can find it on MSI’s site–remember 6820HK is a rare SKU).


I know on MSI GT73VR (6th gen), the 7th gen EC will work on these laptops (GT73VR skylake 7th gen is working).
That’s because CM236 chipset is very similar to CM238 and mainboard is the same.

But I do not know about GT72VR. 6th gen vs 7th gen–i do not know if using 7th gen EC will work on your system.

Also remember this is a 6th generation GT72VR you have. Not 7th gen.

I will tell you these:
20= GTX 1070 power ID=230 Watts AC power allowed (GT72VR).
21=GTX 1080 power ID=330 Watts AC Power allowed (GT72VR).
10=GTX 1070 Power ID (GT73VR 6RE), 230W
11=GTX 1080 power ID (GT73VR 6RF), 330W.

90=GTX 1070 power ID (230W), GT73VR 7RE
91=GTX 1080 power ID (330W) GT73VR 7RF.

I am 100% sure that 90 and 91 will NOT work on your system. 90 and 91 will not even work on Skylake GT73VR because they were not made until Kaby Lake mainboard (EC version 17A1EMS1.108).

You can try “11”.
See if 11 helps.
If 11 is instant 45W TDP right away, try 10.
But 11 is better (if it works) because you will have less battery drain with high AC power load.

I hope you can understand me.

if “11” or “10” does not work…
you can try KABY LAKE GT72VR EC. (7th gen).
Then you can try 11 or 10.

But there is risk of brick. But SVET has said that wrong EC will restore from backup from MSI internal code. I can’t tell you more. I take no responsiblity if you try Kaby Lake GT72VR 7th gen EC.

@Falkentyne , so i tried the different numbers. nothing works, i will not risk bricking my laptop with the other EC firmware, but thanks for the suggestion tho. (latest firmware was installed)

@Lost_N_BIOS So i tried to find that string, and i found 4 results. but all in an Nvar entry ore something. so as you sad there is no magical string in the bios setup. i tried to find some toturials for modifying the AMITSE module, but i think this will not help me.
So is there any other method to modify the bios, ore is my bios unhackeble. I’m still searching for new toturials, but they all are from 2014 ore older. some newer,but just explained differently.

Any other methods?

What happens if you set IMON SLOPE to 10 ?
Does this help? Does the CPU report its using less watts?

imon slope doesn’t work at all. tried imon slope 1, 10, 20, 50, 80, 90 also imon offset set to 1, 10 20 50 100 150 and 255. but nothing changes.

@Falkentyne said AMIBCP alone enables root menu’s access (like OC menu), so once you enable that you can enable any setting within using AMIBCP >> User, and if any of those fail you can edit IFR/Hex to unsuppress.
I stopped on this, assuming you had BIOS from Falkentyne that was all unlocked now, correct?

@Lost_N_BIOS hi, the bios from Falkentyne didn’t unlock the OC section ore something else. But with a key combination that only works on msi motherboards, i get more menu’s, but not the ones i need.
thats why i am still searching for other torurials.

The last thing i tried was modifing your bios (biosreg-BCPIFR.bin) from your quick test. i set more to user in AMIBCP and modified the IFR in bios setup module to unsuppress. but that didn’t work. still the same bios entries as the pictures i provided for you. also supervisor doesn’t work either.

(the bios of Falkentyne unlocked nothing.)

sorry that you misunderstood it,


AMIBCP OC edited.png

hx editor + ifr.png

Sorry I’m unable to help (besides the unlock code).
Even though I have the unlock code. I get lazy to always use it, so I manually unlocked all my menus months ago, which works correctly, except some “Submenus” which are only supposed to appear if a primary option is set to “enabled”, which enables submenus that are ‘supposed to be hidden’ if the option is disabled…but anyway i enabled everything manually.

I have no idea why it didnt work for you :frowning:

@stefanr740 - Sorry, I thought he had it unlocked, and I tried all the ways except his way alone. You guys both have MSI motherboards, so same/same
Anything I sent you is only meant as a test, not for continued use nor for further editing, if the root menu didn’t unlock in any of those files no other changes will help either (Mainly, don’t waste your time with that, as mentioned it’s only for a quick check for you to let me know results as asked back then)

@Falkentyne - you have this board and BIOS, with unlocked OC section? And if yes, only via AMIBCP edit? If yes, thanks, I will try that alone, had not tested that yet since stefanr740 said he already did but maybe he did incorrectly or with wrong version etc

No, I have the MSI GT73VR, and I manually unlocked all my menus with AMIBCP because I got sick of using the 4 key combination every time (I’m lazy).

Thanks @Falkentyne - GT72VR vs GT73VR, same/same for these purposes, so should be possible on his GT72 with AMIBCP alone then too. I am not sure if he unlocked at root levels or not, I think he only posted images of main sections with the settings.

@stefanr740 I think I know how to unlock this BIOS now, do you still need? If yes, send me new BIOS region dump via FPTw.exe -bios -d biosreg.bin
*Unless you already know you can flash modified BIOS via MSI built in flash tool in BIOS (usually rename mod BIOS and extension to match stock and it will flash. If that is possible for this system I can modify stock image for you to flash that way (not via FPT)

Hey guys can you tell me if this is the right settings for a 2021 Razer Blade Advanced with the 11900H? I recently unlocked my bios and I want to do the Imon Slope tweak.