Unsuccesful flashing of MX25L12873F Please help

Hello

I’ve been trying to flash a Macronix MX25L12873F chip on a Lenovo IQ2X0IH board. I aquired a bios through vinafix.com.
I tried flashing with flahrom and a CH341a programmer but flashrom detected chip “MX25L12805D” or “MX25L12835F/MX25L12845E/MX25L12865E”. I selected one of those options, even though it wasn’t my chip and the flashing was succesful. I tried it and it booted one time perfectley but stopped booting afterwards.
I then read on the flashrom supported hardware page that that chip was not supported. So I tried with the windows programs: Ch341a v1.34 and AsProgrammer 1.4. The chip is identified, erased, and written, but fails on verification and of course, does not load.

Any help would be appreciated.

Thank you

Keep trying other tools/version and dont loose time flashing/booting if NO verification is valid.

1.8v chip

And read here, u may get lucky.

I read 3V?

24.jpg



https://www.macronix.com/Lists/Datasheet…8Mb,%20v1.2.pdf

@MeatWar Thanks. I’ll check that out. Why 1.8V? I thought it was 3V



I think the 1.8V are for the MX25U12873F, mine is MX25L12873F

try a 10 uf 6v cap between + and -
and i think i read somewhere a resistor on pin 7
are you reading chip on the board ?
what is the laptop model? strange it booted 1 time after flash.