Updating BIOS of Gigabyte P35C-DS3R

@Iken ,

Thanks for your input. I took a look into your thread and it’s very similar to the issues I’m having. I also get the messages saying that all the drives connected to the ICH9R are detected and controlled by the ICH9R raid bios, but the Ctrl+I menu never shows up, and, when entering the BIOS setup, no drive shows up on the boot order menu option, only the drives connected to the JMicron controller.

I’m also thinking that might exist any kind of binding between the RAID ROM and the AHCI ROM or any of the others, that’s why I am curious to see if the which has the exact same size of the original one will work. If it doesn’t, then it might not be anything related with the ROMs size…

Anyway, I might take a look into the BIOS files from the other boards manufacturers, because people who reported success with the ICH9R are not from Gigabyte… who knows, maybe I could have better luck with ROMs from them?..

That is exactly what I thought but it didn’t work - even 8.x ROMs failed to operate in my board, though they did, misleadingly, flash successfully. That doesn’t mean you shouldn’t try, of course!

I would be very surprised if the same ROM taken from another board would make any difference; I suspect Gigabyte’s board/BIOS architecture is the problem here. It may be worth the risk but make sure you have a method to recover your BIOS in the event of a failure; my board has Dual-BIOS. When I tried to update the AHCI ROM with a slightly newer one extracted from a newer board, the DS4 failed to boot and recovered from the backup BIOS automatically.

Good luck!

Thank you very much, you could have just saved my board! :wink:
Mine is not Dual BIOS, is a Dual Virtual BIOS, so I don’t know if I would risk that… I thought the potential problems were only messing up with the MEMINIT ROM, I didn’t know that by using a wrong AHCI ROM we could also get a corrupted BIOS, so, I guess I would not try using the AHCI ROM from a slightly more recent Gigabyte board. I was considering trying with the ones from GA-EX58-UD4P, EP4C-UD3R and EP35-DS4 (even though this one I think it might be exactly the same of mine).

I also found this thread, which, supposedly, has an 8.0 RAID ROM modded to allow TRIM support in RAID-0 on the ICHR9. Is this info still up to date?

Yes, it is.
Please give us a feedback, when you have tried this OROM version.

Ok, here is my report of yesterday’s testing…

I will start by saying that there is no binding between the Gigabyte BIOS and the original RAID OROM, because I was able to flash two different ones which worked fine: the and the modded by CPL0 to support trim in RAID-0. However, all the others I tried did not work, even though all of them flashed fine:,,,,,, and All these tests were done using the modded BIOS that aaaaaa889 did the favor of creating for me. i simply replaced the OROM RAID at the end with each of these versions.

The two that worked fine have something in common with the RAID OROM of the original BIOS: a size of 64kB. I guess the reason for the others not being working it’s what CPL0 said here: "Possibly your BIOS can not deal with loading OROMs that are larger than 64k into memory."

Since I was able to flash a modded BIOS with a RAID OROM that was changed to support TRIM, my next step would be creating a RAID array and see if the TRIM is active or not. However, I would like to ask a few questions before doing that…
1) @Fernando or @CPL0 Since I was also able to load the, would you think it would be possible to ask CPL0 if he could add the TRIM mod to this OROM also? I know I have the with the mod, but I guess using a slightly newer OROM version would not hurt… :wink: Is him still following this forum (his last activity here was in April)?

2) Shall I create the RAID array with the BIOS RAID software, or with the Intel RST software on windows?

3) To be faster, I am thinking making a copy of my current system using True Image and then copying it back to the RAID array. Should that work fine? I do not feel in the mood for a fresh install… :wink:

Last, but not the least, thank you all for your support! It seems my quest is still not over and the possibility of success is still on my horizon… :slight_smile:

@ yesgrey:
Thank you very much for your interesting report.

Since I know CPL0’s BIOS modding method to get TRIM in RAID0 support, I have done it for you. Attached is the Intel MSM RAID ROM v8.5.0.1030, which has been modded by me to support the TRIM in RAID0 feature.

I recommend to create the RAID array from within the Intel MSM RAID Utility after hitting CTRL+I.

That should work, although I would always prefer a clean install of the OS.

Good luck!

Intel-MSM_RAID-ROM_v8.5.0.1030_TRIM-mod-acc-CPL0.rar (37.9 KB)

Thanks a lot! :slight_smile:

I will try it and then report back if I was able to make TRIM work in RAID0.

It has been taking me quite a little bit of time, because after several failed attempts of trying to copy my current OS installation to the RAID array I decided to quit and go with a clean install instead.

I’m now at the phase of drivers’ installation. I have installed the official RST 11.2 software package directly downloaded from Intel’s website. Will I be fine with it, or do I need to use the ones you supply here in the forum? It’s strange, because I had the idea that these drivers could not be installed on my chipset (P35) without your mod, but they installed pretty fine, so, I guess I was wrong… :slight_smile:

I am offering >here< the exact same package. So your choice doesn’t matter.

[quote="Fernando, post:1, topic:13801"]
Intel RST AHCI/RAID Drivers & Software Set v11.2.0.1006 WHQL
Note: These drivers are dated 05/30/2012 and suitable for AHCI/RAID systems from ICH7R/M up to 7-Series Chipsets, except X79 running in RSTe RAID mode (DEV_2826) and ICH8R/M+ICH9R in AHCI mode.[/li][/ul]
Just for clarification, I was not wrong... I was running my board in AHCI mode, hence why I had to use your modded drivers, and now, in RAID mode, the official drivers work, exactly as you state in the drivers' thread.

Final report
My system is now running in RAID-0 mode and TRIM is working fine!

I am using the OROM modded by Fernando (link above) and the official Intel WHQL drivers and respective RST software.

I have confirmed that TRIM is working using three methods:
1) TrimCheck tool, which reported that "TRIM appears to be working!"
2) Using the Hex editor test I confirmed that after deleting the file and emptying the recycle bin the area was all set to zeros. However, I struggled a lot to pass this test, because whenever I deleted the file the characters were always there, never zero. I then realized it was due to have HxD executable on drive C:, because it creates a ini file where it stores the strings used during the search, so, I was finding that file in drive C: and not the jpg file I deleted. I know you say (step 5) to continue the search to guarantee that the string is not in any other file on the drive, but I think it would not hurt also saying clearly that both the jpg file and HxD executable shall be outside drive C: - from your instructions we can get the idea that only the jpg file needs to be outside C: drive.
3) Before creating the RAID array, I only secure erased one of the drives (the other had the OS), so, when I looked into the RAID-0 array drive using HxD I was seeing a pattern of blocks of zeros and blocks of non zero characters, until the end of the drive, even though after the OS clean install only 10% of the array was in use. I used Anvil’s tool option “Trigger TRIM on free space”, and, when I rechecked the drive using HxD, it was “beautifully” all zeros until the end, being only different then zero in the first 10%, the used area until the moment.

A few notes/suggestions:
-Since the modded BIOS you supplied me is working, I would suggest you to put it also in the BIOS modules thread, and also saying that some old boards have a limitation on the size of the OROMs, which can not exceed 64kB, and that the 8.5 version would be the latest version with a size of 64kB. I was almost about to quit when I found this thread (I guess I’m a lucky guy ), because I was thinking that only OROMs and up could be modded to support TRIM, and that thread showed me it was not true, so, I think it would be good for you to say that in the BIOS modules thread.

Finally, I would like to thank @aaaaaa889 for the help modding my board’s original BIOS, @CPL0 for discovering how to mod the OROMs to get TRIM support, @Iken for sharing his previous experience, and specially @Fernando for all his support and for having created this forum with so much good information. You all have just helped me giving some extra life to my good “old” system.

@ yesgrey:
Thank you very much for your final report. It makes me happy as well, that you got the TRIM modded Intel MSM RAID ROM v8.5.0.1030 working and that you now even enjoy the TRIM in RAID0 feature with your old Intel P35 Express system.

Although I have always done the HxD TRIM tests on my system drive (Drive C:), I never found an ini file you are writing about and which may give wrong TRIM test results.
Question: Did you run the HxD tool as Administrator?

Thank you for your suggestion.

Yes, I ran it as Administrator. The ini file shows up if you use the portable version, so, maybe you have always used the installable one?

Yes, that will probably be the difference. Thanks for your reply, which clarifies the issue.
Since I do not want to change my guide regarding the partition C: (there are a lot of users, who haven’t split their RAID0 array into 2 or more partitions), I will add a notice, that the installation of the HxD tool is required for the test.
Thanks again!

Just to finish, I think a few images with the testing results would be nice…

My RAID-0 array is a mixed one, I am using an Intel 520 120GB and a Samsung 830 128GB in a 200GB array. I left some free unallocated space in both drives to guarantee higher performance consistency and durability.

Both drives single:
With Intel AHCI drivers modded by Fernando (it is showing because that was the version of RST software that was installed, and Anvil report RST version instead of drivers’ version)



RAID-0 array:
With default RAID drivers:


With Intel RAID drivers - write-cache disabled:


With Intel RAID drivers - write-cache enabled, and flushing enabled:


With Intel RAID drivers - write-cache enabled, and flushing disabled:


In my case, disabling the write-cache flushing does not give me any performance gain, so, it is not worthy the extra risk of having it disabled.

I haven’t too, just have some extra drives. but I agree with you, the notice stating the need of installation should be fine. You know, I was feeling so frustrated and disappointed that after all the trouble I went through with the BIOS modding, the several BIOS flashings and the re-installation of my OS ending up with TRIM not working… I tried first with Trimcheck, but instead of opening the cmd window and running it from it, I ran it directly from the windows explorer, and it hanged up, so, my only option was the HxD test which also failed all the times I tried… But then, a good night sleep left me fresh to try again the following day and then I realized all the mistakes I was doing…

@ yesgrey:
Thanks for the benchmark test results.

Slight correction: You probably mean the modded Intel RAID driver v11.2.0.1006 (v11.2.0.1527 is the matching OROM version).

Just to prevent any misunderstanding: This is the MS Win7 on-board Intel MSM RAID driver, but it has been made by Intel and not by Microsoft.
Here are the INF file details for Win8.1:

I suspect, that the driver was v11.2.0.1006 and not v11.2.0.1527.

That is an interesting result because I always got much higher WRITE scores, when the RAID0 device’s write-back buffer flushing was turned OFF. Maybe this is a specific result, when the Intel RAID ROM module belongs to the Intel MSM development branch.

Yes, not only that, but I also meant Intel AHCI driver v11.2.0.1006. And yes, the RAID drivers should also have been Already fixed.

Zitat von Fernando im Beitrag #37

That is an interesting result because I always got much higher WRITE scores, when the RAID0 device’s write-back buffer flushing was turned OFF. Maybe this is a specific result, when the Intel RAID ROM module belongs to the Intel MSM development branch.

Maybe. There are also some reports that say that with Intel ssd drives disabling the flushing might have worse performance, so, since one of the drives is an Intel one… Anyway, since you say the write scores are much higher, I think I will try again with a reboot after disabling the flushing, just to be sure it was really disabled…

Tried with a reboot after disabling the flushing but got similar results. The performance increase is meaningless with my current setup, so I will keep the flushing enabled.

@ yesgrey:

Thanks for the feedback, which verifies, that different systems may react different.