Updating Intel Matrix Storage Manager for Asus P5B-E

Hi Guys,
I need some help from you all, the experts I found this awesome (kudos Fernando and all that have contributed) forum while looking for possible ways of updating the Intel Matrix Storage Manager for my motherboard (Asus P5B-E) as I was looking to create a Raid 5 set up with 4 2tb disk and my version of the Intel Matrix Storage Manager ( wouldn’t acknowledge anything bigger than 2 tb…

So that is the background and I have looked through all the guides and followed them accordingly; using the latest official BIOS in MMTool – replacing the original version of the Intel Matrix Storage Manager and updating it to version (Intel_RST_RAID_ROM_v10.1.0.1008). This was the version which I found worked on other Asus motherboards like P5B-Deluxe (also using Intel ICH8R chipset) - based on the list of BIOS modding results.

It worked fine to insert it using MMTool and to update BIOS with the file worked as a charm, and after a restart and clearing CMOS I can get into the menus through pressing Ctrl+I without any problems at all (after activating the Raid option in BIOS off course). The version is then as intended and I can create Raid options if I’d like, and it seems to be fully functional.
However, now starts the problems – I can’t boot anything, not an usb-drive or harddrive, while having the option set as Raid (the biggest problem then being I can’t boot to a USB drive to reinstall windows that was installed while having IDE selected in BIOS).
While having no usb-drive connected it reverts back to the boot screen, and while having an usb-drive connected it only ends up displaying the error message: Checking VRAM.

And I’m a bit stumped here on what to do the next…

I have tried updating to an earlier version (Intel RST RAID ROM v9.6.0.1014) with the same result.
I have tried numerous different usb-drives with the same result.
I have removed all PCI cards from the computer just to be sure they didn’t affect it (with the same result).
I have removed all non-essential drives without success.

Can someone of all you wise members of this forum please help me out
(Maybe it just isn’t possible to get it working but will not go down without a fight, I will rather destroy the MB trying than giving up )
Thank you in advance!

@ leffek:
Welcome at Win-RAID Forum!

Although I am unsure, if this will help to solve your problem, here are my remarks:

  • If you want to get > 2TB sized HDDs supported, you have to update the Intel RAID ROM to v10.5 or higher. The RAID ROM v10.1.0.1008 doesn’t support them.
  • Since the boot order and boot functionality of the mainboard BIOS has not much to do with the Intel RAID ROM, I suspect another reason for your boot issues. Maybe there is not enough space within the BIOS.
  • It is possible to replace the Intel MSM RAID ROM v6.0.0.1017 of your BIOS by the Intel RST RAID ROM v10.5.0.1034 and even v11.2.0.1527 without any problem (I just have tested it with your mainboard BIOS 1807).

This is what I recommend to do:
1. Remove the OEM Logo module from the BIOS (this will give more space within the BIOS) and save the BIOS after having done that.
2. Replace the original Intel RAID ROM of the BIOS by the v11.2.0.1527 and save the modified BIOS again.
3. Clear CMOS of your mainboard.
4. Flash the modded BIOS.
5. Look what happens (finger crossed…).

Good luck!

Thanks for the answer Fernando! (and thank you for the welcome! )

Actually I got it to create the raid 5 at 5.5 tb with the four disks using so it seemed to accept bigger drives - but then I had the same problem with not being able to boot and reinstall windows…(or do you mean individual disks?)

I took your advice and used v11.2.0.1527 with success - it now boots and I am able to select the usb drive.

Now I get stuck at “windows loading files” when trying to install instead… (waited for 2hrs without any movement at all. then tried numereous times more)

I have tried everything again and I suspect it is related the RAID selection in BIOS - as I get it working fine when I select IDE in BIOS.
I have also ruled out any memory issues as I have tried each of the 4 memorysticks individually with the same result. I have also run memtest on them just to be sure.

I don’t know if you have any idea of what might be causing the issue but again would appreciate any help…

Thank you again in advance!

This is good news!

Maybe the Setup has problems with your RAID array, which obviously has been created with the very old Intel MSM RAID Utility v6.0.0.1017.
My suggestion: Break the RAID, create a new array by using the Intel RAID ROM v11.2.0.1527 and then retry the OS installation by booting off the USB Flash Drive.

Hi again,
Thanks for the answer.

The RAID5 array was actually created on, then I removed it again while trying to get it to work. So that shouldn’t have been a factor at all.
I also created a new RAID5 array with the installed without any success, every time it stops working when trying to load windows install…

I have done some googling on the issue and tried everything possible, removed all but one drive and tried each SATA port individually, and before I tried all memory slots/sticks individually with only one drive but all with the same result.

As soon as I switch over to IDE setting in BIOS it works directly…I don’t understand this at all, it was working to have the raid functionality active in BIOS before I updated to the latest versions of Intel RAID ROM - I had a RAID 1 array earlier (which I’ve removed as well). Just to be sure that it still was working I flashed back the original BIOS from ASUS, with and it worked directly to install windows from the same usb that failes when doing it on later versions…So I’m pretty sure that something in the updated file is causing the issues, but what and why I have no idea…

Can there be something else I need to edit in the BIOS file? or do you have any idea what might be causing this?

There is nothing to edit within the BIOS file.
Regarding the question, what may cause your issues, I have just 2 ideas:

  1. There is not enough space within the BIOS with the consequence, that the Intel RAID ROM has to be too much compressed.
    Question: Did you follow my advice to remove the OEM Logo from the BIOS?
  2. The Intel RST RAID ROM v11.2.0.1527 may not fully support Intel ICH8R SATA Controllers (the related Intel RST drivers v11.2.0.1006 do only support ICH8R SATA Controllers, which are runnng in RAID mode, but no Intel ICH8R SATA AHCI Controllers.
    The last Intel RAID ROM version, which will support > 2 TB sized HDDs and may be fully compatible with Intel ICH8R SATA Controllers running in AHCI and RAID mode, is v10.5.0.1034.
    If the Intel RAID ROM v10.1.0.1008 should work fine (after having solved the space problem), I recommend to try the Intel RAID ROM v10.5.0.1034.

If both should not work, you probably have to stick with your old Intel MSM RAID ROM module (may be updated without any problems to v8.9.0.1023), but with no chance to get >2 TB sized HDDs fully recognized.

Thanks for the quick reply!

1. Yes I removed the OEM Logo - that worked in the sense that it allowed me to boot from the usb drive, but then I ended up with getting stuck at windows install instead

2. Thanks for the info, I will try out Intel RAID ROM v10.5.0.1034.

Will return when I have tried it…


EDIT: It didn’t work with v10.5.0.1034 either…I guess that the fat lady now have sung, time to give up…I’ll just buy a cheap AMD setup instead and use…

That is a pity.

I can understand you, but I would prefer an Intel chipset system.

Any special reason?

Any special reason?

The Intel chipset systems have a better performance. Please compare the AMD AHCI/RAID drivers with the Intel ones. Then you will realize, what I mean.

Just in case someone stumbles upon this problem.

You can update ROM to 7.5.0 and it works, but seemingly no later versions.
ROM file is attached: After Win8.1 install - disks show as “Incompatible” in Intel RST BIOS