Updating ROMS on MSI Big Bang xPower II X79 - File included.

Hi all / Fernando,

I recently won an auction on eBay for a Intel 4960X ES processor and before I start upgrading I want to make sure my motherboard (MSI Big Bang xPower II X79) is using the latest bios with updated ROM’s.
Now I already gave UBU a go, however the bios file is an .exe. I also ran Phoenixtool 2.57, however I don’t understand this tool at all and I don’t want to mess around and ruining anything.

Can someone tell me how to update the ROM’s in MSI bios 7737v27 (for MSI Big Bang xPower II X79) or can take a look at the file and see if someone can extract it correctly?

I am looking to update the CPU microcode (if available at all), the onboard Intel NICs and Intel ROM drivers (both AHCI and RAID*)
Don’t know if there is anything else to update though, doubt it.

I have added E7737v27.rar as an attachment. This is the latest bios version (2.7) I could find on the internet.

So if anyone can take a look and extract the original bios file, I would be happy. And even happier if someone could update the ROMs I mentioned (if it’s not too much work).

Thank you in advance! All help is appreciated!

* Currently I am only using 1 SSD, so non-raid, however I will probably do in the near future. At the moment I am only using AHCI.



//edit forgot to add attachment…

E7737v27.rar (5.83 MB)

The first step should be to extract the BIOS file from the EXE archive.
I tried it by using CodeRush’s UEFIExtract tool, but it didn’t work.
Have you already tried to run the EXE file and then to look into your personal TEMP folder?

I cannot see any attachment within your post, but I got the BIOS (incl. installer) at MSI Support.

Yeah, I forgot to add the file as an attachment (me = stupid).

Anyways, I put it on an USB stick, but now it says my motherboard is not supported. I will try again when I get back home, I am currently at work and ofcourse I have a complete different motherboard here.
I hate it when they use installers from which you cannot extract files.

Will report back later… Thank you so far for the help!


//edit #1

Well I used MSI HQ USB BIOS Flash Tool. and it put the bios on the usb stick. From there I moved it to my computer.
I have included the file, called bios.rar, as an attachment to this post. I had to rar it, otherwise it wouldn’t accept my upload.

I will try to get it to work with UBU in the meantime.

//edit #2

Well when I run UBU it says "Firmware Volume is corrupt."
Followed by CSMCORE not present! etc…

Will try again when I get back home… Don’t understand why it doesn’t work.

bios.rar (5.83 MB)

@ HHawk:

I tried to open your attached bios.bin file with the AMI Aptio MMTool and CodeRush’s UEFITool. Both tools gave me the message, that the image is corrupt.

EDIT:
It is possible to open the bios.bin file with the PhoenixTool. According to the tool there is a BIOS file inside named “E7737IMS.270”.
If you hit the “Structure” button, you can see a CSMCORE file and 2 SataDriver modules.

Well I managed to get the bios file extracted from the .exe at home.
I have included it as an attachment.

Ofcourse UBU doesn’t read the file, unless I change it to bios.rom. Tried updating all stuff, however the bios.bin will become way smaller than before?
Is that normal, or am I doing something really wrong here? Instead of 8192 KB it was resized to somewhere around 5000 KB?!

The attachment I have included is the original one though. Thank you so far for helping and looking. :slight_smile:

E7737IMS.rar (5.13 MB)

Okay UBU working with the new bios file.

First screenshot shows the current versions of the roms

Before:

before.jpg




First updating the Intel RST OROM and EFI SataDriver.
Didn’t know which version I had to pick, though I think v12.9.0.2006 is the best for my MSI Big Bang xPower II X79 motherboard.
Could’t find which option I needed to pick for the OROM/EFI/SCU update, so I picked: v4.1.0.1026 OROM/EFI and v3.8.0.1029 SCU
Hope this is all right?

Next I choose to update the LAN OROM. Don’t think you can go wrong here.
After that I updated the AsMedia Sata Option ROM. I did some research and the MSI Big Bang xPower II X79 motherboard uses the ASM1061 chip, so picked the 1st option (v0.954) to update.

Last, but not least; I selected the option to update the Intel CPU MicroCode.

This is how it looked before the update:

before-cpu-microcode.jpg




You get 3 options presented, given I am going to use an Intel Core i7 4960X ES processor, I choose option #1 - Update CPU MicroCode SandyBridge-E and IvyBridge-E.

This is how the screen looks like after the update:

after-cpu-microcode.jpg




After this, I selected option 0 (Exit).


So did I do everything correctly, or should I have used other versions in regards to the Intel RST(e) ROM’s?

Thank you for your time and answers. And I hope this thread and screenshots will help other people also!

Hey, it seems everything worked fine. Your choice for the OROM is also ok, as newer OROM’s are better for 8 & 9 series chipsets. You’re good to flash the modded BIOS.

Good Luck hanson

Thank you.

One final question, which drivers should I use for these ROM’s?

Option #1
Intel RST(e) AHCI/RAID Drivers & Software Set v13.2.4.1000 WHQL
(or a lower version)

Option #2
Complete Intel RSTe AHCI/RAID Drivers & Software Set v4.1.0.1047

If I am not mistaken my motherboard (MSI Big Bang xPower II X79) uses the C600 chipset, or at least I read that somewhere. Which gives me the impression I should use the ‘Complete Intel RSTe AHCI/RAID Drivers & Software Set v4.1.0.1047’-set?
Am I right here and did I understand it correctly?

Thank you once again!

It depends what you decide inside your BIOS. When you set the controller as RAID RSTe, your OROM of 4.x will be in use and you have to use the 4.1.0.1047 driver. If you set the RAID to RST, the 12.9.x OROM will be used and you should use a driver of the 12.9 branch (I think 12.9.4.1000). Personally I recommend to use RST mode instead of RSTe. I also have a X79 board and with this setting the system is snappier and a bit faster.

Good luck hanson