Upgrading P9X79-E WS, parts list and modding is this all I need? Thanks

Hey Folks. It’s been a long time since I did any worthy than add a new ssd to My PC Build and its time for some upgrades I think. I have a few questions though if anyone could help me out.

I’ve read quite a bit and seem to be getting a lot of conflicting information so this my last ditch before I just buy the stuff and hope it works.

I currently have:
ASUS P9X79-E WS LGA 2011 Intel X79 SATA 6Gb/s USB 3.0 SSI CEB Intel Motherboard
Intel i7-4820K FCLGA2011 3.70 GHz 64 bit Processor 10MB Cache
Kingston HyperX Beast 32 GB Kit (4x8 GB) 2400MHz DDR3 PC3-19200 Non-ECC CL11 DIMM XMP Desktop Memory KHX24C11T3K4/32X
Geforce GTX1080 Ti
Windows 10.0.18363 Home

I have already flashed Bios to 1704+NVME+Bitfurcation Mod (thank you for your work)

My question is this, can I use these NEW parts to run a clean bootable install of Windows 10 from the Nvme/Pci

1. Samsung (MZ-V7S1T0B/AM) 970 EVO Plus SSD 1TB - M.2 NVMe Interface Internal Solid State Drive with V-NAND Technology
2. QNINE [Upgraded] NVME Adapter with Heat Sink, High Performance PCI Express 3.0 x4 to M.2 PCIe SSD (Key M) Card, Support PCIe x4 x8 x16 Slot

and would these also work?

64GB (2x32GB) DDR3-1866MHz PC3-14900 ECC LRDIMM 4Rx4 1.5V Load Reduced Memory for Server/Workstation
In addition to the former memory so thus making 96gb ram.

And is it as simple as plugging everything in and booting from usb stick to install to NVME or do i have a ton of work to do.

Thanks in advance to anyone that can steer me in the right direction, most appreciated.

Hi @Cole , I am using the same model.
I have a modded version of the 1704 bios applied.
Options for bitfurcation and nvme boot were added by @Lost_N_BIOS and @JackSted.
Which mod do you use? Maybe mine is a different one.
Problem is: nvme boot support works, bitfurcation does not, though the options show up in setup screen.

Short answer to your topic:

1.) SSD should work, same model did and does with my X79E-WS.
2.) Adapter Card should work, as I have used another card, but with similar function on my board and ssd.
BUT: You don’t need a bitfurcation for this setup to work. The single PCIe ×4 Card blocks the entire slot and its resources, respectively.
–You only need the NVME boot option of a modded BIOS if you want to boot from NVME.
3.) Bitfurcation might not work on X79E-WS board, or if it did, then on slot #4 (electrically ×8) only.

Your selected registered ECC memory will not work on the X79E-WS board.
The board is capable of mounting non-ECC memory up to size of 64GB (8×8), or unbufferd ECC memory up to size of 128GB (8×16, theoretically. Have only seen a few 16GB DDR3-1600 ECC unbuffered modules at all).
Mixing of ECC and non-ECC memory is also not possible.

Some additions the nvme and bitfurcation topic:
Currently I have an Evo Plus 500GB nvme working as system drive (on P9X79E-WS).
It was mounted via an Aqua-Computer PCIe 3.0 ×4 to M.2 Adapter Card.
So your choice should work also.

Currently I have my Evo mounted to an Asus Hyper M.2 ×16 Card.
So I was able to realize that the apllied bitfurcation mod is not functional.
I use the card on slot #4, which is the electrically ×8 Slot that is directly wired to the CPU, not to the PLX Switch Chips.
I have the resources for slot #4 bitfurcated to ×4×4 in Bios Setup, but it has no effect: a second mounted nvme is not recognized by the system.
The same configuration is recognized as independent SSDs on two virtual ×4 Slots when I plug it to my Z9PED8-WS board, which features bitfurcation by default.
So I could ensure that the NVMEs and the Asus card are working after all.

As mentioned, your EvoPlus should with your selected PCIe NVME adapter card.
You wouldn’t need the bitfurcation feature for this configuration to work, as your adapter card mechanically blocks the entire PCIe slot and, depending on which slot you use, the resources of 8 or 16 lanes are reserved by using the ×4 card.
If you’d want to use bitfurcation of a ×16 or a ×8 slot, you’d either need something like the Asrock UltraQuad M.2 Card or the aforementioned Asus Hyper M.2 card.
Then you could mount two or more nvme ssds there and plug the card to a fitting slot.
An alternative would be to use a PCIe ×16 riser card which features 4 PCIe×4 slots, and to plug single PCIE×4 M.2 Adapter Cards in there.

However, i suspect that options are few for the X79 E-WS Board, as six of the seven slots are wired to PLX PCIe switch chips.
Your i7 CPU provides three PCIe Root Ports, two providing 16 lanes each and one providing 8 lanes.
The two 16-lane root ports are already split and shared among 6 of the mainboards slots.
The 16 lanes of root port 2 (×16) are dynamically shared and switched to and between the mainboard’s slots #1 to #3, the lanes of root port 3 provide for slots #5 to#7.
So it is not really clear what happens If you split the resources for one of these ports in Bios Setup.
But as mentioned before, the PCIe root port 1 is directly wired to Slot #4 of the mainboard, which means that it should me able to apply bitfurcation there.
If a M.2 quad card was used in that slot, the first two M.2 slots on the card could be populated with nvme ssds.
The 8 PCIe lanes should be divided into 4 lanes for each nvme ssd.
That is what I tried, and the option for splitting the resources of root port 1 do show up in the setup screen of the modded bios, BUT… it is not funtional.
I am looking for a solution to that problem again…

@paranoid_android - Why is this first time I’ve seen anyone mention that, I thought you tested early on and it was working just not more than x3 NVME’s? Did others test this too on there P9X79-E WS?
Have you tested with more than one PCIE Card, to ensure it’s not a PCIE Card compatibility issue? Did you test all slots on your card? Does the same apply to the PLX’d slots too?

@Lost_N_BIOS - I could not belive myself that I had overlooked this for nearliy a year
I got the latest version of the bios by @JackSted (I guess, but I’m not sure). At that time, I did owe only one nvme SSD.
It was convincing to me that Root Port 1 which I had tried to set from ×8 to ×4×4 in setup had switched its appearance in HWInfo from one nstance to two instances.
At that time I had a PCIe ×4 USB card mounted to that slot.
And seemingly correct, the first instance of Root Port 1 in HWInfo featured the card, the second instance was empty.
This is how it was displayed by HWInfo then:


Later, when I had aquired the AsRock Ultra Quad ×16 M.2 card I used it with two nvme ssds in the Z9PED8-WS System.
That does feature bitfurcation by default.
Since the bitfurcated ports of both systems did show up in a similar way in HWInfo I was thinking that bitfurcation mod on the X79E-WS board was functional.
My bad that I did not test the UltraQuad card with the two nvmes in the X79-System right away, but I needed them continuously in the Z9-System for some months.

When I finally had time to mount a M.2 quad card to the X79-System and add two nvme ssds I saw that it was not working.
Here are some screenshots from the setup menu, which I had made right after flashing the mod image.
The settings are "default", I did not alter them:



I was so glad that the bitfurcation menu was unlocked now that I oversw completely that even when all ports are set to their default value and not being bitfurcated, the link speed options for every bitfurcated port (2A, 2B, 2C, 2D, etc.) show up. This should only pop up when the respective root port is actually set to ×4×4×4×4, ×8×8 or the like.
Setting any value for my desired port, root port 1 (from ×8 to ×4×4), did have no effect when back in windows.
On the Quad M.2 card, I had the upper two slots populated with nvme ssds. These slots lead to the first 8 lanes on the card’s PCIe cpnnector.
Since only 8 lanes are wired on the MB’s slot, only those 2 upper M.2slots could work.
And the nvme ssd on the top m.2 slot is the one that is recognized by the system.

However, in HWInfo there is only merely one Root Port instance shown at all now.
Which was different before, when I had the Port set to ×4×4 and had a PCIe ×4 Card mounted there.

Since I did not know what to do, I tried to set the Root Ports 2 and 3 to bitfurcation, knowing that could cause problems because these resources lead to the PLX chips.
When I set port 3 to ×4×4×4×4, the system did hang on reboot, with bios error beep signals. I had to reset the CMOS data to get the machine working again.

That I found out so late is clearly my bad, but I did not have the oppertunity to use two nvme ssds on the X79-Systems for a longer period of time.
Here is a screenshot of the current situation:


It makes no difference if I have the Port bitfurcated in bios or not, it is shown in device manager and HWInfo in the same way.
Even when I have only one nvme attached at this moment, would the bitfurcation setting be functional, a second root port 1 instance should be shown, which would have no device attached.
But instead it is missing completely.

Now the X79-System runs on a single 970EvoPlus which sits on top of the UltraQuad M.2 Card.
It is the system’s boot volume, which is fully functional thanks to your nvme boot mod.
The system even supports uefi safe mode boot from the nvme.

Would you consider looking at the image file again?
I have several now, maybe it’d help if provided them?

Oops, I see that I was answering to my problem in this thread.
I thought it would be my own thread in which I posted a simlar question recently.

Link speeds have nothing to do with lane width, and those are always visible in any edits I’ve done (i force them all visible)<br />If you leave BIOS settings at default, then nothing will be bifurcated, you have to change the settings to 4x4x8x or 8x4x4x etc.
In your above BIOS images, no bifurcation is set, so if that is what you are using then this is the issue! You need to set 4x4x8x or 8x4x4x (4x4x4x4x may work as well, unsure though since everyone says more than three NVME always fail)

I do not know how any of this looks with bifurcation setting applied vs empty or populated slots, so I can’t comment about any of that.
I suggest you test both PCIE cards with 2 NVME on this system, until you do that you can’t be sure if there is some issue with the card and the BIOS conflicting or something. Also, with board cards, test single NVME in each slot one by one, to ensure all slots work on both cards.
When using two NVME, you may need to use certain slots, like 1+4 or 1+3, or 1+2 etc, I am not sure, so that need to be sorted out as well, for both cards, so you aren’t mistakenly thinking it’s failing when maybe just wrong slots in use

Do you want me to move posts 3-6 here to your main thread?

@Lost_N_BIOS - Yes, it might be more transparent if the posts from 3 on were moved to my thread.

Aboute the provided images showing the Bios screens: MNaybe I forgot to mention, but those were made directly after flashing, before I had set any bitfurcation options.
That was to demonstrate what I thought was an error -that the link speeds were all displayed no matter if the ports were split or not. You said it was on purpose, I dit not know that, sorry.

What I wanted to say is that I had later set bitfurcation of port IOU1 from ×8 to ×4×4 wihtout any effect on the attached nvme ssds.
Only the one in m.2 slot #1 was visible in the system.
And that setting port 3 to ×4×4×4×4 caused system hang right before POST.

What is left to try out now is your suggestion to swap the nvme ssds between both M.2 quad cards an on all M.2 slots.
However I think that swapping the M.2 slots on the cards may have no effect as I can clearly see which M.2 slot is wired to which position on the PCIe connector.
For the Asus card, M.2 slot #1 is visibly wired to the part of the ×16 connector that’s corresponding to the conncetors of ×4 cards, and the wirings of M.2 slots #2 lead to a position that corresponds to the last section of a ×8 card’s conncetor.
So placing a nvme ssd on M.2 slot#3 should have no effect when using the quad M.2 card in a ×8 slot, as I desire for use with the X79E-WS board.

Next I will try to see what happens when I use the Asrock Card with both nvme ssds in the X79E-WS board instead of the Asus card.
To exclude the possibility that my problem relates to some kind of incompatibility between the board and the Asus Quad M.2 card.

@paranoid_android - Please link me to the thread you mean and I will move from #3 onward, I was thinking this one but I see now it’s not your thread - [Guide] - How to Bifurcate a PCI-E slot (5)

Please use 8x4x4x or 4x4x8x as mentioned, and then test with both cards, in all the ways I stated, so you can be sure you are using correct slots on the cards, that both cards work same/OK on that board, and that all slots on the card function OK too.
I only wanted you to test all that for the above reasons, not in any way to try and make bifurcation work right now, only to check the cards, adapter slots, and how/if they all function no matter what NVME is where etc.

Someone else with these boards, or your exact board, and one of these cards will have to help you further, I cannot advise on any of this myself

Good to see you did set bifurcation at least, you had me very confused for a bit looking at those images and your comments


Thanks for your reply, much appreciated.

So I got the pci adapter and 970 evo plus 1tb.

Got the system to boot from windows installation usb key, windows 10 home installed onto the 970. rebooted into fresh install of win10 updated the graphics drivers to latest and did the first windows system update then rebooted again, and now it freezes, hangs on a b2 which i believe is legacy option ROM initialization, so kinda stuck. i cant even get into bios right now to check things over.

Yes I have the same bios as you I think. 1704 with bifur

As of this morning have tried a cmos reset, unplugging power cables and battery for 15 mins.

It still wont let in bios, visually it seems like the keyboard isn’t switching on quick enough for me to be allowed to hit F2 or Del… but i could be mistaken.

Are you also saying that you had your boot nvme in slot 4(black) I have my GPU in slot 1 (Blue) which covers the next slot 2 (black) So I should remove from slot 3 (Blue) to 4?

Update Changed to slot 4 (black) still hanging on b2 not allowing boot into bios also tried another Bios from @miG174 (without Bifurcation) P9X79EWS.zip still no luck.

Ok, sooooo after a ton of trial and error… and removing pretty much everything except gpu, got it narrowed down to a b4 code which is USB HP, not sure why but it didn’t like the 4 port usb plugged in the back usb3… will have to figure that one out. but its back to windows booting again. for now…