USB Device not found - Port reset failure


I have a bran new build that has issues with the USB port not being recognized. The board is a Gigabyte Auros Z390 Master and right after installing Windows I had a few yellow exclamation marks in device manager as to be expected. So I installed my devices and downloaded the latest chipset software from either intel or the manufacturer and installed them, but I get this error still that one my usb devices isn’t recognized - port reset failure. I have narrowed it down to the usb type c port as thats the only one that does not work. I have tried uninstalling the device and reinstalling. Even tried Fernando’s modded usb Intel drivers. Still nothing except a message at every boot that my system has undergone changes and I should reboot. Not sure whats up with that…


Cleared CMOS and tried another BIOS version to rule out BIOS issues? If yes, it may be a faulty port, might have to RMA

Yes I tried all of that!

Would return it for a new one but Microcenter but they are sold out!

Also its water cooled so not looking forward to removing the board. It is doable though just a pain.

I wouldn’t have to drain my loop or anything. Just slide the board out of the cpu heatsink waterblock.


At least you checked the things already that I would have first too, that’s all I could think of as possible causes other than some hardware level component failure. Did MC say when they’d restock? Might be quicker to wait on them, if they’ll allow it, than an RMA

Can you see USB connected devices anywhere in the BIOS, maybe boot choices etc? If yes, does anything show in BIOS for that port when connected?

You can try UsbView to see detailed info.
I have found sources and have rebuilt it with newest Win10 SDK…