Use the E3 V5 series CPU method on the H110 B150 Z170 motherboard

Why can’t we extract ME region and microcode directly from Xeon v5 supporting motherboards? For instance, here download page
Gigabyte site

Really GA-X150M-PRO ECC officially supports Xeon E3 V5 and V6 also!! We can use ME region and microcode.

One person in the Russian YouTube segment launched E3-1235L V5 on the motherboard gigabyte. He just flashed the BIOS from the GA-X150M PRO ECC into his GA-B150M-D3H.
What do you think, if I also flash the BIOS from the GA-X150-PLUS WS to my ga-z170-hd3 ddr3, and then, FPT will replace the BIOS region, can I overclock the xeon E3V5?

It is another chipset = likely You simply brick MB

I had a feeling using C232/6 bios elements might do the trick. Once my soic8 clip comes i’ll have a look at this variation of the mod.

Meanwhile, i can confirm kaby engineering sample (ES) xeons are compatible with the mod too, i’m typing from mine now:

[OFFER] MSI B150A Gaming Pro Xeon Bios Mod

However, my Asus board didn’t like it:

QL32 Kaby Lake Xeon Engineering Sample on Asus Prime Z270-AR - Works but Can’t Restart

Is it possible to use Xeon E3 v5 without disabling ME? I don’t like this idea since MB would start very slowly. Maybe I can simply use some appropriate version of ME firmware?

What board are you using? Not all of them start slowly. It may be possible by changing SKU or porting the ME region from another board, but I don’t think anyone has tried it yet. I might try with my MSI soon.

I have a lot of MB. I want to use Asus H170I-PRO - it has BIOS chip on panel, easy to flash on CH341a. Also have a lot of MSI B250, B150

Asus boards shouldn’t have a delay when starting without ME. no warning as far as i know, either.


Hi friends I’m new here and sorry about the English. I’m Brazilian and still learning English. I saw in the topic subject saying that this process can be done in boards with h110m chipset too, but in neither of the topics anybody did in this chipset, I saw only in B150 and H170. I will test it in a Asus board h110m. Does anybody tested and confirm that work in this chipset? Other doubt… The only program that I will use is Flash Image Tool? If the Me version isn’t compatible (11.0.xx.xxxx) what software I can use to change the ME version of my image? Thanks a lot.

Im running MSI E3 GAMING KRAIT V5 with a Xeon 1230v5, I can modify the BCLK frequency but the multiplier is locked at 34 with all cores or if you do some fiddling 36… I think if you turn off the power step stuff.

Annoying as I learnt all this bios extraction and modification stuff inorder to be able to unlock the Xeon multiplier and I havent been able to get it to work. Ive gone as far as to upgrade the microcode in UBU and go through all thee settings in AMIBCP and enable the "user" mode - but this doesnt work.

Looking for help trying to create a BIOS for my board that has unlocked multiplier for my 1230v5 - maybe this is locked at the hardware level though.

Bro i have B150M Pro4 and i want to work e3 v5 , please guide me what im going to do because im not clearly on instruction

On FIT only BIN And XML can be Load , how to load asrock bios .00 file format to FIT Thanks Advance

Hi guys,

sorry for my english.

Sorry for refloating this topic.

The thing is, I have a Gigabyte B250-Fintech motherboard and there are 2 CPU support lists.

One is this:

and the other is this:

This is the same motherboard but there are different supported CPU lists.

The thing is, I have a Xeon E3 1230 V5 which is listed on the second list (Aorus site) but not on the Gigabyte one.

If I put the CPU on the board, it turns on and after a second it turns off.

I updated the BIOS to the latest version available (F4a) but it does not work with the Xeon (Checked on a server board and it works fine)

Is there a modified Bios that I can use to get the Xeon on the board to work?

Thank you very much for your time

Try this: (4.6 MB)

Thanks, but it didn’t work, in Q-Flash it says invalid bios image :sob:
Thanks for your time and quick answer dude!

you could try to flash it using modded efiflash or intel fpt

thanks, anyway I’m afraid of breaking the motherboard and I never used what you tell me,


1 Like

hi Is there a modded BIOS I can use to get the Xeon e3 v5 1220 to work on the board?

Thank you very much for your time, is it a z170 hp3 ddr3 or take care of what I need

@Militar5030 Hi and welcome to Win-Raid forums.

It should be possible to run a Skylake Xeon on the Gigabyte Z170 HD3 DDR3 but you must use BIOS F20 or later.

As the Skylake Xeon microcode is already in the BIOS (CPUID 506E3) you don’t need to add it.

  1. Download and extract CoffeeTime v0.99 and drag and drop the BIOS file onto it (or open CoffeeTime and select the BIOS manually and click continue).

  1. Click on the two dots in the ME section and select ‘ Corp Cut’ from the drop down list at the bottom then click on ‘Replace’

  1. In the ME section click on the arrows to change ME to ‘Disabled’

  1. In the Fixes section for ‘ME Recovery’ click on ‘Remove’ so it turns green (this is usually required on Asus boards but I would do it just to be safe)

  1. Click on ‘Save image’ at the bottom and give the file a new name (note that it will have the extension .bin)

  1. If you want to use Q-flash to flash the BIOS you must edit one byte using a hex editor so that it will accept the modified file.

Otherwise use a modified version of Efiflash from a bootable USB drive.

WARNING & DISCLAIMER: There is a risk when you flash any BIOS that the system may become bricked and this risk only increases when you modify the BIOS. I am not responsible should you brick the board - you must decide if the risk is worth it. I highly recommend obtaining a hardware programmer to recover from a bad flash.

WARNING #2: Please note that this motherboard has ‘DualBIOS’. If the board fails to boot after flashing a modified BIOS it may attempt to boot from the backup BIOS automatically without any warning message! If you then flash a bad BIOS over the backup chip you will brick the board!

1 Like

hi , I tried this method to my lenovo m900 and it success to accept e3 1245 v5 on chipset Q170 , thanks for all
this is motherboard IQ1X0MS V1.0
modified with coffe time 099 and CSME tools v11 , and finaly flashed with CH341A Programmer , because my motherboard deos’nt accept fptw