Used SPI programmer on Gigabyte b250m now reboot loop

Do I need to unlock any kind of protected regions if I do use an SPI programmer on Gigabyte motherboard?

All I did was use the me_cleaner (-s) to set the HAP bit.

after that system is power cycling after bios screen.

Also, when I used the bios flashing tool inside the bios to restore it, there was a strange graphical option to flash the BIOS without ME region. It recognized that I had edited the ME region and offered a graphical option to flash with/without the ME region.

I flashed first without the ME region and it was on reboot loop. then I flashed both and my bios was fixed. So the problem was in the ME region? is there some kind of protection mechanism that could inhibit proper operation from a programmer?

extracted bios…iew?usp=sharing
edited bios…iew?usp=sharing

@medisabled - Don’t use ME_Cleaner, problem solved If you really feel you need this done, do it manually using Intel FITc.

No, there’s nothing special needed done with Gigabyte BIOS before using programmer, maybe was a failed write (even if verified) Did you dump after write and compare via hex?
It’s most likely this is the issue, have you ever written a BIOS to this board successfully yet, via programmer? If not, test it now with stock unedited BIOS, be sure to erase first and blank check, so you know 100% the outcome is solely based on what you write to the chip.
Sometimes BIOS updates, depending on version, ME update or not etc, that offer full BIOS update w/ ME or BIOS without ME update (Partial).
Some BIOS/boards give you this option (Full/partial) or Fast/Intact Fast = EUFI/NVRAM/DXE PEI and Intact includes ME + rest previously mentioned) each time you update when using Qflash
Sometimes backup BIOS updates with Full/Intact too, and sometimes it does that with fast too but less often, depends on security updates like ucode/ME or Qflash changes

Sorry to disturb you again.

Is there a guide available that shows where I have to set the HAP bit because I only want ME disabled with as little trouble as possible.

So if I somehow find the HAP bit on a hex editor and change it it wouldn’t work, would it?

[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

This guide talks about cleaning the Data region of ME/TXE etc. Do I need to do everything here? What is the purpose of this guide would you give me a clue?

i redid everything, this time with the full cleanup with me_cleaner.

i did everything twice, checked with diff command and after write I read the bios back and it was identical to what i read from the bios.

there are checks that are making me_cleaner worthless. which guide do I follow please give me a clue. I will read thoroughly but currently in a hurry so I cannot read the whole forum please.

What’s the reasoning here? Sorry, I don’t know of any guides, but I do know you can find ME disable settings within ME while using FITc, I suggest you disable there instead.
That guide you linked, yes, that is the proper way to redo and put a clean ME into the BIOS. That is what I suggest using, and once you are done with the setting changes it mentions, then find the ME Disable setting and disable ME before you rebuild the BIOS.
I believe the setting is the last one in ME Kernal Section, set to 0x00000001

If i remember correctly, unless you have a specific version of ME gigabyte 1151 boards don’t support disabling it.

I didn’t think “Boards” were in charge of this @_haru only what you set in the ME itself. I’m not an ME specialist though, even more so am not when it comes to disabling ME.

@Lost_N_BIOS I’m not much of an expert either, but IIRC Gigabyte BIOSs for 1151 motherboards in general don’t work with disabling ME. This is why you can’t run Xeons on them. However i did hear that Dsanke found a ME version that you can downgrade to first, then disable to get it booting without ME.

I think that’s it, it’s more about the ME version used above all else, disabled or not.

Could you give me a link/clue abt the BIOS version @_haru san?

I’m in a twist here, Flashed the BIOS with ch341 many times. verified everything.

Today, I took the advice from someone on Lordkag’s post that Saving the BIOS from the QFlash utility inside bios makes it calculate all checksums again. Used that method to flash a BIOS supplied by Gigabyte. So it was configured+accepted by BIOS utility+checksums calculated by Qflash.

So the only problem is the HAP bit. There is definitely a check that stops HAP bit enabled boards from booting.

Now how does one find this exact ME version number?

@dsanke ^^ Can you help advise here, thanks!

Use MMTool or UEFITool remove F1FCD66F-8966-441E-909C-77F211AB9C3E/MeRecoveryDxe.

Thanks @dsanke - so after that, no specific ME version needed to be used before disable HAP bit?

@Lost_N_BIOS Yes ,no specific ME version needed.
If you just want set HAP bit , just do not use 11.0 for 200 series.
If you want run xeon, you need corporate sku me fw.

I don’t know how to thank you for this.

However, my board got bricked after all of this and a successful boot, I accidentally enabled intel boot guard.

Is there a way to undo the boot guard and unbrick my motherboard? I tried flashing my old SPI image no luck, no luck with stock bios update downloaded from OEM either.

never even prompts the bios screen.

Last file I flashed before it bricked. Is it game over for me and I have to buy a new motherboard?

How exactly did you "Enable" boot guard? Do you mean you did that with Intel ME tools, ending manufacturing and setting bootguard active at FPF? Why? I mean how can you do that accidentally???

It worked after restarting a few times.

Thanks to God and dsanke.

EDIT: I was messing around with the settings and accidentally set Boot guard. I thought I set it at the FPF so gave up on my mobo. Yesterday I left the PC on for some reason, and it booted after a few restarts!

EDIT: spelling mistake

@medisabled - good you were able to get it working again! Now you can check with MEInfoWin and see if you did enable Boot Guard at FPF, it will be at bottom of MEInfoWin report