Using CBROM to get AHCI option in old Laptop

Hello, it’s me.
Please could someone try to open this Phoenix BIOS using CBROM:…

I’ve tried with four different versions (182,195,196,198) but it just hangs there with CPU at 100%. It’s possibly one of those that can’t be opened using CBROM but it’s also possible that I’ve made a mistake somewhere. I’m not even sure I’m working on the correct file. I tried to add an image of what I typed and where it got stuck but I hit the language barrier.

Additional info:
I’m trying to enable AHCI on a laptop that was bought in 2006. The original BIOS didn’t have the option to select it, which didn’t surprise me, but I’m disappointed that neither does this latest version. In fact there was no visible difference between the two BIOSes.

The Laptop is: Toshiba Satellite Pro L20: Model no. PSL25E-00600DEN
The controller is: Intel 82801FBM Ultra ATA Storage Controller – 2653

Apparently 82801FB is Base(ICH6) and 82801FBM is Mobile(ICH6M) and that ICH6M supports AHCI.
When I type the VEN (8086) and DEV (2653) into it says SATA AHCI Controller.

It’s my understanding that XP never had AHCI drivers included with it and when I installed it I didn’t press F6 to supply additional drivers. So as far as I’m concerned it’s definitely running in IDE mode. Device manager says that the installed driver is v6.1.0.1004 (dated 24/03/2004).

Is there such a thing as ‘Auto’ when it comes to SATA controller settings in BIOS? Would I be wasting my time installing an AHCI driver in XP and rebooting to see if it magically worked? (I’d make a drive image first which I could restore using a Macrium Reflect Boot disc when XP inevitably BSOD on startup).

Thanks to the instructions on this forum I’d have been quite confident using CBROM, initially to just compare the module version numbers of the old and new BIOSes, but then to replace modules with ones I extracted myself from other BIOSes. If PhoenixTool turns out to be my only option then I don’t think I’ll bother. It seems a bit too complicated and I’m not sure about the security implications of using a tool developed by an enthusiast. And flashing a BIOS that someone else modded isn’t all that appealing either.

Also, I’m a bit concerned about potential problems with my DVD drive if I manage to switch to AHCI.

Feel free to comment on anything I’ve written, especially if it’s wrong. Thanks.

@Me1 :
Welcome at Win-RAID Forum!

You have to use the PhoenixTool.

No. You will only get the on-board Intel SATA Controller running in AHCI mode, if you have chosen the related BIOS setting option (either "AHCI" or "Enhanced IDE").

Yes, unless the BIOS gives you the option to choose "AHCI" or "Enhanced IDE".

Dieter (alias Fernando)