vBios problem based on Coffee Lake CPU with B150 motherboard

Hello guys, I successfully moded my bios thanks to Revlaay’s automated tool, and my computer(ZOTAC EN1070) works well with 9400f cpu and GTX1070 (MXM3.0B version) together. The only problem is that the vbios I’m using for 1070 is a MSI official version which enable only 1 (out of 2 in total) DP output port works, and also some important information about the graphic card, such as chip temperature, can’t be correctly shown in tools like HWinfo. The reason I use MSI version vBios for my original ZOTAC graphic card is the original vBios will lead to Nvidia driver failure together with 9400f CPU, while it works with no problems when I use 7700t. I was trying to figure out the reason of this situation but seems like it can’t be solved on software level because I checked the Device ID and INF file in Nvidia drivers, which match well with each other, no matter what CPU is being used.

In summary, my situation can be list like this:
7700t + zotac vBios = works well
9400f + zotac vBios = Can be powered on, but Nvidia driver stop working(Error Code 43) as soon as entering the windows system
9400f + MSI vBios = works well
The mother board BIOS I’m using comes out from Revlaay’s MOD tool

I firstly think the MOD tool integrated PCI fixing step (enable Coffee Lake CPU to work on a 100/200 series motherboard, many thanks to Mov AX) has some problems lead to the driver failure, but since the MSI vBios works well, I arbitrarily guess that ZOTAC original vBios has some restrictions or errors lead to the graphic card not able to work with Coffee Lake CPU (or the moded motherboard SKU Z370). So I hope someone can help me to figureout if the Zotac vBios can be fixed through HEX editing or the problem was caused by any other problems, Thank you!

Both the original and MSI vbios are affixed in the appendix, please check them out if necessary.

1070vBios.zip (298 KB)

@kenarp - MSI has UEFI Version 30003 and Zotac has 30004, not sure if this matters, but I noticed this. Also, MSI Has InfoRom present and Zotac doesn’t, and also no IFR/IFR Subsystem on the Zotac either. MSI has EFI Rom, and the Zotac does not.


Neither are updated to latest GOP version, this may help with both, but certainly might with the Zotac. With no EFI Rom, you’ll need to boot using Zotac on legacy/CSM not UEFI/Secure boot mode


Thank you for reminding me these differences. I noticed the difference in GOP part and updated the Zotac vBios through the GOP update tool then burned the moded vBios back with a programmer. But still, the Nvidia driver doesn’t work when 9400f being used. Sorry, I don’t really know the function of EFI ROM( I thought it’s identical to GOP), do you think the lack of EFI ROM is a potential reason of driver failure? The most thing I want to figure out is which part in the Zotac vBios doesn’t fit Coffee Lake CPU while it works well with Kaby Lake ones. I have no idea about some items you mentioned above, like Info rom, IFR subsystem and EFI rom, I’ll appreciate if you can explain a little bit more on them, and how they can possibly influence the Nvidia driver. Thank you!

@kenarp I probably described some of that wrong/backwards, vBIOS is not my thing I think the MSI has legacy vBIOS image and the Zotac doesn’t, that was main thing I see there.
@lordkag @Sylar76 maybe @hellm and some others I can’t think of right now can help with this if they have time, I think you need legacy image added to Zotac (or from 9400f boot EIF/UEFI/Secure boot only), maybe some other things need changed too as I mentioned this is not my thing

I too updated the GOP as a test, and it all still looked the same, the other stuff I pointed out, all still same, no IFR filesystem, no InfoRom

I’ll give it a try as soon as possible. Stay tuned.

I appreciate your help so far. I’ll keep reporting my problems and new findings back as long as I get anything new.

Thanks, I’ll be ready to do any kind of works related to vBios and Bios since I have stocked several more flash chips, programmer, soic socket and solder iron, basically all the items will be potentially needed.

@kenarp - get SOIC8 test clip, then you wont need to desolder/solder anything

Thanks @Sylar76 !! Do you think maybe it’s due to legacy rom missing, or whatever the IFR Filesystem etc stuff that’s missing?


Try this please.

ZOTAC1070.ZIP (150 KB)


There are slight differences between MSI and Zotac (like PCI Subsystem ID for example) via hex editing.

Now the Zotac rom should match nvidia info required.

Thanks so much for your help on this for kanarp, and the info on this @Sylar76 - Was I correct in that the MSI has legacy image and the Zotac one does not, or both only EFI/GOP?


Did you, or is it possible, to copy/put a legacy image into the Zotac too, and is/was that also possibly part of the issues.
Thanks again for the help, I don’t edit vBIOS often, need to always try and learn more about this so I can hopefully help with vBIOS one day like I know regular BIOS now.

Hi Sylar76, thank you for responding so quickly. I burned the moded vbios in but unfortunately, Nvidia driver still doesn’t work with 9400f. I went for 7700t then and it worked well as always. Please let me know if any other kind of feedbacks would be helpful /useful to you.

I think there is a lack of compatibility between Zotac PCI subsystem IDs and 9400f. I haven’t any other solutions yet.

Yes, I do have a test clip but the issue is that I have to spend considerable time on making sure the clip has successfully connected to the chip. I’m actually thinking if there are more test on vBios to run, I’ll solder a sop8 test socket on the board to substitute the solder fixed flash chip.

Thanks though. The thing makes me feel really confused is that whatever vbios and cpu being used, the graphic card get the same Hardware ID, but on the same time only MSI vbios can make driver works under 9400f. The only difference between 7700t and 9400f platform is the altered device instance path, as it shows below.

7700t: PCI\VEN_10DE&DEV_1BA1&SUBSYS_141319DA&REV_A1\4&39596A30&0&0008
9400f: PCI\VEN_10DE&DEV_1BA1&SUBSYS_141319DA&REV_A1\4&8F11CFA&0&0008

The other problem is graphic card fan will gradully speed up after powered on, finally the computer will shut down when the fan speed reached at a very high level (probably maximum I guess), this happens only when the driver can’t be loaded successfully. Actually there were several times the driver can’t be loaded under 7700t as well, but this situation only happens when I insert the 7700t right after removing 9400f everytime, but after restarting the system it goes away.

I feel like that would be my very last time to struggling with a test clip, believe it or not I almost spent all the passed 2hours on clipping the flash chip to burn the MSI vbios back, but still failed at the end. I’m going to buy a test socket which can be soldered on the grahic card board then do more possible test.

Hope you can get the socket soldered in easier than fighting the clip! Maybe by time it arrives Sylar76 or someone else will have more vBIOS for you to test

I noticed in the vbios provided by @Sylar76 , all the missing part in the original Zotac vbios have been added, but unfortunately the driver stll didn’t work as you guys have already known. Since I still want to figure out the reason, I searched on the internet and found a Nvidia official document about vbios content (Link: https://download.nvidia.com/open-gpu-doc…tion-Table.html). During reading this document, though I don’t really understand the terms they used since I have no hardware/software development background, the description of PCI Expansion ROM still drew my attention. Just wonder if there is a possibility that the operation of driver partially depends on the PCI Expansion ROM, where Zotac original vbios lacks support to coffee lake cpu while MSI did a good job. Please let me know any potential reason of this situation, I’d like to do more test, basically for perfection of my PC. Thank you!

I’ve been having similar troubles with a Zotac EN1080k. Running fine with a modded BIOS and an i7-7700; error 43 with an i7-8700.

The closest equivalent Coffee Lake system I’ve found is the ASRock Desk Mini (Z370/Z390) which comes with a GTX 1060, 1070, or 1080 and supports Coffee Lake CPUs. It has two DisplayPort and one HDMI output, so it may be a better match than the MSI vBIOS. If the vBIOS for the Desk Mini can be found, it may be compatible or help with figuring out what is missing in the Zotac vBIOS.