Very low write speed to flash drive | Usb 3.0 Renesas/Nec| Win 10 64 bit 1607 | Usb 3.0 Not Working???

Just built an Asus Maximus IV Extreme motherboard system whose components were lying new in a box for 6 years.

I had tried to copy 12 gigs of data from the main SSD to a Sandisk Ultra 16GB usb stick. The write times were ridiculously slow, around 10Mb/sec.
Motherboard uses dual Renesas usb 3.0 host controller, using latest driver version, Firmware Version 4021
Flash benchmark data:

It would appear that Renesas Usb 3.0 is not working.

Using 2700k processor @ 3.8Ghz, 32MG Corsair Vengeance memory @ 2133Mhz, Samsung 850 Evo 500MB SSD.

Legacy Usb Support : Auto
Legac Usb3.0 Support: Enabled
ECHI Hand-Off : Enabled
USB 2.0 Switch : NEC

Had attempted to change drivers to Microsoft/Renesas Usb3.0 Host Controller 0.96, but that failed because the device manager showed two Super Speed Hubs (Non functional).

@charlestek :
Welcome at Win-RAID Forum!

Have you already tried to clear the CMOS of your mainboard?
This was the method how another ASUS Maximus IV owner solved his USB 3.0 problem (look >here<).

Good luck!
Dieter (alias Fernando)

Fernando, the device manager tree looks fine with no yellow exclamation point devices. I just did some reading, apparently a write speed around 10-15Mb/sec is ?? normal for usb 3.0? I didn’t realize that the normal speed was so low. Please verify this fact for me.

I also have a Sandisk “Extreme” model usb stick, which I know is capable of higher write speeds, but I’m not really testing usb 3.0 flash drives, I’m trying to make sure the motherboard has normal usb 3.0 speeds.

I was doing some more reading. Definitely the write speed of the Usb 3.0 should be higher, but I don’t know what the issue is. Perhaps the Renesas version 1 is just a very poor implementation, I don’t know.

How did you get the benchmark? From the internet, or is this from your exact drive?
Have you tried this drive on a different computer, and got better results?

I would not call it a benchmark, but I got it from using the FlashBench tool on the computer in question using a 16gb sandisk ultimate flash drive.

I have since tried to install the Microsoft/Renesas Usb drivers and when you do, the system automatically installs a non functional super speed driver, per this MS technet article:

"For certain unsupported USB 3.0 hubs, Windows may disable the SuperSpeed portion of the hub and report it as “Non Functional” in Device Manager."

Which means that Microsoft does not really support the uPD720200A Nec usb 3 controller for Win 10.

This is really irritating to me, as I could install an extra Pciex card for usb3/3.1 to make up for the useless Renesas ports on the Maxiums IV-Ext, but I have only one extra operational card slot, having used two for the two video cards. I want this slot for my telephony Modem.

Ok, so the speeds can be high, but they drop off when copying large files? edit: Oh wait, you mean read is fast, but write is slow… That could just be a thing of that particular flash drive.…-at-superspeed/
Try that usbview program they refer to.

I have the usbview program. The speeds don’t drop off, they are consistently low. It is normal to drop off in the graph. It is a problem with the drivers for the earlier Renesas chip and Microsoft support for the drivers which appears to be non existent. Perhaps the Creator’s Edition has some fixes, I don’t know.

I think it’s the flash drive.…6GB/Rating/1658

Don’t forget it’s almost the same as with those SSDs, that have a quite high reading speed, but bad write speed.

jj, I didn’t realize how bad that Sandisk Ultra Flash drive is.

I just ran the tests on one of my Sandisk Extreme flash drive’s.

Write speeds are much better. However, the only fair comparison is to compare these results to a computer using an Intel Usb 3.0 chipset, which I have on my Lenovo thinkpad laptop.

Will check those speeds shortly.

Ok, Just ran the test on my W530 Thinkpad.

The Intel usb 3.0 chipset performs somewhat better.