Voltage management via BIOS stopped working after crash

Hey there,

I am sorry if this is the wrong subforum, but I was not able to find a more suitable place to ask for support.
Please move this thread if I chose the wrong subforum.

My issue:
I have recently upgraded my laptop to an Intel 9700F, with the help of a modded bios.
To stabilize the CPU, I did add some overvolting and had a stable device.
While this initially worked just fine and was stable all around, it did crash when trying to play Valheim.
Strangely enough, it kept crashing afterwards - just booting into Windows and letting it sit there could lead to a crash.
After some digging, including installing Linux and crashing there as well, I found out that the voltage management via BIOS seemed to no longer work.
I attributed this to the first crash (maybe something got overwritten?) and reflashed the modded BIOS, as well as clearing my CMOS.
However, the voltage management via BIOS is still not working - I can still change voltages via Throttlestop (Windows) and undervolt script (Linux) just fine.
What I mean by “not working” is that the settings are set up in the BIOS and are still there after a reboot but seem to not be applied when booting the system.

The question:
Is it possible that a register / setting is persistent across CMOS resets and BIOS flashing (via Intel FPT’s tool along a -greset command) which could cause this behavior?
Or is it a known issue of the coffee lake mod on Z170s that voltage management via BIOS does not work? (even though I am certain that it did work during the first days up until the Valheim crash)

My setup:
Eurocom Tornado F5 (a rebranded MSI 16L1, offering a LGA 1151 socket) running a Z170 motherboard
Intel 9700F (via the modded bios I have attached)
nVidia 1080 GTX
32 GB Ram

Thank you very much for your support and insights.

E16L1IE9-me.zip (4.74 MB)

I would like to add some details, in case anyone else is stumbling across this problem.
So far, I have not found a solution or definitive answer.
However, this user has experienced a similar issue, which points to a general problem with the mod / BIOS (perhaps in general, perhaps only on this device):

I would think that undervolting is based on MSR which is more privileged then bios it self.
Bios is setting some of msr’s, of course but it is internally set probably by microcode which is firmware of cpu, so this is reason you observed that strange situation, despite relashing bios, the problem was still persisting.
But if you can set voltage during runtime via Throttlestop than you are winner anyway no matter what bios is thinking about :slight_smile: