VROC, Asus Hyper m.2 & Supermicro

Hello! I need some help, guys:)))
My config:

Supermicro X11DPH-T
Xeon Gold 6246 х2
Asus Hyper m.2 card V2 VROC Ready
NVMe Samsung PM983 1ТБ х4
Supermicro VROC Key VROCSTANDMOD.

I want to assemble RAID-10 on Asus Hyper m.2 with Intel VROC, but I have a problem - motherboard does not recognize disks correctly.
As a result of the setting, all 4 disks appear on the Asus card, but only one of them gets into VROC, the other 3 disks remain in the BIOS.
Widnows has a similar situation: in Device Manager, disks are recognized differently.
In the “Server Management” utility, when trying to create an array, only one disk out of 4 is recognized.
I attach screenshots and hope for help in solving the problem.







i tried to find disks in UEFI Shell, got these results:
3 disks are recognized as "Samsung NVM Express Controller and 1 disk “Volume Managment Device (VMD) Controller”

@RksW - Wipe all disks to RAW, and then create partition after you make the array (GPT). I see in your last image of post one, 3 NVME initialized as MBR, you can’t use NVME in MBR it needs to be GPT initialized

You can use diskpart in windows from OS (Direct from any CMD Prompt), or from installer ISO (press Shift + F10 on the first setup screen where you pick language)
Either way, remove all other drives, so only the NVME is there, and any other disk you will recognize by size/name etc - so you don’t accidentally wipe wrong things.
I suggest you wipe all four NVME’s, so they are all same and all RAW

At CMD Prompt >>

>> Diskpart
>> List disk << Here, identify by size, and then note the number which disks you will be wiping to raw here (If in windows, these #'s will match what you see the drives shown as in Disk Management) - Be sure you do not select your USB or main OS drive if in OS
>> Select Disk # << here, replace # with first NVME # you want to wipe to raw. Once done with first NVME, you will repeat starting here for 2nd, 3rd, and 4th
>> Clean

Then repeat from “Select disk” after clean first NVME above, selecting second NVME, then clean, then select third NVME and clean, and finally select forth NVME and clean
Then >> Exit and your done. Then reboot and do your array setup and it should work properly now

@Lost_N_BIOS , thx for you answer!
I erased all discs to RAW, but the result is the same :С VMD sees only one disk on one card:С
(now i install 2 x Asus card with 8 disk)

You’re welcome, sorry it was not the immediate solution!
All NVME are same model, correct? Keep working with one card only, don’t add to the pile… yet
Maybe this is a key issue? Sorry, I have not dealt with this before, only replied hoping the MBR thing was the issue since it caught my eye. Maybe best to get help with this on Asus forums since it’s Asus card, or directly as SuperMicro.
You do have BIOS bifurcation set to 4x4x4x4x correct?

Here is EVGA guide, maybe some of these settings will be similar enough for you to see some setting your missing to change?
https://www.evga.com/support/faq/FAQdetails.aspx?faqid=59720
Or, also, this Asus BIOS setting guide for VMD and some settings mentioned there could help, see page 1.10 - https://dlsvr04.asus.com/pub/ASUS/mb/Soc…e_EM_V2_WEB.pdf
SuperMicro one - https://www.supermicro.com/manuals/other…MOD_Windows.pdf

@Lost_N_BIOS , yeah, bifurcation 4x4. All setup guides absolutely useless for me, because in them all disks after turning on VMD are completely detected, unlike my situation. All disks work, but for some reason VMD sees only one disk on the card.
-------------------------

UPD:
VMD does not see specific disks, but specific ports on Asus cards. VMD sees port number 4 on PCI Slot 5 and port number 1 on PCI Slot 2.
If i remove disks from these ports, VMD does not see anything.

And your sure bifurcation is set to 4x4x4x4x (not 4x4), for whichever PCIE slots you are testing?
Are you using latest motherboard BIOS? What is the RST EFI/ROM versions in that BIOS? Link me to BIOS you are using if you’re not sure

@Lost_N_BIOS , bifurcation 4x4x4x4 (4 lines x4), VROC version 6.2, latest BIOS (3.3).
At the moment, Asus tech support answered me. They say that for the card to work properly, a “responsive function” is required in the motherboard BIOS.
As they pointed out, their motherboards have this “responsive function”. @Lost_N_BIOS , do you know someone who could bring this feature into the my motherboard’s BIOS? (if Asus and Supermicro refuse to help me) I’ll pay for the job :slight_smile:

goddamit, card and motherboard say “VROC Ready” wtf they can’t work together? What is the point in this VROC technology then?

the problem was solved. According to Supermicro technical support, bifurcation for third-party boards is prohibited in their BIOS. They threw me the beta version of the BIOS, it is fixed in it. I post the bios, maybe it will come in handy for someone. Please note that you are acting at your own risk - this is beta and has not been tested by Supermicro! link



As I was reading this thread I was wondering if there was a vendor compatibility lockout. VROC is pretty amazing but I really only saw insane sequential and 4KQ1T1 performance when I combined smallest stripe size, Optane, OCed RAM and CPU and mitigations disabled.



I messed around with different stripe size, BIOS, clock speeds, drivers, mitigations on and off and performance was all over the place. Sometimes 4KQ1T1 was as low as 25 megs. Things seem dialed in now.

I use the Asus Apex X299 board so it had 0 issues with the Asus hyper 16X V2. The documentation also indicates that adding a 2nd card would be very easy but I can’t think of why I would need one.